Fehlermeldung: Frame size 768x56...

  • Jedesmal wenn ich eine DVD durch den RB schicken will erscheint die Fehlermeldung von CCE :
    Frame size 768x56 is not supportet. Supported frame size is up to 720x576.
    Dabei liegt die DVD in dem Format vor.
    Der Fehler taucht bei RB 2.70 + 2.69 auf.
    In folgendem Tread hatte jemand ein ähnliches Problem, hat aber nicht zurückgeschrieben.
    http://forum.gleitz.info/showthread.php?t=18457
    Unten die Fehlermeldung und die avs im Player


    Danke


    Bernhard

    Dateien

    • Fehler.bmp

      (58,87 kB, 151 Mal heruntergeladen, zuletzt: )
    • Avis..bmp

      (132,39 kB, 109 Mal heruntergeladen, zuletzt: )
  • Zitat

    Q14.2: Why do I get a "Frame size XXXxYYY is not supported. Supported frame size is up to 720x576" error message or only a 10 seconds clip when I try to load an AVISynth script?


    This indicates that there is an error in your AVISynth script. In this case AVISynth outputs not actual video but just a short clip displaying an error message. Depending on the length of the error message, the clip may also have a "non-standard" resolution like 852x52 and that's what CCE complains about. Open the script in Windows Media Player to see the error message and fix your script. A good starting point for fixing script errors is the AVISynth Troubleshooting Guide.


    quelle: http://forum.doom9.org/showthread.php?s=&threadid=53770


    AVISynth Troubleshooting Guide =>> http://www.avisynth.org/index.php?page=Troubleshooting



    +++++++++


    ich denke du solltst avisynth (2.55) neu installieren und sicherstellen, dass alle einstellungen im rebuilder (bzw dessen setup) korrekt sind


    zusätzlich könntest du auch erstmal mit rejig statt cce testen oder quenc/freenc, um zu sehen, was über diese routinen geschehen würde



    #############



    quelle: http://forums.afterdawn.com/thread_view.cfm/97052

  • Danke für die Antworten. Komm gerade aus der Arbeit, werd das mal durchprobieren, und mich wieder melden. Wird aber leider etwas dauern, den ich hab die Woche leider teildienst!!


    Grüße


    Bernhard

  • Hab Avisynth gestern neu installiert, und probiert die dll´s statt im Plugin Ordner im RB zu laden. Ging aber nicht. Jetzt hab ich sie wieder ins Pluginverzeichnis kopiert, und im RB trotzdem angegeben, und jetzt funktioniert es. Hab zwar keine Ahnung warum, den eigentlich hat sich nichts geändert.


    Danke für eure Hilfe :)


    Bernhard


    P.s.: Hat vieleicht jemand einen Plan warum???

  • Das PlugIn-Verzeichnis ist in der Registry eingetragen. Wenn im Script die DLL ohne Pfad angegeben wird, wird die aus dem PlugIn-Verzeichnis genommen. Unter WinXP wird wahrscheinlich noch im %Windows%\System32-Verzeichnis gesucht.

  • Gestern hab ich den Film durch den Rebuilder geschickt, und das Problem war behoben. Ich hab die Einstellung One Click Modus, und shutdown at one-click completion aktiviert gehabt um mich schlafen legen zu können. Hab natürlich gewartet und mein erstes Problem war behoben(?). (Danach kam noch eine Fehlermeldung(siehe unten), die sich mit "Spezial Error Processing" behoben ließ.
    Heute drehe ich den PC auf und will sehen, ob es geklappt hat.
    Die Ausgabedatei ist 2,2 Gb gross, und "das Video" besteht aus der Ursprünglichen Avisynth Fehlermeldung(kann leider keinen Scennshot machen), nur ist sie gestreckt und in die höhe gezerrt.
    Ausserdem fehlen einige Dateien(Vergleich unten)
    Was mache ich falsch?? Ich hab echt keine Ahnung mehr, da ich mich noch nie mit Avisynth auseinandergesetzt hab. Habt ihr irgend eine Idee oder Lösung? Tut mir leid


    Bernhard

  • Mann, mann, mann, Du kannst es einem aber auch wirklich schwer machen... :rolleyes:
    Das erste was hier jeder erwartet ist, dass man zumindest die "Wichtig"-Beiträge liest, die am Anfang jedes Unterforums stehen, da hättest Du den 768x-Fehler auch schon gefunden.
    Wenn Du hier was anhängst, dann bitte nicht als bmp, sondern als jpg oder png.
    Zu Deinem 767kb Buntesdateiexplorerbildchen: da fehlt gar nichts, die Dateien sind einfach komprimiert worden, deshalb sind halt nicht mehr so viele da... ;)
    Bei Deinem Hauptfilm (VTS01) ist natürlich schon was schief gelaufen, dazu brauchen wir aber erstmal das Script.
    Du öffnest jetzt also in Deinem D2VAVS Arbeitsverzeichnis das der Rebuilder angelegt eine der V01...avs-Dateien und zwar mit einem Editor und postest bitte den Inhalt.

    Cu Rippraff

  • Nein ich schneide nicht, und die Versionsdatei hab ich schonmal vor Tagen geöffnet(Steht die Version, eine url und noch was).


    Ich werd ab jetzt als jpg anhängen. (Ich hab mich eh schon gefragt was da schief gegangen ist)


    Zitat

    Q11. Wenn ich DVD-RB starte funktioniert das "Prepare" ohne Fehler, wenn ich aber das "Encode" starte dann bekomme ich diese Fehlermeldung:
    "CCE SP Trial version: Frame size 948x56 is not supported. Supported frame size is up to 720x576."
    Das sieht nach einen AviSynth Script Fehler aus. Solche Meldungen entstehen, wenn AviSynth eine Fehlermeldung als Video generiert.
    Also: Video anschauen und den genannten Fehler beseitigen, oder die darin lesbare Fehlermeldung hier im Forum zitieren!
    Es sollte mindestens AViSynth ab Version 2.5.0 verwendet werden.


    Hab ich ja auch gelesen und befolgt


    Und das Script:


    #------------------
    # AVS File Created by DVD Rebuilder
    # VOBID:01, CELLID:01
    #------------------
    LoadPlugin("D:\Dokumente und Einstellungen\asdf\Desktop\DVD-RBv070PR\MPEG2DEC.dll")
    mpeg2source("C:\DVDTEMP\WORKINGPATH\D2VAVS\V01.D2V",idct=7)
    trim(0,670)
    ConvertToYUY2()
    AudioDub(BlankClip())


    War gleich die erste, aber das seht ihr glaub ich sowieso.


    Danke


    Bernhard

  • Zitat von Börnie

    Nein ich schneide nicht, und die Versionsdatei hab ich schonmal vor Tagen geöffnet(Steht die Version, eine url und noch was).


    Und wieso teilst Du uns die Versionsnr. nicht mit?
    Es haben doch schon einige Leute versucht Dir klar zu machen, dass es an Avisynth und den dazugehörigen Plugins liegt.
    Gerade bei den Plugins ist es wichtig, dass diese auch zu der dazugehörigen Avisynthversion passen.

    Zitat

    LoadPlugin("D:\Dokumente und Einstellungen\asdf\Desktop\DVD-RBv070PR\MPEG2DEC.dll")


    Da ham wir's wahrscheinlich schon, Du solltest die MPEG2DEC3DG.DLL haben, wie oben auch schon steht.
    Ansonsten sieht das Skript völlig okay aus, falls Dich das tröstet. ;)

    Cu Rippraff

  • Die MPEG2DEC.dll könnte möglicherweise für AviSynth 2.0x gedacht sein - mit AviSynth 2.5x würde die nicht funktionieren. Statt dessen sollte DVD-ReBuilder besser eine MPEG2Dec3dg.dll oder DGDecode.dll verwenden.


    Aber genau werden wir das hoffentlich wissen, wenn du uns schreibst, welche Fehlermeldung AviSynth als Video generiert. Dazu am einfachsten die *.avs-Datei in VirtualDubMod als Videoquelle öffnen, das Bild mit [Umsch]+[1] (also "!") und im Dateityp PNG speichern, und an deine nächste Antwort anhängen.

  • Jippie, nur einmal im Leben schneller als LigH sein! :ja:
    Die Fehlermeldung steht im Anhang des ersten Posts, Moment ich schau nochmal in PaintShopPro :rolleyes: mpeg2source does not have a named argument "idct" und dann eben die Idct=7-Nr.

    Cu Rippraff

  • Kein iDCT=7? Dann ist es klar: MPEG2Dec ist zwar die Version, die zur aktuell installierten AviSynth-Version passt (Achtung: Es gibt tatsächlich eine MPEG2Dec.dll für AviSynth 2.5!), aber iDCTs werden da wohl nur zwischen 0 (bedeutet: wie in der *.d2v) und (ungefähr) 3 unterstützt.

  • Danke für die Antworten.


    Entschuldigt ich dachte das hab ich gleich im ersten post geschrieben. Verwende Avisynth 2.55


    Also soll ich die .dll gegen eine MPEG2Dec3dg.dll tauschen !?!?!?!


    Zitat

    Kein iDCT=7? Dann ist es klar: MPEG2Dec ist zwar die Version, die zur aktuell installierten AviSynth-Version passt (Achtung: Es gibt tatsächlich eine MPEG2Dec.dll für AviSynth 2.5!), aber iDCTs werden da wohl nur zwischen 0 (bedeutet: wie in der *.d2v) und (ungefähr) 3 unterstützt.


    Kannst Du mir bitte erklären was damit gemeint ist?? (Bitte nicht schlagen!!) Was sind iDCTs? (Ein Link wäre ausreichend) :ratlos:

  • "iDCT" = "inverse Diskrete Cosinus-Transformation": Die Technik, die aus dem (nach JPEG/MPEG-Standard) in 8x8-Pixel-Blöcken frequenzcodierten Material wieder ein sichtbares Bild macht. Dabei gibt es


    - eine mathematisch exakte Rechenvorschrift ("Referenz"): Die ist aber unheimlich langsam.
    - mehrere "Abkürzungen", die evtl. nicht ganz so genau sind, aber viel schneller!


    Manche dieser "Abkürzungen" in der Rechenvorschrift sind extrem auf die Möglichkeiten aktueller Prozessoren optimiert, in einem Rechenschritt gleich mehrere Zahlenwerte zu berechnen (SIMD = Single Instruction, Multiple Data), wie MMX, SSE, SSE2, 3Dnow! und Varianten.


    Erst durch diese Abkürzungen und Gleichzeitig-Berechnungen schafft es ein PC überhaupt, MPEG2-Video schnell genug abzuspielen, um als Software-DVD-Player verwendet werden zu können.


    Man hat mittlerweile Rechenvorschriften gefunden, die sowohl sehr schnell, als auch sehr exakt sind. Die wurden aber erst in den aktuelleren Versionen der Decoder-Plugins eingebaut. Der iDCT mit der Nummer 2 sollte auf so gut wie jedem aktuellen PC laufen, der braucht nur MMX.


    Auf der doom9-Webseite kann man einen iDCT-Vergleich finden, der "beweist": Man sieht's nicht wirklich, ob eine iDCT-Funktion leichte Ungenauigkeiten hat, da die normalerweise so verteilt sind, dass sie sich im Durchschnitt ausgleichen. Und da GOPs auf DVD maximal 15 Frames haben sollten, und maximal 2 B-Frames zwischen I- und P-Frames, können sich die Verluste gar nicht so weit ansammeln, dass sie auffällig werden.