StaxRip Encoding-Frontend (Diskussion)

  • Gibt wieder eine neue beta:


    1.1.1.2 beta


    • Fixed bug AviSynth plugins setup failing on 64bit systems
    • Updated x264 to version 1179
    • Updated mkvtoolnix to version 2.9.7
    • Updates x264 features reflecting recent x264 changes


    hi


    hat sich da die ordner-struktur geändert?


    zuvor


    staxrip/settings/applikation


    und jetzt


    staxrip/applikation


    gruss


    p.s:


    habe auch probleme mit den templates, ich kann sie zwar auswaehlen aber es wird nichts umgestellt :-(

  • Habe auch Probleme Staxrip 1.1.1.2beta zum laufen zu kriegen.


    Habe das letzte mal vor ca. 16 Monaten Staxrip 1.0.0.3 nach langem hin und her (Einstellungen) endlich für meine Zwecke zum laufen gebracht. Damals hat ja die Installation ziemlich gut "automatisch" funktioniert.


    Jetzt, nach 16 Monaten und einer zwischenzeitlichen Neuinstallation meines Rechners wollte ich den Zustand von damals wieder erreichen (hatte alle Programme von damals noch, ausser jenen, die Staxrip automatisch gedownloadet hat). Habe zuerst mit Version 1.1.0.1 probiert, aber da geht ja das automatische installieren der Tools nicht mehr. Hier im Forum hab ich dann von 1.1.1.2beta erfahren, bei der die Tools mitgeliefert werden (gezipt). Das hat dem Anschein nach funktioniert, habe keine Meldungen von f ehlenden Tools mehr.


    Nur leider kommt sobald ich das Sourcefile ausgewählt habe die Meldung "Can't register the YV12 Decoder..." und ein Tip, man solle evt. die Anwendung als Admin ausführen, was aber auch nix bringt.


    Ich benutzte Windows XP SP2


    An was kann das liegen?

  • Es liegt daran das StaxRip Admin Rechte nicht erkennt und deshalb den YV12 Dekoder nicht registrieren kann. Denke das ist ein Bug in .NET, siehe hier:


    http://forum.doom9.org/showthread.php?p=1304382#post1304382


    Entweder man verwendet das Bugfix oder man installiert einen Dekoder manuell. XviD hat ein YV12 Dekoder, registriert ihn aber nicht, man müsste die Registry von Hand editieren oder das Setup von 1.1.1.2 ausführen welches XviD als YV12 Dekoder registriert, das Setup ist im External Applications Dialog zu finden. Man kann auch ffdshow benutzen: VFW configuration -> Codecs -> Raw Video -> YV12


    Ist eintweder XviD oder ffdshow registriert, dann sollte die Meldung verschwinden.

  • @ Deinorius
    .. ja hab ich (K-Lite Mega Pack - 4.9.5, da sollte der drin sein ;))



    @ Stax
    Habe mich für diese Variante entschieden:


    ... Denke das ist ein Bug in .NET, siehe hier:


    http://forum.doom9.org/showthread.php?p=1304382#post1304382


    Dieser Fix ist zwar StaxRip 1.1.1.1beta und bringt wieder andere Fehlermeldungen. Wenn ich diese dann aber ignoriere und danach wieder StaxRip 1.1.1.2beta starte ist die Y12-Fehlermeldung weg. Mal sehen ob jetzt alles ander (noch) geht .


    Vielen Dank für die prompte Antwort.

  • Moin,


    ich hab noch die "vor" Version, also quasi die Stable (1.1.1.0) von StaxRip, nicht die Beta. Allerdings hab ich den aktuellen x264 installiert.
    Ist da jetzt irgendwie ein Qualitätsunterschied zu erwarten wenn ich nicht die Beta Version nutze ?
    Ich meine nur so Sachen wie z.B. die Einstellung des Blocking Filters. Ich hab das Gefühl egal ob ich den auf -2 -1 oder auf +2 +2 stelle es ändert sich nichts. Ist da im Codec was geändert worden ? (das gabs vor einiger Zeit doch schonmal mit dem deblock oder dem AQ ?!?)

  • hab da nen kleines nerviges problem. Das Drag & Drop bei meinem staxrip funktioniert nicht mehr richtig. Die erste datei geht noch, aber wenn eine datei geöffnet in staxrip ist kann ich keine zum encoden vorbereiten. muss es entweder komplett neustarten das prog oder halt manuell suchen.


    Ich nutze Staxrip 1.1.1.0. habe allerdings vor ein paar tagen mal versucht 1.1.1.2b zu verwenden, aber als die version meine alten profile nicht angenommen hat, habe ich wieder den ordner von 1.1.10 an seine alte stelle getan und wieder genutzt.


    kann es sein das eine neuere version eines programms diese funktion verhindert?



    ich encode immer recht viel und immer die dateien manuell suchen und einfügen ist mühsam und dauert zu lange.

  • naja wenn ich was encoden will schieb ich die avi/vob oder mpg datei einfach in staxrip rein und er muxxt das alles, danach stelle ich filter und so ein und füge es zu den jobs hinzu. danach sieb ich immer das nächste video rein wonach staxrip dies dann muxxt.


    nur dieses erneute drag & drop geht nicht mehr. der mauszeiger zeigts halt auch an.


    werd heute mal staxrip 1.1.1.0 mal neu machen mit allen programm versionen die es will. vielleicht gehts dann.

  • hab mal nen alte sichterheits kpoie des kompletten staxrip ordner verwendet. das fallen lassen geht immer noch nur das eine mal. sind also keine stax programme die das machen.


    könnte .Net verantwortlich sein?

  • Du könntest versuchen ob andere .NET Programme auch Drag & Drop Probleme haben, würde aber nicht zwingend bedeuten das .NET beschädigt ist sondern z.B. das es im System eine Veränderung gibt mit der .NET nicht zurechtkommt, kenne sowas schon. Für Drag & Drop ist die Shell verantwortlich welche wie alle komplexeren/neueren Windows APIs über COM programmiert wird. Was ich z.B. feststellte ist das wenn man eine Programm installiert welche eine bestimmte clipboard API zwecks history verwendet, dann funktionieren in .NET Programmen clipboard Funktionen nicht mehr gescheit, denke clipboard ist auch Shell/COM, solche Probleme sind auch für Drag & Drop denkbar, z.B. gibt es eine shell extension API für Drag & Drop. Auf meiner Website gibt es ein Programm 'File Type Registry Viewer', damit kann man sehr einfach schaun welche Shell Erweiterungen für welche Dateitypen installiert sind und dann am ausgewählten Schlüssel Regedit starten, umbenennen führt dann zur Deaktivierung. Wenn man nicht gerade Erfahrung mit Shell Programmierung hat, kann es schwierig sein mit sowas fertig zu werden.

  • so hab mal alle SP´s und sprachpakete deinstalliert und nur das benötigte 3.5 instaliert. was soll ich sagen es ghet wieder.


    war bestimmt was beschädigt oder so. werde jetzt nach und nach die anderen versionen wieder installieren. dann werd ich mich auch mal an die neste beta machen^^ aber ne möglichkeit die alten filter profile aus 1.1.1.0 der beta zu importioeren geht nicht oder?




    könnte man in staxrip eigendlich ne funktion mit einfügen das automatisch die kapitel einer vob mit eingebunden werden? Nutze momentan noch chapterXtractor und füge die manuell ein.

  • Zitat


    aber ne möglichkeit die alten filter profile aus 1.1.1.0 der beta zu importioeren geht nicht oder?


    Für Filter Profile gab es noch nie eine Import/Export Funktion.


    Zitat


    könnte man in staxrip eigendlich ne funktion mit einfügen das automatisch die kapitel einer vob mit eingebunden werden? Nutze momentan noch chapterXtractor und füge die manuell ein.


    Müsste man versuchen, hab leider selbst an Untertitel und Kapitel kein Interesse und arbeite an solchen Dingen nur noch wenn ich unterstützt werde.

  • 1.1.1.3 beta


    • Vista CommandLink buttons enabled, looks worse on XP now...
    • Updated x264 to 1184 and added new AQ mode Auto-variance
    • Added reset button in external applications dialog to reset the location
    • Added checkboxes to setup dialog to control what to setup
    • Added context menu in x264 dialog to copy the command line
    • Fixed bug user privileges wrong detected leading to fail registering YV12 decoder
    • Fixed setup issues on Win XP
  • mit ´importioeren mein ich, das ich die setting.bin einfach ins neue staxrip verzeichnis kopiere und somit alle alten einstellungen auch im neuen sind.


    so ne export geschichte währe aber cool^^ muss meist mühsam alle profile einzelnt neu erstellen.

  • Hallo,


    ich hab mir mal die neue 1.1.1.3 beta installiert und hätte da mal ne Frage zu der Tune Option des x264 Profiles.


    Für was Fim und Animation gut sein soll kann ich mir denken, aber was Grain, Psnr, Ssim und Touhou hab ich keine Ahnung.
    Kann mir bitte jemand kurz erklären was diese bewirken?


    Und dann gibt es noch die Option "Slow Firstpass". Macht die Irgendeinen Sinn im Quality-Mode?


    MfG
    Ratbert

  • Ich hab jetzt auch den Schritt zu 1.1.1.3 gemacht. Allerdings hab ich jetzt das Problem das StaxRip die zu encodierenden *.mkv Files nicht mehr demuxed. Es wird nur das Video encodiert. Audio wird nicht angezeigt. Soll das so ?


    Hab nochwas festgestellt. Die produzierten Files (ohne Ton) ruckeln. So als ob StaxRip ein 23,976fps file in 25fps wandelt. Eigenartig. Das lief mit meiner 1.1.1.0 alles besser. Hätt ich die mal nicht gelöscht ! jetzt läuft die auch nicht mehr.