StaxRip Encoding-Frontend (Diskussion)

  • Folgender Schönheitsfehler ist mir aufgefallen:


    Wenn man einen Job suspended und nach längerer Zeit (z.B. 2h) wiederaufnimmt werden unsinnige eta Zeiten angezeigt. Anscheinend berechnet er aus der ursprünglichen Startzeit und den bisher encodeten frames die fps und daraus die Endzeit (eta). Wünschenwert wäre die augenblickliche Restzeit , d.h. ohne Berücksichtigung der Pausenzeit.


    Lupissimo

  • Habe gestern Abend vor dem Schlafen gehen mal die neueste Testversion 1.1.5.1.7z ausprobiert:


    Von x264/mkv in XviD/avi .


    Nachdem Start scheint alles normal gelaufen zu sein, EAc macht seine Arbeit die DTS zu wandeln und beim First Pass auch alles noch okay, aber beim Umspringen zum Second Pass brach Stax Rip ab mit einer Meldung die wie folgt lautete:


    The Function was set on Stream Source !!!


    Leider gerade kein Dump bzw Logfile erstellt, lasse das nochmal laufen und liefer das nach.


    Vielleicht weiss ja einer was das ist.


    LG


    ALan

  • Hi,


    ich habe mir die neue StaxRip Version installiert, bei der alten konnte ich immer meine h264 Dateien in einen mp4 Container packen.


    Bei der neuen Version gibt es mp4 nur für iPod/iPhone und für console/handheld.
    Kann man den alten MP4 Container nicht mehr nehmen?


    (StaxRip 1.1.3.0)


    MfG
    jim936


  • klaro! ich nehme divx plus (x264) und nebendran mp4 als container (console/handheld) wählen. denke nicht, daß sich am container-format irgendwas gross geändert haben soll. ich kann ihn problemlos verwenden (auch am pc).

  • Stax


    Auch ich hätte eine Frage, da mir in einen anderen Thread


    http://forum.gleitz.info/showthread.php?t=41980&page=3


    geraten wurde mich direkt an Dich zu wenden:


    Ich habe es anscheinend endlich geschafft TempGaussMC_beta1mod.avsi ans laufen zu bekommen (wie kannst Du Dir vielleicht in oben genannten Beitrag anschauen) - habe immer noch das GEfühl als wenn ich dort doch was falsch gemacht habe...


    Mein eigentliches Problem jetzt ist, dass er mit TempGaussMC_beta1mod für einen TestClip, für das StaxRip sonst eine Minute gebraucht hat, jetzt 30 braucht. Kann das richtig sein?


    Besten dank...


    Lapje

  • ich nehme divx plus (x264)


    DivX Plus hat so viel mit x264 zu tun wie ein Smart mit einem Testarossa.


    Beide sind zwar Encoder für MPEG4-AVC (H.264), aber in völlig verschiedenen Leistungsklassen.


    H.264 ist der theoretische Standard, x264 ist eine praktische Implementation von vielen. Und nicht von DivX Networks.

  • Auch noch ne kleine Zwischenfrage von mir.
    Warum steht bei Sourceforge jetzt was von Staxip final?
    Ist das nun mal ne endgültige final? Wenn ja warum? Was ist an dieser Version (1.1.3) anders??

  • Kleiner feature request:
    - Option um Audio&Video Profile beim Export als .xml zu speichern.


    Wenn das gemeint ist, wie ich es verstehe, schließe ich mich dem voll an! Welches dann auch einen Import benötigen würde


    Ich habe hunderte von Serien die ich aufnehme (DVB-S) und die bekommen alle unterschiedliche Eigenschaften.


    Mit den Templates klappt das ja nicht so wie es eigentlich sein soll, weil ja immer nur das ganze Projekt gespeichert wird. Default Templates ohne File anzulegen ist ziemlich blöd und fast unmöglich.
    Habe auch schon versucht das "rip" file dahingehend zu bearbeiten was zur Folge hat, daß ich das Template damit wohl zerstöre.
    Als VDUB/Gknot verwöhnter, vermisse ich die Funktion sehr.


    Oder ich mache was falsch?

  • Hallo alle miteinander,


    ich habe erst vor wenigen Tagen begonnen mich mit dem Thema zu beschäftigen. Nach ein wenig stöbern in den Foren und im 'Encoderwissen' habe ich mich dieses Wochenende an meine ersten Versuche gewagt.


    Zunächst einmal ein Lob. StaxRip macht es einem Neuling tatsächlich einfach. Für die Bedienung ist zunächst kein Atomphysikstudium notwendig ;-).


    Nun zu meinem Problem. Ich wollte eine meiner BluRays auf Festplatte bannen, um sie zu meiner PS3 zu streamen. Im ersten Versuch habe ich die Standardeinstellungen des Profiles PS3 verwendet. Nach einigen Stunden Laufzeit war ich doch sehr überrascht, dass von der 38GB Datei gerade mal gute 3GB übrig geblieben waren. Allerdings war ich mit dem Ergebnis nicht ganz zufrieden, was bei einer solchen Kompression wohl auch nicht zu erwarten war ;-). Insgesamt war das Bild insbesondere in den dunklen Szenen zu milchig und in den hellen nicht annähernde so strahlend, wie das Original, auch fielen einige Details dem Vorgang zum Opfer ;-).


    Danach habe ich dann mit den Einstellungen im 'Config Codec' Bereich experimentiert. Ich habe den CRF-Wert zunächst auf 20 und in einem weiteren Versuch dann auf 18 und den Parameter 'Tune' auf Film gesetzt.


    Die daraus entstandenen Ergebnisse waren 8 und 12GB groß.
    Wie zu erwarten nahm die Detailgenauigkeit zu, allerdings blieb das Bild milchig.


    Die Suche im Forum nach 'Schwarzwert', 'Tiefenschwärze' oder 'milchig' brachte leider kein befriedigendes Ergebnis.


    Hier mal der Vergleich (mit CRF 18; rechts das Original)
    http://cid-a11656f02ae4ad4c.sk…x/milchig/schwarzwert.jpg


    Wäre nett, wenn jemand sagen könnte, ob das milchige Ergebnis dem Prozess geschuldet ist, dann kann ich nämlich meine Versuche einstellen und bleibe beim Scheibeneinlegen ;-), oder ob ich an einer anderen Schraube drehen muss.


    Grüße
    Bonbod

  • hab da mal ne frage: hab zufällig gesehen, daß ich ja eine nvidia grafikkarte habe und da angeblich die dgavcindex-probleme mit dgavcdecnv nicht bestehen sollen habe ich mir das geholt. habe auch schon gegooglet wie blöd aber noch nichts gefunden, wie man das in staxrip einbinden kann, weil durch blosses umbenennen stürzt staxrip ab! ein tipp oder link würde mir sehr weiterhelfen! danke im voraus!

  • Hab auch noch mal ne Frage und zwar was die Resizefilter angeht, speziell downsizing von HD-Quellen.
    Hab bisher eigentlich immer auf Spline36 gesetzt da er auch in anderen Foren und hier empfohlen wird. Dann heißt es mal wieder Lanczos ist für downsizing ausnahmslos der beste.
    Was benutzt ihr so? Was empfiehlt sich??

  • Hi


    bin ich blind oder gibt es die möglichkeit nicht: ich hab von einer Quelle Forced Subs extrahiert (Zeitungstitel auf Deutsch usw.) - die möchte ich permanent eingeblendet haben - aber nicht einbrennen! ;) ... mit mkvtoolnix gehts - mit staxrip seh ich da keine Option. Muss ich also nach der MKV erstellung noch mal mkvtoolnix anschmeißen?


    Ansonsten: Verbesserungsvorschlag ;) bei den UTs die möglichkeit einen als Forced zu markieren.


    Gruß

  • Hi, ich bin seit langem begeisterter Staxripper :) aber habe seit einiger Zeit ziemlich kritisches Problem, das immer mehr um sich greift. Es muß seit einer Version in diesem Jahr so sein.
    Ich mache im Grunde nichts exotisches: Ich nehme normal DVB-MPG Aufnahmen auf. Diese haben ja üblicherweise hin und wieder empfangsbedingt kleine Aussetzer. Bisher konnte staxrip diese immer wunderbar demuxen, die "Löcher" auffüllen und wunderbar als h264 mit mp3-Sound im mkv-Container encoden.
    Nun ist es immer häufiger so, daß der Sound im Laufe der Datei asynchron wird (über 1 Stunde z.B. ca. 4 Sekunden hinterher).
    Ich habe es mit der (default-mäßig deaktivierten) ProjectX-Option versucht und ohne. Aber beides holf nicht.
    Dann dachte ich, daß vielleicht das Zusammenspiel mit BeSweet nicht mehr richtig klappt, aber auch wenn ich eines der neuen Presets nehme (bei denen man übrigens leider kein Mono-MP3 mehr einstellen kann?), klappts nicht.
    Fällt dazu jmd. etwas ein? :(

  • Hi, ich bin seit langem begeisterter Staxripper :) aber habe seit einiger Zeit ziemlich kritisches Problem, das immer mehr um sich greift. Es muß seit einer Version in diesem Jahr so sein.
    Ich mache im Grunde nichts exotisches: Ich nehme normal DVB-MPG Aufnahmen auf. Diese haben ja üblicherweise hin und wieder empfangsbedingt kleine Aussetzer. Bisher konnte staxrip diese immer wunderbar demuxen, die "Löcher" auffüllen und wunderbar als h264 mit mp3-Sound im mkv-Container encoden.
    Nun ist es immer häufiger so, daß der Sound im Laufe der Datei asynchron wird (über 1 Stunde z.B. ca. 4 Sekunden hinterher).
    Ich habe es mit der (default-mäßig deaktivierten) ProjectX-Option versucht und ohne. Aber beides holf nicht.
    Dann dachte ich, daß vielleicht das Zusammenspiel mit BeSweet nicht mehr richtig klappt, aber auch wenn ich eines der neuen Presets nehme (bei denen man übrigens leider kein Mono-MP3 mehr einstellen kann?), klappts nicht.
    Fällt dazu jmd. etwas ein? :(



    hi


    welche version benutzt du? bzw. schneidest du mit Staxrip oder extern mit projextx?


  • hi


    weclhe version nutzt du?


    bei der aktuellen 1.1.5.2 und eigentlich auch bei den aelteren einfach auf "Config Container gehen"


    gruss

  • @ bonbod:


    :welcome:


    Schwer zu sagen, welche Ursache deine Abweichungen haben; ich glaube, bei dir sind die Unterschiede noch nicht mal so stark, wie man es von einer Differenz zwischen "PC-Scale" (0-255) und "TV-Scale" (16-235) erwarten würde. Blieben dann also höchstens noch Reduktionseffekte durch adaptive Quantisierung und MBTree -- hierbei hat sich in letzter Zeit aber einiges verändert, also auf jeden Fall noch mal updaten. Und dann schau noch mal hier rein, welche Änderungen kürzlich passiert sind und welche Optionen die Qualität in dunklen und wenig strukturierten Bereichen beeinflussen könnten.

  • Ich mache im Grunde nichts exotisches: Ich nehme normal DVB-MPG Aufnahmen auf. Diese haben ja üblicherweise hin und wieder empfangsbedingt kleine Aussetzer.


    Wenn die Anlage richtig justiert ist eher sehr selten (Unwetter) bis garnicht.


    Zitat

    Nun ist es immer häufiger so, daß der Sound im Laufe der Datei asynchron wird (über 1 Stunde z.B. ca. 4 Sekunden hinterher).


    Ich demuxe meine DVB-S Aufnahmen (Vantage HD 8000S) erst mit ProjectX um sie dann mit Mpeg2Schnitt framegenau zu schneiden. Bis hierher ist der stream IMMER synchron. Erst dann codiere ich den geschnittenen Film mit StaxRip. Meist lasse ich aber MPEG MPEG sein.


    Gruß

  • hi


    welche version benutzt du? bzw. schneidest du mit Staxrip oder extern mit projextx?


    Momentan habe ich 1.1.4.8 beta, aber hatte es wie gesagt auch in Versionen davor schon. Ich schneide in staxrip, das hatte davor auch immer super geklappt, auch wenn's Empfangs-Aussetzer gab.