StaxRip Encoding-Frontend (Diskussion)

  • Hi,


    ich hab die Version 1.1.5.2 am laufen und bekomme beim Encoden von BluRay Material bei einigen Jobs nach 100% encoding ne Fehlermeldung mit Abbruch. Irgendwas mit x264 encoding failure. Den genauen Wortlaut reiche ich nach. Auf jedenfall muxt StaxRip das eigentlich fertige Videofile und das Audiofile nicht zusammen. Ich muß dann auch manuell den Auftrag löschen (wurde ja nicht fertiggestellt und ist somit noch drin bei den Jobs) und den nächsten starten. Ist das ein bekannter Bug oder nur bei mir so. Ich werde mal schauen ob das nur bei h.264 oder auch bei VC1 so ist.


    greetz

  • Momentan habe ich 1.1.4.8 beta, aber hatte es wie gesagt auch in Versionen davor schon. Ich schneide in staxrip, das hatte davor auch immer super geklappt, auch wenn's Empfangs-Aussetzer gab.



    schau mal unter "Tools/Settings" und da dann "ProjectX zum Demuxen" auswaehlen, vielleicht hilft das ja


    gruss

  • Wie sieht es nun eigentlich mit dem Feature aus, das man ne komplette DVD-Struktur laden kann, also mit ifo usw...?
    Bisher gehen ja nur die vobs was ich ziemlich unpraktisch finde. Deshalb demuxe ich vorher immer alles fein säuberlich mit PGC-demux und importiere dann die m2v-Datei.
    AutoGK konnte das damals also das ifo direkt laden, und dann hat man halt den Hauptfilm angewählt oder was man halt haben wollte!
    Könnte man das nicht implementieren??

  • Natürlich könnte man. Ist aber alles andere als trivial. Und da stax angekündigt hat, eine längere Codingpause einzulegen, wird’s das wahrscheinlich so oder so in absehbarer Zeit nicht geben.

    Brother John
    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
    DVD nach MPEG-4 klappt nicht? Verzweifelt? Auf zum Encodingwissen!

  • Hauptfilm oder was du eben gerade brauchst auf die Platte ziehen und dann erst an StaxRip verfüttern. Ob du das mit PgcDemux oder einem anderen Ripper machst und ob du alles demuxt oder die VOBs lässt, ist nicht so entscheidend.

    Brother John
    ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
    DVD nach MPEG-4 klappt nicht? Verzweifelt? Auf zum Encodingwissen!

  • Wie siehts aus ...
    Ich arbeite immer noch mit der 1.1.2.1, da sie bisher absolut fehlerfrei bei mir arbeitet.
    Da ich jetzt aber gern mal x264 probieren wollte, würde ich gern die aktuellste Version ausprobieren. Kann ich die inzwischen ohne Problem parallel zur alten Version installieren oder zerhauts mir dann wieder alle Encodingprofile und Templates?

  • Wie siehts aus ...
    Ich arbeite immer noch mit der 1.1.2.1, da sie bisher absolut fehlerfrei bei mir arbeitet.
    Da ich jetzt aber gern mal x264 probieren wollte, würde ich gern die aktuellste Version ausprobieren. Kann ich die inzwischen ohne Problem parallel zur alten Version installieren oder zerhauts mir dann wieder alle Encodingprofile und Templates?


    Schau mal bei Dokumente und Einstellungen/All Users/Anwendungsdaten. Da ist ein StaxRip-Ordner drinn, in dem such auch die Templates befinden. Die solltest Du dann eh mal sichern. Normalerweise geht das mit dem Parallelbetrieb - bei mir zumindest, und StaxRip greift bei mir auch auf die alten Templates zu. Aber wenn StaxRip doch einen neuen Ordner erstellen sollte, kannst Du die Templates ja einfach da rein kopieren...

  • Hi


    ich hab Probleme mit nem h264-Stream von ArteHD (IPTV).


    Ich nehme die Sendung mit VLC auf.
    Das TS schneide ich dann mit h264ts-Cutter
    Dann mit txmuxer demuxxen


    => jetzt in StaxRip das .264-File reinladen. Noch ohne Einstellungen sag ich nur 2pass-Film-Slow oder Medium (ist egal) => Compressibility-Check


    Jetzt kommt eine Fehlermeldung:

    Zitat


    avs [info]: 1280x704p 0:0 @ 50/1 fps (cfr)
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 Cache64
    x264 [info]: profile High, level 4.0


    was sagt mir das? ;) und wie mache ich den Check nun? :(


    Gruß


    Edit:
    Das tsmuxeR-Log sieht so aus:

  • hi


    wie kann man das dgindex fenster wieder einblenden wenn er das source video abtastet? optisch mit dgindex das ist doch die einzig verlaessliche quelle was interlaced oder nich interlaced betrifft oder?

  • Spiele jetzt schon seit 2 Wochen mit dem Teil rum.


    Echt Hammer! Mache mittlerweile nur noch .mkvs mit dem Tool. Wenn man das mit den Templates mal raushat, gehts. Trotzdem würde ich eine Speicherung von Templates ala GK begrüssen.


    Was mit aber aufgefallen ist, ist daß die Funktion "-ota( -d %delay% -g max )" überall als Standard definiert wird.


    Ich persönlich halte eine Lautstärkenormalisierung als Standardeinstellung in der vorliegenden Form nicht für sinnvoll.
    Erstens klingt es schrecklich aufgeblasen und zweitens:


    habe ich hier Harald Schmidt und Oliver Pocher und Ultimative Chart-Shows gerechnet.


    Ich verwende für Staxrip ein komplett werbungsfreigeschnittenes fertiges .mpg(2)


    Dabei passiert der Fehler, dass beim Übergang bei einem Applaus z.B, bei einer Ein/Ausblendung des Tons der normalisierte Ton nicht mehr sauber auf 0 ausgeblendet wird (logisch) und sich das im gerechneten File grausig anhört.
    Habe mir jetzt ein Standard Template ohne Normalisierung gebastelt. Vielleicht sollte man ein Nichtnormalisieren des Tons als Standard favorisieren.

  • Doch einfach unter Applications\x264 die x264.exe umtauschen.
    Irgendwann meckert dann Staxrip "New x264 Version" und dann musst du halt sagen "Continue with unknown version".
    Dann verwendet er die neue x264 Version.

  • Oder die neue beta testen. :)

    1.1.5.3 beta


    • Fixed crash making a comp. check with sources having a high bitrate
    • Fixed crash streams in MKV sources containing titles using Unicode
    • Added setting to encode audio in parallel, disabled by default
    • Added option to change sample rate in audio dialog
    • Updated x264 to r1510, added Superfast preset, added --nal-hrd switch, added Blu-ray device and profile
    • Updated mkvtoolnix to v3.3.0
    • Updated eac3to to v3.18
    • Updated MediaInfo to v0.7.30


    http://sourceforge.net/project…_1.1.5.3_beta.7z/download


    Danke für die per Email gesendeten Bug Reports und für die Spenden. Mach bis nächsten Winter keinen Forum Support weil ich keine Lust hab wie letztes Jahr ständig vor dem PC zu hocken, danke deshalb an alle die hier helfen, besonders an das Doom9 Team.

  • Du kannst ein AviSynth-Skript mit DeLogo/Logoaway erstellen und das Video in das Skript einbinden, als xxx.avs abspeichern und als Source in StaxRip laden.


    ok, hab es nach langem basteln & testen dann doch hinbekommen und funzt sogar :D
    TY für den Tip, jedoch ...


    Einfach eine "empty = " Zeile bei Misc eintragen und so das Script beliebig um selbstgetippte Zeilen erweitern.


    das funzt sogar noch einfacher, sofern sich die Logos nicht verändern. Andernfalls hat man eben eine lange Latte an Auswahlmöglichkeiten....


    Auch Dir, smizz, Big TY


    Zum x264 über mir .... hab jetzt die neue Beta am Start, aber das austauschen geht natürlich auch, is nur immer wieder nervig es jedesmal bestätigen zu müssen.
    Vllt kann man das ändern. Irgendwie wie bei megui oder in den früheren stax, wo man updaten kann/konnte ...


    Greetz

  • kann mir mal einer sagen was es mit der fehlermeldung aufsich hat?!


    x264 Encoder failed with exit code 3


    avis [info]: 640x480 @ 119.88 fps (179202 frames)
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
    x264 [info]: profile Main, level 4.1



    bekomme bei fast jedem video diese meldung und nur durchs komplette neu reinladen der datei geht es...wenn ich glück hab aber nur.


    das geht mir echt langsam auf die nerven, genau wie der umstand das staxrip IMMER abschmiert wenn ich ne frische datei drin hab und ne externe datei wie zb UTs oder ne zweite TS einfügen will. das prob hatte ich schon früher, aber helfen konnte auch keiner so wirklich.


    ne crash datei wird auch net erstellt um die jemanden zu schicken!!!



    zz verwende ich noch 1.1.1.9, aber auch mit 1.1.3 treten die gleichen fehler auf