MKV 2 Bluray TUTORIAL

  • MKV 2 BLURAYPlayer/Ps3 TUTv.2012


    Da viele da draussen Probleme haben ihre .mkv Dateien auf einem Bluray player oder ihrer Ps3 abzuspielen gibt es hier mal ein kleines simpeles Tutorial von mir.Ihr erhaltet in nur 3 Schritten eine komplett kompatible und selbst erstellte Bluray-DVD ( je nach grösse dvd+r dl oder eine normale dvd-r), die ihr dann auf jedem Bluray player oder auch der Ps 3 abspielen könnt, in HD inklusive Untertitel usw!


    SOFTWARE: LINKS AKTUALISIERT---29.11.2012


    -NEUE Tsmuxxer Version
    Latest version:
    1.10.6 (May 11, 2009)


    http://www.videohelp.com/tools/tsMuxeR



    -RIPBOT


    Latest version:
    1.17.3 (August 01, 2012)


    http://www.videohelp.com/tools/RipBot264


    Changelog:



    NEUE FFDSHOW version:


    Latest version:
    r4494 20121028 (November 28, 2012)


    http://www.videohelp.com/tools/ffdshow/version-history





    -Haali Media Splitter


    Latest version:
    03/03/2011 (March 03, 2011)


    http://www.videohelp.com/tools/Haali-Media-Splitter



    -IMG BURN
    Current version v2.5.7.0
    Released: 29th March 2012

    http://www.imgburn.com/index.php?act=download



    START TUTORIAL


    Das häufigste Problem ist das die erstellten mkv/blurays garnicht erst erkannt werden in handelsüblichen Playern. Das wiederum liegt meistens daran das eine falsche Auflösung vorliegt. Handelsübliche Bluray-player akzeptieren nur "echte" 720p oder 1080p, sprich 1280*720 od. 1920*1080!
    Hat eure .mkv nun aber eine Auflösung von zB. 1280*544 könnt ihr sie mittels tsmuxxer in eine Bluray struktur bringen, der player wird es aber nicht abspielen können!! Wir müssen also die mkv in das vom player gewünschte 720p bzw. 1080p Fromat bringen.
    Das geht zwar auch schritt für schritt , aber unser genutztes Tool macht die Sache Kinderleicht.;)

    1. Video (mkv) inklusive Audio encodieren


    Ripbot muss nicht installiert werden, einfach auf die .exe klicken.Auf add im Hauptfenster und es erscheint folgendes Bild:

    Beim ersten start von Ripbot werden die fehlenden codecs angezeigt und man kann sie direkt per link laden.



    <a href="http://www.bilder-hochladen.net/files/a2x3-1-jpg-nb.html"><img src="http://www.bilder-hochladen.net/files/a2x3-1.jpg" alt="Bilder Upload"></a>
    oben Links eure mkv öffnen, egal ob mit oder ohne Audio. Öffnet ihr das mkv file mit Audiostrem demuxxed ripbot automatisch.
    In der Mitte level 4.0 Bluray,Console auswählen. Das war es schon für den Videostream.


    <a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img12.imageshack.us/my.php?image=rippb.jpg'><img src='http://img12.imageshack.us/img12/3614/rippb.jpg' border='0'/></a><br/><a href="http://g.imageshack.us/img12/rippb.jpg/1/"><img src="http://img12.imageshack.us/img12/rippb.jpg/1/w586.png" border="0"></a>


    Unter Mode stellt ihr[B] 2-Pass ein und könnt dann die gewünschte Bitrate einstellen, oder aber unten rechts auf Locksize( sieht man im oberen Bild nicht ,da ich nicht 2-Pass ausgewählt hatte beim screenshot machen..sry) klicken und die gewünschte Zielgrösse anhand der erscheinenden Tabelle auswählen oder selbst eingeben.
    Jetzt noch Zielpfad unten eingeben und auf Zielformat .mkv klicken (Bluray erstellung lieber mit Tsmuxxer später, da Ripbot in dem Punkt leichte schwächen hat, ist aber auch die einzigste schwäche!), und wir sehen im folgenden Bild:


    <a href="http://www.bilder-hochladen.net/files/a2x3-5-jpg-nb.html"><img src="http://www.bilder-hochladen.net/files/a2x3-5.jpg" alt="Bilder Upload"></a>


    ....das in der Audio spalte nun Copystream steht, hier könnt ihr nun das gewünschte Zielformat eingeben.


    Alles erledigt, dann auf den Properties Tab klicken. Ein neues Fenster geht auf:


    <a href="http://www.bilder-hochladen.net/files/a2x3-6-jpg-nb.html"><img src="http://www.bilder-hochladen.net/files/a2x3-6.jpg" alt="Bilder Upload"></a>


    Unter dem Punkt Size gebt ihr nun euer Zielformat, sprich 720p oder 1080p ein. Bei Eingabe wird auf der unteren rechten Seite direkt das Script erstellt:


    <a href="http://www.bilder-hochladen.net/files/a2x3-7-jpg-nb.html"><img src="http://www.bilder-hochladen.net/files/a2x3-7.jpg" alt="Bilder Upload"></a>


    Habt ihr Untertitel, die noch schnell unter Subtitles einfügen.
    Dann auf Ok klicken und auf done im folgenden Fenster. Jetzt seit ihr wieder im Startbildschirm von Ripbot und könnt mit dem Prozess beginnen.
    Start klicken!
    Nur zur Info, bei 720p dauert es in etwa komplett 2-3 stunden bei 1080p 4-5 stunden. Am ende habt ihr eure Fertige mkv bereit zum muxxen.



    2. Erstellte .mkv zur Bluray muxxen


    Tsmuxxer muss ebenfalls nicht installiert werden, einfach den Gui ausführen und es erscheint folgendes Bild:


    <a href="http://www.bilder-hochladen.net/files/a2x3-8-jpg.html"><img src="http://www.bilder-hochladen.net/files/thumbs/a2x3-8.jpg" border=0></a>


    1. eure eben erstellte .mkv einfügen.
    2. auf create Blu-ray disk klicken.
    3. Zielpfad angeben.
    4. Muxxen starten.


    Das ganze dauert nur wenige Minuten. Im Zielpfad habt ihr nun zwei Ordner , mit denen gehen wir wie folgt vor.



    3. Bluray Struktur brennen


    Das Program zum brennen ist eure persönliche wahl. Hier einkurzes beispiel anhand Imgburn (freeware).


    <a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img15.imageshack.us/my.php?image=imgdt.jpg'><img src='http://img15.imageshack.us/img15/975/imgdt.jpg' border='0'/></a><br/><a href="http://g.imageshack.us/img15/imgdt.jpg/1/"><img src="http://img15.imageshack.us/img15/imgdt.jpg/1/w610.png" border="0"></a>


    WICHTIG ist nur das ihr beide erstellten Ordner brennt, also bei imgburn auf write folders gehen und ihr seht das fenster oben. Hier unbedingt UDF und auf 2.5 stellen. Desweiteren auf Recursive subdirectories klicken. Es sollte so aussehen wie im Bild oben.


    So, jetzt noch brennen und dann viel spass beim anschauen...:D



    Made by Willensstark 2009

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    110 Mal editiert, zuletzt von Willensstark () aus folgendem Grund: Titeländerung

  • Hallo,


    ich kann in den "Picture-properties" nicht die im Tutorial angezeigte Auflösung einstellen,
    er zeigt mir da nur "HD 1280x544" an, also das Video-Ausgangsformat.
    Stelle ich auf "Custom" die vorgeschriebene Auflösung von 1280x720 ein,
    wird das Bild in der Script-Vorschau verzerrt dargestellt.
    Weiß jemand Rat?


    fuzzilein

  • fuzzilein


    Hi,


    Hast du die oben verlinkte version ???
    Codecs etc. installiert ???


    Und noch das wichtigste, ein paar infos zu deiner source wären ganz nett.


    Gruss der Wille



    EDIT:


    Mir fällt da noch was ein. Habe ganz vergessen zu erwähnen das man bestimmte codecs braucht...:(
    Na ja hier nun der nachtrag. Beim ersten start von Ripbot werden die fehlenden codecs angezeigt und man kann sie direkt per link laden.
    Einzig den benötigten ffdshow REV 2633 bekommt man nicht auf diesem weg. Hier ist ein direkter link:


    http://sourceforge.net/project…125_xxl_mt.exe&a=54535356 ......wenn der Download nicht direkt startet, einfach auf der verlinkten seite oben nochmal auf den link klicken.


    Ihr solltet alle anderen versionen deinstallieren und nur die hier verlinkte installieren. Ich denke das sollte alle probleme beheben.


    Gruss

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    2 Mal editiert, zuletzt von Willensstark ()

  • Hallo,


    meine source ist ein MKV-File in der o.a Auflösung.
    Habe alle Codecs etc. installiert. Habe mal ein jpg der "Properties"
    von RipBot264 'drangehängt, so wie es bei mir aussieht.


    Brenne ich den Film in der vorhandenen Auflösung in eine BD-Struktur,
    wird er zwar vom BD-Player(Sony S350) als AVCHD erkannt, jedoch wird
    das Bild ca. in der Mitte,eher etwas weiter rechts, vertical geteilt.


    fuzzilein

  • fuzzilein


    Also für mich ist das entweder ein problem mit den codecs oder mit der source.
    Schomal eine andere source verwendet? Wenn nicht versuche es bitte mal und sage bescheid ob du nun alle auflösungen siehst.
    Und, nur die benötigten codecs installiert und alle anderen vorher deinstalliert?


    Werde ansonsten mal sehen was ich noch heraus finden kann. Leider ist dein Problem eher selten, also gib mir was Zeit.


    Gruss der Wille


    EDIT:


    Hast du die Bilder 1 und 2 in der Anleitung GENAU befolgt bevor du auf properties geklickt hast?
    Also hast du auch vorher bei save as auf mkv geklickt??

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    Einmal editiert, zuletzt von Willensstark ()

  • Hallo,


    habe eine für mich akzeptable Lösung gefunden.
    Um das re-encodieren komme ich zwar nicht herum, aber es geht in
    einer akzeptablen Zeit (z.B. für eine 4,5 gb große MKV-File im 2-pass
    Verfahren ca. 3,5 Stunden, Dualcore, 2500mhz).
    MegGUI ist die Lösung gewesen!


    (letzter Beitrag)


    Man kann damit eigentlich alles machen, die Qualität ist wirklich super!!
    Bin vollauf begeistert!!!


    Gruß,
    fuzzilein

    Wissen ist Macht, nix wissen macht nix ...

    Einmal editiert, zuletzt von fuzzilein () aus folgendem Grund: Link gelöscht

  • fuzzilein


    Na gut,
    Aber lösche bitte den link zu dem anderen tutorial. Das gehört hier nicht rein.Vorallem weil ich es so LEICHT wie möglich machen wollte, ohne eigene script erstellung etc.
    Das problem lag wie gesagt an deinen Codecs, habe gestern iin einem anderen forum mit jemandem gequatscht der genau das gleiche problem hatte. Deinstallation und installation der RICHTIGEN codecs für das Program RIPBOT brachtem ihm den erfolg.


    MEGUI installiert übrigens auch codecs , und das nicht zu knapp. Also wenn du megui erst nach deinen ripbot versuchen installiert hast, versuche es doch jetzt nochmal und schaue ob du jetzt alle auflösungen siehst.


    Gruss der Wille

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    Einmal editiert, zuletzt von Willensstark ()

  • Willensstark
    Warum hast du eigentlich ständig Probleme damit, wenn jemand mit einem anderen Lösungsvorschlag besser zurecht kommt als mit deinem? Warum darf fuzzilein nicht als alternative Hilfe zu deinem Tutorial für Andere hier auf einen anderen Thread verlinken? Vielleicht solltest du mal darüber nachdenken, wie viel Hilfe du schon von anderen Usern aus diesem Forum bekommen hast um deine Tutorials überhaupt verfassen zu können anstatt deine kleinen Anleitungen als die ultimativen Lösungen schlechthin darzustellen.


    ---------


    Im Übrigen installiert MeGUI im Sinne von im System registrierten Codecs, Filtern, Splittern etc. rein garnichts. Das sind alles Standalone Tools und ein paar AVISynth-Filter-DLLs die in verschiedenen Unterordnern des Installationsverzeichnisses abgelegt werden und je nach Bedarf über die GUI angesprochen werden.


    greets
    LTJ

  • @jake


    Habe ich irgendjemanden beleidigt oder sonst was? Nein, ich habe geschrieben das er den link löschen soll weil es halt ein anderes tut ist, und am ende recht wenig mit meinem zu tun hat.( Wenn er mit nem anderen TUT besser klarkommt ist das vollkommen ok, aber nu kommen wieder PN`s was an meinem nicht stimmt.) Auf meine versuche ihm zu helfen ging er ja auch nicht ein. Ausserdem habe ich dieses Tutorial zu 100% selbst erstellt.
    Wie auch immer, schade das ich mich hier immer rechtfertigen muss. Zum glück gibts hier einige die noch"normal" mit mir sprechen, zwar nur via PN aber nun gut.


    Zu guter letzt sei bemerkt das der sinn hinter meinen Tutorials eigentlich der ist, das ich leuten helfen möchte. Ich habe kein interesse mehr mich mit euch anzulegen oder ähnliches, deswegen bitte LessthanJake nächstes mal per pn bitte. (Zitat:"...deine kleinen Anleitungen")....und höre auf mich in meinen threads so schlecht zu machen, wie soll das denn ankommen? Und jetzt lass es gut sein, keine Lust mehr auf Buh-Mann Position; Danke


    ps: Dachte gerade Megui dient dazu schnell an codecs zu kommen. (update funktion?)
    wenn ich da falsch liege sorry.

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    2 Mal editiert, zuletzt von Willensstark ()


  • ps: Dachte gerade Megui dient dazu schnell an codecs zu kommen. (update funktion?)
    wenn ich da falsch liege sorry.


    Die Updatefunktion von MeGUI ersetzt einfach nur die einzelnen Tools / AVS-Filter etc. durch aktuellere Versionen und bringt die GUI und die Profile auf den neusten Stand. Sie ist natürlich kein Onlinecodecpackinstaller.


    greets
    LTJ

  • @jake


    Da hab ich dann wohl daneben gelegen. Sorry Jake, aber im normalfall nutze ich immer Codec packs. Da diese hier aber nicht gern gesehen sind , kam ich auf Megui.
    Wie auch immer, ich werde mal sehen wie man die benötigten codecs am einfachsten und schnellsten bekommt. Für tipps bin ich immer dankbar.


    Greets der Wille

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

  • Es geht nicht darum, dass CodecPacks hier "nicht gern gesehen" sind, sondern darum, dass sie in der Regel mehr Probleme bereiten als lösen, was wiederum dazu führt, dass die Benutzer solcher hier Threads eröffnen, und fragen: "Warum geht Programm XY nicht, früher hat´s ja auch geklappt." Das deutet dann fast immer auf irgend einen Knoten im DirectShow-System hin und sowas kann man per Ferndiagnose eben nicht so ohne weiteres oder sogar garnicht lösen. Im Extremfall existiert auf dem betreffenden Rechner so ein Codec-Chaos, dass man die Probleme nur durch Neuaufsetzen des Systems beheben kann. Um diesem Vorzubeugen muss man nichts weiteres tun als gezielt die Codecs / Filter / Splitter etc. zu installieren, die man eben genau benötigt. Dazu analysiert man zuvor das Mediafile und informiert sich dann über den passenden Decoder und installiert ihn dann. Frage lieber hier vorher, welcher Filter für dein Problem angemessen ist, wenn du mal nicht weiter weist. Dabei haben beide Parteien gewonnen. Der Threadersteller hält sein System sauber und der potentiell Antwortende auf diesen Thread muss sich nicht wieder mit irgendeinem Codec-Salat auseinandersetzen.


    Vielleicht solltest du mal folgenden Beitrag lesen. Er ist etwas älter, aber im Kern immer noch völlig zutreffend:
    http://forum.chip.de/video-bea…g-codec-packs-532201.html


    greets
    LTJ

  • Willensstark


    Natürlich habe ich Deine Ratschläge befolgt, die letztendlich aber, (zumindest bei mir) zu keinem befriediegendem Ergebnis führten.


    Deine Mühe zu diesem TUT respektiere ich natürlich und der link
    sollte nur einen weiteren Weg aufzeigen, um Leuten zu helfen, die die
    gleichen Probleme hatten wie ich.


    Okay, der link gehört hier nicht 'rein, denn es ist ja Dein TUT, aber der Sinn dieses Forums ist ja, sich gegenseitig zu helfen und event. auch andere Wege
    aufzuzeigen, zumal der link ja noch aus dem gleichen Forum kommt ...!


    Bißchen weniger Egoismus und etwas mehr Zusammenarbeit könnte manchmal nicht schaden.;)
    Damit verabschiede ich mich aus diesem thread!


    Gruß,
    fuzzilein

  • Es gibt eine neue Ripbot Version 1.13.3,,,hier der Link:


    http://www.videohelp.com/tools…version-history#changelog


    [/URL]
    Changelog:
    v1.13.3
    Fixed: Not working FF/RWD/Chapters on some Blu-Ray players due to missing --aud --nal-hrd in command line
    Updated: eac3to v3.12, TSMuxer v1.8.18


    Voller Changelog:
    http://www.videohelp.com/tools…version-history#changelog


    Mit dieser version gibt es auch keine probleme bei den verfügbaren auflösungen.


    Gruss der Wille

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

    3 Mal editiert, zuletzt von Willensstark ()

  • Hi, ich habe alle Pakete so installiert, wie Du es geschrieben hast.


    Ripbot startet auch ohne Fehlermeldung.


    Wähle ich jetzt eine M2TS Datei aus, startet bei mir MediaPlayer Classic... um sich umgehend mit einem Fehler zu beenden:


    Zitat

    Media Player Classic hat ein Problem festgestellt und muss beendet werden.


    Nach dem Klick auf "nicht senden" ist die Video Liste von Ripbot leer.


    Wenn ich versuche, mit MediaPlayer Classic, die Datei direkt zu öffnen bekomme ich einen anderen Fehler:


    Microsoft Visual C++ Runtime error


    Ist sicher nicht die Schuld von Ripbot, aber vielleicht weiss hier ja einer, was zu tun ist ?


    Hier die FileInfo der Datei:



    Jemand 'ne Idee ?

  • lance


    Hi,


    Leider ist mir dein problem nicht bekannt. Jedoch hatte ich vor geraumer Zeit ebenfalls einen Microsoft Visual C++ Runtime error. Ich konnte machen was ich will, am ende half aber nur eine neuinstallation. Dann lediglich die benötigten codecs (siehe ripbot aufforderung) installieren und es geht.


    Ein codec-pack benutzt?
    Über ein vorhandenen codec installiert ohne diesen vorher zu löschen?


    Gruss Wille

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.

  • Jain... ich hatte schon mal eine ffdshow version drauf. Es ist auch nicht einfach damit, im Netz befinden sich diverse Versionen. Geht denn NUR die, die Du gepostet hast, also neuere gehen nicht ?

  • Hallo,
    ich habe nach dem Tutorial eine Disc erstellt, hat auch alles wunderbar geklappt.
    Wenn ich die gebrannte Disc nun in meine Playstation3 schiebe, wird sie nur als Daten-Disc erkannt.
    Ich kann zwar die Datei "0000" im Ordner "BDMV\Stream" ansehen, aber leider höre ich nicht einen Mucks! :nein:


    Wo war mein Fehler, bzw. was kann/muss ich anders machen???
    Danke und Gruß

    Gruß Sanzen


    [SIGPIC][/SIGPIC]
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    "The music business is a cruel and shallow money trench, a long plastic hallway where thieves and pimps run free, and good men die like dogs.
    There's also a negative side.
    " - Hunter S. Thompson

  • Hi,


    hab mich genau an die Anleitung gehalten und zwei .mkv Filme auf DL DVDs gebrannt. Wenn ich sie mit der PS3 starte laufen die Filme auch, allerdings springt er erst auf 1080p, dann 1080p24 und beim Start der Wiedergabe springt die PS3 dann auf 480p und entsprechend dürftig sieht das ganze dann aus. Im unteren Bereich sieht man auch einen grünen Streifen im Bild.


    Was hab ich falsch gemacht?

  • Jain... ich hatte schon mal eine ffdshow version drauf. Es ist auch nicht einfach damit, im Netz befinden sich diverse Versionen. Geht denn NUR die, die Du gepostet hast, also neuere gehen nicht ?


    Hi,


    War 2 monate auf einer schulung, deswegen melde ich mich erst jetzt.
    Zu deiner frage,,,JA NUR die hier verlinkte version.



    sanzen und Verisign


    Habt ihr beide nur die hier verlinkten codecs benutzt?? Ohne sie bei der installation zu verändern?
    Alle anderen codecs vorher deinstalliert?
    Und dann noch die frage mit welchem programm ihr die bluray struktur erstellt und gebrannt habt?


    Bei dir Sanzen scheint es die audio einstellung im ripbot zu sein. Hast du es auf "Copystream" stehen? Wenn ja bitte mal infos zur audiosource geben.


    Verisign bitte mal generelle infos zur source.


    Gruss Wille

    1. Die besten Schnappschüsse ergeben sich sofort, nachdem der Film voll ist.
    2. Die zweitbesten Schnappschüsse scheitern am Linsendeckel.
    3. Alle übrigen Schnappschüsse werden ruiniert, da jemand ahnungslos die Tür zur Dunkelkammer öffnet.