Erneut Fehler nach Update bei MeGui

  • Nicht wirklich ein Fehler doch bei XVID Rips war die Codec ID eigentlich immer XVID und jetzt steht FMP4 was dass nun wieder ?
    Wurde wieder was vergessen beim Update ??


  • Eigentlich nur die kleine Ungenauigkeit, ob der korrekte FourCC eingetragen wurde. Der ist auch noch größenabhängig, also 'XVID' ist nicht das selbe wie 'xvid'. Und wenn man ffmpeg gar nichts vorgibt, kann sich ffmpeg auch schon mal entscheiden, als Standard-FourCC 'FMP4' einzutragen. Müsste man also mal schauen, ob es in den Konfigurations-Dialogen für den Xvid-Encoder oder für den AVI-Multiplexer möglich ist, sich explizit den FourCC 'XVID' zu wünschen. Wenn nicht, korrigiert ein "FourCC Changer" das auch ganz einfach.

  • Leider schreibst du viel zu wenig darüber, wie du beim Konvertieren in ein Xvid-AVI vorgehst (insbesondere veröffentlichst du nicht die komplette Log-Datei). Welche der vielen Funktionen in MeGUI verwendest du: OneClick, AutoEncode oder manuelle Job-Verwaltung? Die ersten beiden kenne ich nicht, die sind mir zu automatisch; bei der letzteren könnte ich vielleicht einen Tipp geben.


    In den letzten Versionen wurde ja in dem Bereich etwas verändert, es wird jetzt mit ffmpeg zu AVI gemultiplext (angeblich gab es mit der vorherigen Methode Probleme mit sehr großen Dateien, was mich verwundert, denn bisher war AviMux-GUI eigentlich dafür bekannt, mit dem AVI-Container so korrekt wie kein zweites Programm umzugehen, man muss es nur in allen Details richtig konfigurieren). Dabei kommt es nun wohl darauf an, wie das vom Xvid-Encoder erzeugte MPEG4-ASP-Video zwischengespeichert wird. Wird es als "roher" Videostream (RAWASP) abgelegt, dann erkennt ffmpeg wohl beim Multiplexen nicht mehr, dass das mal ursprünglich aus dem Xvid-Encoder kam, und markiert es nur allgemein als "MPEG4-ASP" (FourCC = FMP4), nicht speziell als Xvid-Video (FourCC = XVID). Ich vermute mal, wenn es in einem Container-Format zwischengespeichert wird, könnte ffmpeg den Ursprung aus Xvid besser erkennen; oder man müsste ffmpeg beim Multiplexen dazu zwingen, das Video als 'XVID' zu markieren.


    Zur Sicherheit können wir ja noch Zathor hierauf aufmerksam machen, der ist ja auch in unserem Board.


    Und bis dahin änderst du eben mit dem FourCC-Changer (AviC.exe in der Xvid-Codec-Installation) das fertige AVI noch mal ab.


    FourCC Description Code: [ xvid ] (alles klein)
    FourCC Used Codec: [ XVID ] (alles groß)

  • sorry blick ich nicht bzw. finde kein FourCC Changer .. im MeGui Ordner ?
    Updates sind erst mal deaktiviert , jedes mal so ein Theater nach den Updates ..
    meine Ripps waren immer ok und jedes mal nach Updates stimmt irgendwas nicht mehr..


    EDIT .. ich mach alles mit dem Fileindexer !

  • Ich schrieb, in der Installation des Xvid-Codecs. Damit meinte ich den VfW-Codec von https://www.xvid.com/download/


    Außerdem gibt es den noch bei VideoHelp einzeln.


    Und nein, der liegt nicht der MeGUI-Installation bei.


    P.S.: "Jammern" hilft nicht. Was dem Entwickler hilft, seine Fehler zu korrigieren, sind Fakten, Fakten, Fakten - und die Log-Datei des letzten Versuchs. Nicht bloß mal hier ein Bröckchen, mal da ein Schnipselchen.

  • naja bei meinem Installierten xvid Codec find ich dass hier :

    kann ja jetzt auch nicht sein dass ich nach jedem Rips so was machen muss .. oder was versteh ich nicht ..


    Und mit dem AVI FourCC Code Changer 1.00 bekommt man kein XVID als Codec ID

  • ^ Das sind die Codec-Einstellungen, aber nicht der FourCC Changer.


    Nun ja, ich weiß nicht, ob einer ganz aktuellen Installation immer noch die AviC.exe beiliegt; die war schon älter. Zumindest gibt es sie noch einzeln. Und ich glaube, mit einer Google-Suche hätte man das auch gefunden...

  • Das versteh ich jetzt nicht. Was soll der FourCC-Changer machen bzw. nicht machen?


    Ich schreib's mal Schritt für Schritt auf...


    • AviC.exe starten
    • AVI laden: [ ... ]
    • Unten den großgeschriebenen FourCC 'XVID' auswählen (*); weil oben kein kleingeschriebener FourCC 'xvid' zum Auswählen vorhanden ist, mit der Tastatur hineintippen
    • Änderungen übernehmen: [ Apply ]


    Wenn das jetzt zu kompliziert war, so dass du leider aufgeben musst ... ja, dann ... lass das lieber mit dem Konvertieren von Videos. Insgesamt.


    (*) Wenn in deiner Version da auch nichts auswählbar ist, eben dort auch hineintippen. Ich hab meine Version mal hier angehängt.

    Bilder

    • 4CC_1.png
    • 4CC_2.png
    • 4CC_3.png

    Dateien

    • AviC.zip

      (2,51 kB, 77 Mal heruntergeladen, zuletzt: )


    Auf gute Zusammenarbeit:


    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten


    Orden.gif

  • Ja siehst mit dem jetzt geht es und mit dem da vor eben nicht.. Danke!!


    aber nichts desto trotz kann es ja nicht sein dass ich nach nem Ripp mit MeGui die File noch mal mit nem Tool bearbeiten muss , sollte eigentlich MeGui übernehmen den Job !

  • Ist schon richtig. Nur bevor der Fehler korrigiert werden kann, muss er erst mal bekannt und hinreichend dokumentiert sein.


    Wird schon werden... Nicht verzweifeln. :)


    Für einen PC ist das auch erst mal kaum ein "Fehler", gute Decoder werden den Videostream auch mit einem anderen FourCC richtig erkennen und korrekt abspielen. Problematisch wird es vielleicht bei Hardware-Playern, die da nur wenige spezielle FourCCs kennen.

  • Der "MeGUI-Mensch" hat das schon vor einiger Zeit behoben:

    Code
    1. 2558 [XviD Encoder] changed FourCC to XVID when muxing with FFmpeg (regression of 2546)


    Kann es also sein, dass du eine alte MeGUI Version verwendest? Wenn du dir unsicher bist (oder die aktuelle 2561 verwendest), poste bitte dein MeGUI Log.

  • MeGUI Version 2561


    { Hauptfenster }


    AviSynth Script: [ *.avs ]
    Video Output: [ *.avi ]
    Encoder settings: [ Xvid: *scratchpad* ]
    File format [ AVI ]


    ( Queue )


    { Queue }


    job 1 : *.avs : *.m4v : XviD : video
    job 2 : *.m4v : *.avi : ffmpeg : mux


    ( Start )


    Code
    1. GeneralComplete name : *.aviFormat : AVIFormat/Info : Audio Video InterleaveFile size : 4.64 MiBDuration : 6s 680msOverall bit rate : 5 824 KbpsWriting application : Lavf56.36.100VideoID : 0Format : MPEG-4 VisualFormat profile : Advanced Simple@L5Format settings, BVOP : 2Format settings, QPel : NoFormat settings, GMC : No warppointsFormat settings, Matrix : Default (H.263)[B]Codec ID : FMP4[/B]Duration : 6s 680msBit rate : 5 812 KbpsWidth : 720 pixelsHeight : 576 pixelsDisplay aspect ratio : 5:4Frame rate : 25.000 fpsStandard : PALColor space : YUVChroma subsampling : 4:2:0Bit depth : 8 bitsScan type : ProgressiveCompression mode : LossyBits/(Pixel*Frame) : 0.561Stream size : 4.63 MiB (100%)Writing library : XviD 67


    Der Aufruf ist theoretisch korrekt, nach bisherigem Stand unseres Wissens...


    Code
    1. "E:\Programme\MeGUI\tools\ffmpeg\ffmpeg.exe" -y -i "*.m4v" -vcodec copy -vtag XVID -r 25 "*.avi"


    Reicht aber offensichtlich nicht aus, oder wird ignoriert. Müsste mal aktuell geklärt werden, vielleicht weiß jemand im IRC was.
    __


    Theoretisch sollte ffmpeg das so tun können... Man solle da vielleicht einen Eintrag in den Bugtracker setzen.