TV-Aufnahmen Reencoding fehlerhaft

  • Hallo!


    Ich habe mit meiner DVB-C Karte Filme aufgenmmen, diese mit TSSniper geschnittten und anschließend neu encodiert.


    Hier die Media-Informationen nach der Aufnahme:

    Code
    1. VideoID : 5101 (0x13ED)Menü-ID : 10301 (0x283D)Format : AVCFormat/Info : Advanced Video CodecFormat-Profil : High@L4Format-Einstellungen für CABAC : JaFormat-Einstellungen für ReFrames : 4 framesFormat_Settings_GOP : M=8, N=32Codec-ID : 27Dauer : 1h 52minBitrate : 11,8 MbpsBreite : 1 280 PixelHöhe : 720 PixelBildseitenverhältnis : 16:9Bildwiederholungsrate : 50,000 FPSColorSpace : YUVChromaSubsampling/String : 4:2:0BitDepth/String : 8 bitsScantyp : progressivBits/(Pixel*Frame) : 0.256Stream-Größe : 9,32 GiB (88%)


    Und hier die encoding einstellungen:


    Das Ergebnis hat nun aber leider heufige Bild-Fehler, hier eine Auswahl:





    Die Aufnahme selbst, auch nach dem Schitt, ist einwandfrei. Weiß nun jemand wie diese Störungen zustande kommen und wie ich sie vermeiden kann?


    Danke im Voraus!

  • Alle 3 Teile der Sissi-Filme, gibt es bereits auf Blu-ray (1080, 16:9, Vollbild). Mir ist der Sinn nicht klar, dass Du viel Zeit und Stromkosten in solch ein Projekt investieren willst.
    Nur als Test für andere Filme, wäre diese Arbeit gerechtfertigt.


    Das letzte Bild zeigt mir, dass die Bilddatenrate viel zu niedrig ist. 1,799 kbps sind Quatsch. Das sind in MPEG nicht einmal 5,4 Mbps, dies entspricht SD-Qualität.
    Für HD und schnelle Bewegungen, sind mindestens 12 Mbps (H.264) erforderlich. Dann hat man 36 Mbps in MPEG, so wie bei einer Blu-ray.
    Ich würde diese 11,8 Mbps (AVC, oder H.264) unbedingt beibehalten. Dann müsste das Problem beseitigt sein. Ein Komprimierungswahn bringt da nichts. Die Filmdauer ist auch unterschiedlich.

  • Warum soll der Film von 1280x720 auf 960x720 gestaucht werden? Auch ist der crf-Wert von 23 (Standardeinstellung?) schon recht grenzwertig. Auflösung beibehalten und crf auf 19 einstellen und testen.

  • Der Film ist 960x720 / 4:3! Die Aufnahme wurde kurz vor beginn gestartet als noch mit 1280x720 ausgetrahlt wurde. CRF / Bitrate sind so gewollt, Fehler tritt auch bei niedrigerem CRF auf.

  • Der Film ist 960x720 / 4:3!


    Deine Bildbeispiele zeigen aber eher 16:9. Die ARD HD sendet doch im Falle 4:3 mit seitlichen Balken und 1280x720. Auf jeden Fall muß der Film so geschnitten werden, daß das erste Bild die korrekte Auflösung anzeigt. Ziemlich unklar das Ganze!

  • Für TV-Mitschnitte benutze ich zuerst zum Schneiden (TSDoctor) und zum Reencoden dann Hybrid.


    Wenn es mit Hybrid Fehler gibt, dann hat mir schon oft ein neucodieren mit Handbrake geholfen.


    Einfach mal ein anderes Programm probieren wäre mein Tipp.

  • Zitat

    Wie meinst Du das? Ich habe es abgespielt und augeschaut


    Der Punkt ist, dass unterschiedliche Decoder unterschiedlich mit leichten Defekten umgehen. :)
    Nur weil z.B. VLC etwas ohne Bildfehler anzeigt, hast das nicht das jedes Bild fehlerfrei ist und das z.B. MPlayer das Material genau so abspielt.
    Analoges gilt für die Unterschiedlichen Sourcefilter in Avisynth und Vapoursynth.

  • Laut Mediainfo ist es definitiv 1280x720.
    Da die meisten Sender aber 4:3-Material als 16:9 senden, bleiben auf der linken und rechten Seite, schwarze Streifen im Bild sichtbar, wie bereits geschrieben.
    Das tatsächliche Bild ist aber in 4:3. Ja, Auflösung beibehalten und nicht unter 5 Mbps im Encoder einstellen. Direkt im x264vvfw müsste das um 15 bis 19 sein.


    Aber der originale Stream mit 11,8 Mbps, wäre da schon empfehlenswert.
    Bei einer Gesamtstreamgröße von 9,32 GB, ist mir unverständlich, dass der Film noch einmal stark gequetscht werden soll.


    Ansonsten stimme ich den Kollegen zu.