AVC-Video: Abläufe im Video zu schnell / Abspielzeit aber offenbar normal

  • Vielleicht bietet dir VirtualDub2 die richtige Umgebung, die Framerate zu finden und das Ergebnis dann als MP4 oder MKV zu speichern (ohne Neucodierung, "Video: Direct Stream Copy").


    Hallo,


    ich habe mir eben VirtualDub2 installiert und die Videodatei geladen.


    Allerdings erhalte ich folgende Fehlermeldung beim Speichern als MP4 oder mkv:


    Zitat

    "Direct Stream copy cannot be used with this video stream. You may want to select different input drivers."


    Zudem bin ich mir unsicher, wo ich nun vor der Abspeicherung die 15 fps eintragen muss. Unter Sourcerate adjustment oder unter Frame rate conversion?


    Für Hinweise wäre ich dankbar!

    Viele Grüße

    testit2007



  • Hallo,


    ich habe vor Jahren einmal mit aviSynth gearbeitet.


    Aber es scheint doch bei Deiner Empfehlung virtualdub2 gar nicht nötig zu sein, aviSyth einzubinden.


    Wenn ich bei Sourcerate Adjustment 15 frame eintrage, spielt VD2 das Video offenbar auch mit 15 fps ab.
    Auch wird unten mit VD2 die Abspieldauer "hochaufgelöst" angezeigt.


    Es geht jetzt eigentlich nur noch darum, wie ich das Ganze ohne Reencoding mit 15 fps abgespeichert bekomme, d. h. die Fehlermeldung vermeide, die ich oben angeführt habe. Ob möglicherweise dasd Originalvideo tatsächlich mit VFR gearbeitet hat, werde ich so schnell nicht herausbekommen, aber die 15 Bilder/s scheinen eine gute Annäherung zu sein.


    Viele Grüße

    testit2007



  • Zum ersten: Auf jeden Fall nur "Source rate adjustment". Bei "Frame rate conversion" bleibst du bei "Process all frames", oder das Video müsste recodiert werden.


    Das mit der Fehlermeldung muss ich selbst mal testen. Und wenn es mit VirtualDub2 nicht geht, dann direkt mit einem reinen Multiplexer wie MKVtoolnixGUI oder MP4Box und einer GUI dafür (z.B. MeGUI, Tools - Muxer - MP4 Muxer {Strg+5}). Da kann man die Framerate explizit einstellen.




    Hmm, also ich kann *.264-Dateien gar nicht in VirtualDub2 öffnen:


    Zitat

    FFMPEG: Cannot figure stream duration. Unsupported.


    Wenn es in MKV gemultiplext war, kann ich es öffnen.


    Tja, und die Fehlermeldung kann ich nun auch bestätigen. Also frag ich mal shekh, warum das nicht klappt. Bis auf weiteres empfehle ich dann die Muxer in MeGUI.


    Beim Anpassen der Framerate in MKVToolnixGUI habe ich auch eine Überraschung bekommen: Obwohl ich im Feld "Standarddauer/BPS" den Wert "15p" eingetippt habe, zeigte mir der Player "30 fps" an; aber das kann am PAFF-Interlacing liegen, dass es eigentlich 30 Halbbilder pro Sekunde sind. Bei progressivem AVC sollte das kein Problem sein.

  • Hmm, also ich kann *.264-Dateien gar nicht in VirtualDub2 öffnen:

    Ich auch nicht!


    Und da es sich offenbar ausweislich der o. a. MediaInfo-Ausgaben ohnehin nicht mehr um einen korrekt geschnittenenes Videostück handeln kann (die Webcamaufnahme hatte neben Timinginfos sicher auch eine Audiospur), habe ich das Video mit XMEDIA Recode erst einmal ohne Neurendering (Modus: Kopieren) in eim mp4/mov umgewandelt, das ich mit VirtualDub2 einlesen kann.


    Ich könnte mit XMEDIA Recode im Modus KONVERTIEREN auch die Framerate 15 vorgeben, allerdings würde dann wohl neu encoded.

    Viele Grüße

    testit2007

  • ...

    Tja, und die Fehlermeldung kann ich nun auch bestätigen. Also frag ich mal shekh, warum das nicht klappt. Bis auf weiteres empfehle ich dann die Muxer in MeGUI.


    Ich habe mir inzwischen - wie von shekh empfohlen (habe mich dort registriert, man kann aber als Neuling erst nach 5 Tagen posten) - fcchandler matroska installiert (WMV.vdplugin), erhalte aber beim Speichern als mp4/,kv erneut die Fehlermeldung:

    ---------------------------

    VirtualDub Error

    --------------------------

    Direct stream copy cannot be used with this video stream.

    You may want to select different Input Driver.

    ---------------------------


    Muss ich diesen fcchandler matroska erst noch irgendwo in VD2 aktivieren? Er sollte lt. readme eigentlich durch das Kopieren in das plugin-Verzeichnis autom. gefunden werden.


    NOCH EIN PROBLEM:


    Ich kann zwar mit "RECHTS" / "LINKS" in VirtualDub2 zu bestimmen Frames springen, aber das Video bewegt sich dann nicht analog dazu. Es bewegt sich hierbei überhaupt nicht, sondern nur, wenn ich auf PLAY klicke.Wie bekomme ich es hin, dass sich auch das Video entsprechend des gewählten Frames darstellt bzw. die entsprechende Stelle angezeigt wird?


    Danke und viele Grüße

    testit2007

  • Hallo,


    ich habe nun einmal testweise mit 15 frames das Video neu mit XMEDIA RECODE encoded.


    VLC Player zeigt auch 15 frames/s (Codec-Information) an und spielt das Video genauso ZU schnell ab.
    Wie erklärt sich das?


    Viele Grüße

    testit2007

  • Das heißt, dass xmedia recode die Anpassung der Framerate dadurch erreicht, dass es Frames hinzufügt (dupliziert) oder löscht.

    (die Abspielgeschwindigkeit bleibt gleich, nur die fps ändert sich, also das, was 99,9% aller User von einem Editor wollen)


    Du möchtest aber die Frames schneller/langsamer abspielen.

  • Danke Dir für die Erläuterung!


    Aber was würde denn VirtualDub2 anders machen als xmedia recode, wenn ich dort eine Framerate 15 einstelle und das abspeichern als mp4/mkv endlich funktionierte?


    Viele Grüße
    testit2007

  • Um einen anderen Input Driver als den "Cached"-Standardtreiber in VD2 zu verwenden, muss man den sicherlich im "Öffnen"-Dialog auswählen (unten links).


    Die MeGUI-Multiplexer hast du nicht versucht? Oder gar die eigentlichen Multiplexer an der Kommandozeile, falls du deren Bedienung hinkriegst?

  • Guten Morgen!


    Ich kann dort leider nichts auswählen, weil INPUT DRIVER - OPEN USING CACHING INPUT DRIVER ausgegraut ist. WMV.vdplugin bzw. WMV64.vdplugin liegen ordnungsgemäß in ihren Plugin-Verzeichnissen.


    MeGUI-Multiplexer habe ich noch nicht versucht, weil ich eigentlich dachte, dass sich das Ganze mit VD2 realisieren ließe.


    FRAGE (vgl. oben):

    Ich habe inzwischen in VD2 testweise ein anderes Video geladen, das ich mit dem Smartphone aufgenommen habe. Auch bei diesem springt VD2 nicht zur entsprechenden Stelle im Video, wenn ich mit Pfeil RECHTS oder Pfeil LINKS eine Framezahl auswähle. Was mache ich hier falsch? Das Video bewegt sich bei Pfeil rechts/links überhaupt nicht, obwohl die Frames vorwärts/rückwärts gezählt werden.


    Viele Grüße

    testit2007