dither-tools - Debanding bei 16bit Ausgabe

  • Hallo zusammen


    Ich hab hier ein sehr merkwürdiges Verhalten der Dither-Tools bei der Ausgabe von 16bit Material.

    Ich entrausche den org-Clip und ziehe is nochmal mit GradFun3 glatt damit kein Banding entstehen sollte (!!)


    Setzt man nur dfftest + Gradfun ein, so entstehen selbst bei einem CRF von unter 20 noch deutliches Banding auf dem TV.

    Daraufhin habe ich das Beispiel aus den "man-pages" von dither genutzt das Rauschen teilweise wieder zurückführt.


    Ich encode grundsätzlich in 10-bit HEVC ... daher darf/sollte der Avisynth Output ebenfalls lsb sein. Ich habe also das ursprüngliche Script etwas abgeändert:



    Hier das x265 Script dazu:


    Code
    1. "C:\Program Files (x86)\Video Tools\avs2pipemod-1.1.1\avs2pipemod64.exe" -rawvideo "01.avs" | "C:\Program Files\x265\x265-3.2_34.exe" --preset slow --crf 21 --psy-rd 2.0 --rd 5 --psy-rdoq 10.0 --aq-mode 3 --me star --no-open-gop --no-sao --input-res 1920x1080 --input-depth 16 --fps 24000/1001 --output "01.h265" --input -


    Wie schon gesagt sind hier deutliche Banding Artefekte auf dem TV zu sehen ...

    Nun also wieder zurück zur "Original-Version" jedoch mit einem kleinen Zusatz um das Ganze in den 10-bit x265 zu bekommen:



    siehe da, die Bandings sind weg 8| ... Aber wieso ? Was ist der Unterschied zur obrigen Vorgehensweise ?

    Ich hab hier mal alles angehängt:


    https://easyupload.io/pptwsq


    Pass: forum.gleitz.info

    Expires: 15 days

  • may24

    Hat den Titel des Themas von „dither-tools - Debanding Fehler bei 16bit Ausgabe“ zu „dither-tools - Debanding bei 16bit Ausgabe“ geändert.