MeGui stürzt nach Audio-Encode immer ab.

  • Hab mit MeGUI x64 (Version 2924) unter Win10 64-bit ein Problem.

    Jedesmal, wenn ich eine Wave-Spur mit 2 Kanäle nach Dolby Digital mit 6 Kanäle encodiere, stürzt MeGUI ab und die Tonspur ist verschrottet.


    Welche Ursache liegt es daran? Was kann ich tun, damit sie bis Ende erfolgreich abschließt? Im alten Windows war es nicht so.


  • Stürzt MeGUI selber ab, oder der aufgerufene Encoder (ffmpeg)?


    Vielleicht ist es ja möglich, den letzten Befehl (Zeile 51, statt -i - aber das temporäre Audio-Skript, falls das noch zu finden ist, oder aus den Zeilen 21-42 rekonstruieren) per Batchdatei oder direkt in CMD auszuführen, um unabhängig von MeGUI das Ergebnis zu bekommen und die neue Tonspur danach nur noch mit dem konvertierten Video zu multiplexen. Das klärt zwar nicht die Ursache, aber verhilft vielleicht zu einem Ergebnis.

  • Ich hab schon oft nur Audio encoded und hat prima geklappt, aber jetzt nicht mehr. Ich verstehe das nicht.

    Erst wenn das Encoding zu Ende ist (bis 100%), stürzt MeGUI ab.

    Dann hab ich Tonspur reingehört und auch mit Audacity gecheckt, die Tonspur ist kaputt.


    Was ich gemacht habe, ist:


    1. MeGUI geöffnet

    2. Audio Input als wave

    3. Config -> Preferred Decoder: FFAudioSource, Output Channels: Upmix 2 to 5.1 via SuperEQ (slow), Sample Rate: Keep Original S. R., Time Modification: Keep Original und die Bitrate: 448kbps.

    4. OK

    5. Queue


  • Hm...


    Bei mir steht nichts von WAVSource im MeGUI. Wie muss ich installieren?


    Audio-Info:


  • Leider kein Erfolg!


    Avisynth-Script als Hochzeitsfeier.avs gespeichert und mit MeGUI unter Avisynth-Script geöffnet.

    Code
    1. WAVSource("F:\Videobearbeitung\Eigene Videos\Projekt\Hochzeitsfeier.wav")


    Hab ich MeGUI richtig installiert?


    1. MeGUI-2913-64 entpackt

    2. Ordner im C:\Program Files als MeGUI 2913-64 eingelegt und die Dateien hinzugefügt.

    3. Options -> Auto Upldate: Häckchen für UseAutoUpdate beibehaltet und als "Use devolopment update server" gesetzt.

    4. Updates durchgeführt, Programm neugestartet, dann müsste es normalerweise funktionieren, leider scheitert es.

  • Die Installation und das Update klingen soweit korrekt.


    Das Minimal-Skript (ohne Upmix) ist eigentlich auch korrekt. Wenn da jetzt noch was schiefgeht, kann es nur ein generelles Problem mit MeGUI (bzw. einem Plugin, z.B. SuperEQ) oder ein Fehler in der WAV-Datei sein.


    Ich dachte jetzt etwa an diese Kombination:


    Hochzeitsfeier_WAV.avs

    Und dann der Aufruf in einer Batch oder direkt an der Eingabeaufforderung:

    C:\MeGUI-2913-32\tools\ffmpeg\ffmpeg.exe -i "F:\Videobearbeitung\Eigene Videos\Projekt\Hochzeitsfeier_WAV.avs" -y -acodec ac3 -ab 448k "F:\Videobearbeitung\Eigene Videos\Projekt\Hochzeitsfeier.ac3"

    sofern dieses ffmpeg auch selber AviSynth-Skripte als Input akzeptiert; wenn nicht, müsste man noch einen Pipe drum herum basteln oder ein anderes ffmpeg benutzen, das AviSynth-Skripte lesen kann.

  • Auch auf anderen Windows stürzt MeGUI ab. Ich glaube, diese Version wurde von Entwickler irgendwie verschrottet.


    Und jetzt sieht bei mir so aus:



    :|

  • Ah, ich hätte 4 Dateien "3e38010987e.........." nicht löschen sollen, dann habe ich nach Scheitern des Programms wieder in den Aviscript eingefügt und mit CMD noch einmal durchgeführt, dann bekam ich die nächste Meldung:



  • Hab alles gelöscht, dann noch einmal mit Progi durchgeführt, scheitert wie immer am Ende, dann wollte ich mit CMD durchführen und es läuft irgendwie schon, aber der Blinker blinkt seit ca. 20 Minuten schon und im Ordner sehe ich, dass es noch immer 0KB der ausgegebenen Datei ist. Mir scheint, dass diese CMD wie MeGUI nicht mehr weiter durchführen kann.



  • MeGUI ist wirklich schrott geworden! Bei mir kommt ständig zum Absturz, auch wenn ich eine ganz kleine Stereo-Tonspur gerendert habe und habe auch viele Wege ausprobiert - kein Erfolg! MeGUI wird von mir verabschiedet! Dann suche ich eine Alternative.


    Edit: Mit TFM Audio Tool klappt wunderbar und die erstellte 6 Kanäle sind sauber.

  • Ich glaube nicht, dass MeGUI selber Schuld ist, weil es nur eine Benutzeroberfläche ist.


    Kern der Ausführung ist AviSynth+, und das wird momentan noch erheblich weiterentwickelt. Es ist durchaus vorstellbar, dass da im Audiobereich gewisse Inkompatibilitäten mit Plugins aufgetreten sind. Dafür spräche, dass direkt an der Eingabeaufforderung mit ffmpeg ebenfalls etwas nicht klappt. Man würde den Entwicklern sicherlich helfen, wenn man das noch im Detail analysiert. Ich werde mal versuchen, so gut wie ich es hier verstanden habe, das Problem im englischen doom9-Forum zu schildern.


    Du kannst MeGUI ja vielleicht immer noch nutzen, um das Video alleine zu konvertieren und dann eine vorkonvertierte Tonspur damit zu multiplexen.


    Festzuhalten wäre vielleicht noch, dass es nicht unbedingt ein "Absturz" ist (dann würde ja ein Windows-Dialog aufpoppen, der den Prozess beenden will), sondern eher ein Festlaufen ohne Fortschritt. Das ist schon ein wesentlicher Unterschied.


    Es könnte auch sein, dass dieses Problem nur mit bestimmten AviSynth+-Versionen auftritt. Dazu könntest du versuchen, dir von gispos aus seinen github-Releases verschiedene Versionen zu installieren und in MeGUI die Verwendung der mitgelieferten DLL zu deaktivieren. Aktuell gibt es schon v3.6.2, also ist deine v3.5 nicht ganz neu.