Deinterlacing von komischen (blend) Material

  • Ich habe hier interlacetes Material, was wohl mal 25p S/W Film war. Der Film wurde neulich erst im Fernsehen gesendet auf einem HD-Kanal. Das Material ist um ein Halbbild verschoben. Soweit erkenne ich das schon. Aber hinzukommt, dass die Hälfte der Halbbilder auch noch Blends sind. Das sieht man an den Kanten der Objekte. Ich hätte ja einfach die Hälfte der Fields weggeworfen. Es ist sowieso kein echtes HD, also würde mich etwas Unschärfe durch Verlust der Hälfte der Zeilen nicht stören. Ich will nur die Blends rausbekommen. Aber mal sind es die geraden Fields, die die Blends enthalten und mal sind es die ungeraden Fields, die die Blends enthalten. Von Szene zu Szene verschieden. Weiß jemand wie man so einen ganzen Film deinterlacen kann und am Besten die Blends rausbekommt?


    https://www.magentacloud.de/share/o1rkbvjq-q

  • Das beste Ergebnis habe ich mit Cdeblend + Srestore erhalten. Kann man sicherlich noch besser anpassen. Sind immer noch blends vorhanden, aber viel weniger oder man macht es per Hand (lol)


    Code
    1. clip=haf.QTGMC(clip, TFF=True, Preset="fast", FPSDivisor=1)
    2. clip = muf.Cdeblend(clip) # muvsfunc
    3. clip= haf.srestore(clip, frate=25)
  • Nun, ich habe das Script ausprobiert. Leider kommt es dadurch oft zu 2 aufeinanderfolgende Frames, die fast den gleichen Inhalt haben. Das wirkt sich als "Stocken" (Ruckler) aus bei sich gleichmäßig bewegenden Objekten oder Kameraschwenks. Ich werde wohl einfach Deinterlacen (zu 50p) und dann die Hälfte der Frames wegwerfen zu 25p. Mehr ist da wohl nicht rauszuholen.

  • Mit avisynth oder vapoursynth ausprobiert? Weil ich habe es extra paar mal durchlaufen lassen und doppelte frames sind mir eig nicht aufgefallen.


    Sehr wichtig hier ist, dass dein source filter 100% framegenau arbeitet. Je nach ffms2 oder lsmash version ist das nicht immer der fall bei AVC interlaced.

  • Ich hab's nur in Avisynth ausprobiert. Mit dem LWLibavVideoSource(" ") Quellfilter

    Ich habs an einer anderen Stelle des Film ausprobiert.


    EDIT: Auch bei dem Testvideo sind doppelte Frames genau dann wenn das Auto losfährt. (Und das liegt nicht am schlechten Fahrstil des Fahrschülers ;) )