Avisynth und ffdshow auf nagelneuem Win10 Laptop läuft nicht, was kann das sein ?

  • Hallo Allerseits, habe Problem und weiß nicht warum. Habe neuen Win10 Laptop gekauft und wollte nach langer Zeit mal wieder einen Clip mit Vdub encoden, dazu ffdshow_rev4530_20140209_clsid und Avisynth 260 installiert. MeGUI erstellt anstandslos ein script und kann es auch encoden, aber wenn ich das gleiche script in Vdub lade bekomme ich Meldung:

    Avisynth open failure:

    LoadPlugin: unable to load "D:\Neuer Ordner\MeGUI\tools\lsmash\LSMASHSource.dll", Module not found. Install missing library?

    (D:\Neuer Ordner\video.avs, line 1)

    Was läuft da schief?

  • Okay,..

    1. ffdshow_rev4530_20140209_clsid sollte nichts damit zu tun haben.

    2. Warum Avisynth 260? Das erscheint mir heutzutage sehr veraltet?


    Das Problem wird vermutlich sein, dass Du einen alten 32bit Avisynth 2.6 installer verwendet hast, aber ein 64bit Windows benutzt und der Installer die Dateien in den falschen Windows Ordner kopiert.

    32bit avisynth.dll&co müssen bei 64bit Windows Systemen in den syswow64-Ordner.

    64bit avisynth.dll&co müssen bei 64bit Windows Systemen in den system32-Ordner.

    siehe auch: https://forum.doom9.org/showthread.php?t=173877


    Cu Selur

  • Hallo Selur,


    die Pfade, die du nennst sind etwas ungewöhnlicht. Aber wenn du das so schreibst, wir das schon stimmen.


    Sollten die Pfade nicht so heißen:

    32bit avisynth.dll&co müssen bei 64bit Windows Systemen in den system32-Ordner.

    64bit avisynth.dll&co müssen bei 64bit Windows Systemen in den syswow64-Ordner.


    Sorry, wenn ich das jetzt falsch verstanden habe.

    Eine 64bit-Anwendung in einem System32-Ordner ist für mich sehr ungewöhnlich, es sei denn die 64bit-Anwendung wird emulgiert, was ich bei AviSynth nicht glaube.


    Es gibt ein neues Visual C++ 2015-2022 für x64 und x86. Ich meine, dass bei dieser Version die Synchronstabilität vom Ton besser ist.


    Microsoft Visual C++ Aktuelle unterstützte Downloads


    Es wird empfohlen beide Versionen zu installieren.

  • LoadPlugin: unable to load "D:\Neuer Ordner\MeGUI\tools\lsmash\LSMASHSource.dll", Module not found. Install missing library?

    Ziemlich sicher fehlt dir hier die Installation der dazu passenden Version der Microsoft Visual C++ Runtime. Leider weiß ich nicht, welche der vielen Versionen (mit Jahreszahlen wie 2010, 2013, 2015, 2017, 2019) du für diese Version des Plugins brauchst, aber MSVC-Runtimes aller möglichen Versionen brauchen ja sowieso viele Programme.

  • Danke Thomas für die Aufklärung. Wenn das so funktioniert, ist das eigentlich eine gute Sache. Zuerst denkt man immer an einen x86-Ordner.

    Was den WOW64-Ordner betrifft, da bin ich noch nicht so tief in die Materie eingestiegen.