Beiträge von Lupissimo

    Vielen Dank für Eure Antworten! Mein Feature Request wurde abgelehnt, mit der Aussage, dass bei nicht gesetztem Flag der Matroska Defaultwert "Flag active" gilt und wenn Player, das nicht können, können sie die Matroska Spec nicht! Das kann man leider so sehen. Ich versuche noch herauszufinden, welche Flags nötig für eine Anzeige auf meinem Player sind und das ist bei den vielen Möglichkeiten ein Puzzlespiel: Standard Track Flag: Ja,Nein,Standard , Anzeige Erzwungen : Ja, Nein und versteckt noch Track active : Ja, Nein.

    Ich benutze MKVMERGE GUI zum Muxen von meinen Videos mit Audio tracks und oft auch mehreren UTs. Dabei stelle ich fest, dass die erzeugten mkvs in Zoomplayer zwar die UTs anzeigen, aber in Standalone Mediaplayern wie z.B. Mede8er 500X2 keine UTs zu sehen sind. Erst wenn ich über den Kopfadteneditor bei den UTs das "Track active" Flag aktiviere und den Wert auf "Ja" stelle, werden sie sichtbar und lassen sich auswählen. Leider lässt sich dieses Flag von MKVMERGE Gui nicht als default "Ja" einstellen. Auch mit STAXRIP wird es über mkvmerge nicht aktiviert, so dass immer eine Nachbearbeitung mit dem Kopfdateneditor nötig ist. Gibt es eine einfachere Löung?


    Lupissimo

    Folgender Schönheitsfehler ist mir aufgefallen:


    Wenn man einen Job suspended und nach längerer Zeit (z.B. 2h) wiederaufnimmt werden unsinnige eta Zeiten angezeigt. Anscheinend berechnet er aus der ursprünglichen Startzeit und den bisher encodeten frames die fps und daraus die Endzeit (eta). Wünschenwert wäre die augenblickliche Restzeit , d.h. ohne Berücksichtigung der Pausenzeit.


    Lupissimo


    @ Lupissimo:


    Nicht rätselraten. MediaInfo-Analyse zeigen. Vielleicht ist es ja gar kein echter MPEG2-Transport-Stream, sondern nur so was ähnliches -- so dass es das eine Tool gerade so erkennt, das andere aber nicht mehr, weil es enger an der Spezifikation klebt.


    Auch das mach ich gerne:



    Hilft MIR aber nichts !


    Dies ist ein typischer HD.ts der öffentlichen Rundfunkanstalten
    und ich versuche schon seit Monaten in Staxrip eine vernünftige Antwort zu bekommen. Leider ohne Erfolg!


    Lupissimo

    Tut mir leid, aber natürlich kann ich den file mit Zoomplayer oder DVBviewer oder auch Magix wiedergeben. Ohne konkretere Hinweise auf eine Lösung komme ich leider nicht weiter und die Lösung hatte ich mir in STAXRIP erhofft. Sonst muss ich eben weiter Mit Magix den File nach xvid.avi wandeln und den in Staxrip einlesen. kein sehr elegantes Verfahren.

    Das Problem ist ja, dass dgavcindex nicht mehr weiterentwickelt wird in seiner jetzigen Form. Es wären sicher nur marginale Änderungen notwendig um dgavcindex zu den ÖR-Streams kompatibel zu bekommen, aber DG wird nichts mehr daran machen, wegen eines anderen, wie ich finde völlig geringwertigem Problems.


    Unglücklicherweise sind andere h264-indexer einfach noch nicht weit genug. Wir müssten alle DG mal anschreiben und versuchen ihn zu überreden, wenigstens für die deutschen ÖR einen kleinen Patch herauszubringen.


    Ich kann mit DGAVCIndex die HD.ts files problemlos schneiden und demuxen - zumindest wird ein HD.demuxed.264 und die audio files erstellt und der HD.demuxed.264 ist in DGAVCIndex auch einlesbar und wird sauber angezeigt.
    Allerdings hab ich kein anderes Programm gefunden, was diese .264 Datei "versteht". VLC Player crashed auch, was bei einer demuxten ASTRA-HD Aufnahme nicht passiert, die er allerdings nicht anzeigt.


    Aber angeblich soll es ja eine STAXRip Einstellung mit driect show geben, die solche ARD /ZDF HD .ts in XP SP3 verarbeiten kann. Könnte bitte mal jemand, bei dem es geht, erklären, wie man Staxrip konfigurieren muss?


    Lupissimo

    matmiller : Danke für Deine Antwort. Wie Du aus der Fehlermeldung oben siehst, benutze ich 1.1.3.7 und habe keine neuere Version gefunden. Wenn automatisch directshow verwendet wird, verstehe ich nicht den Programmabsturz. Leider sind die neueren Staxrip Versionen nicht mehr so narrensicher und verlangen deutlich mehr insider Wissen als die früheren.


    Vielleicht findet sich ja ein XP SP3 Benutzer ,der die neuen ARD/ZDF/Arte HD Programme in x264.mkv codiert und das Problem gelöst hat.


    Lupissimo

    Ich kämpfe schon seit einiger Zeit damit, dass sich die "deutschen" HDTV Aufnahmen (720p,50Hz) nicht mit Staxrip (1.1.2.1_beta oder auch 1.1.3.7) ohne Absturz encoden lassen, so dass ich gezwungen bin die Streams (.ts) zunächst mit Magix Movie Edit in xvid.avi zu wandeln und dann in Staxrip zu x264.mkv zu encoden.


    Mein System: XP SP3.


    Direkt in DGAVCIndex lässt sich der ts.file einwandfrei demuxen und schneiden. Wenn ich den DGA file ( oder auch die original.ts ) dann in Stax lade stürzt es beim x264-encoden mit dieser Fehlermeldung ab:
    x264
    ------------------------------------------------------------


    "C:\Programme\StaxRip_1.1.3\Applications\x264\x264.exe" --level 4 --keyint 100 --vbv-bufsize 25000 --vbv-maxrate 20000 --output "I:\DVBRECORD\Catch me if you can - Mein Leben auf der Flucht_EncoderOutput.h264" "I:\DVBRECORD\Catch me if you can - Mein Leben auf der Flucht.avs"



    ------------------------------------------------------------
    Error
    ------------------------------------------------------------


    x264 failed with exit code 3


    avs [info]: 1280x720 @ 50.00 fps (395541 frames)
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.1 Cache64
    x264 [info]: profile High, level 4.0
    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information.


    Angeblich soll es über "directshow" gehen, aber ich finde keine Anleitung, wie man dies einstellen kann. Alle anderen Programme ( DVBviewer oder auch ZOOMPLAYER haben mit den ts.files kein Problem. Als codec in ZOOMPLAYER benutze ich für die .ts den ffddshow mit der x264 option ffmpeg-mt.


    Für einen Hinweis zur Problemlösung wäre ich sehr dankbar, da der Umweg über Magix zu xvid.avi sehr zeitaufwendig ist ( für 2h Film ca 5h Encode) und dann kommt noch der eigentliche encode zu x264.


    Lupissimo

    Ich habe es auf 2 unterschiedlichen PCs probiert mit identischem Ergebnis!


    Bei XVID encoding passiert der Abbruch an der gleichen Stelle 33%. Allerdings wird kein Log des Fehlers ausgegeben.


    Der Teststream ist 32 MB. Bei einem 2. Teststream ( 70MB) stürtzt er bei 14% ab. Es sieht also so aus als könne er nur ca. 10MB verarbeiten.


    Lupissimo


    Ergänzung zur Info:
    Die Streams von Astra HD+ lassen sich encoden und sind 25fps interlaced,
    Die Streams von ZDF und ARD sind 50fps progressive.


    Problem ist "gelöst":
    Anscheinend hatten die Sender auf dem HD Transponder 11362H ein "unübliches" Streamformat gesendet. Inzwischen sind alle Aufnahmen wieder mit Staxrip zu verarbeiten.

    Ich habe 2 Probleme mit dem Encoden von HDTV ( Arte,ZDF,ARD) Material , aufgenommen mit dem DVBViewer 4... ( Filename.ts )
    Ich habe den Test mit Staxrip 1.1.1.0 und 1.1.1.3beta gemacht.


    1. Es kommt beim ersten Scannen des Files in Staxrip die Fehlermeldung:
    ""Die Datei "O:\DVBRECORD\HDTV im Zweiten temp files\AutoCrop.log" konnte nicht gefunden werden.
    Dateiname: "O:\DVBRECORD\HDTV im Zweiten temp files\AutoCrop.log"
    bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
    bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    bei StaxRip.StringHelp.ReadFile(String path)
    bei StaxRip.GlobalClass.AutoCrop()
    bei StaxRip.MainForm.OpenVideoSourceFiles(List`1 files, Boolean autoMode)""


    Die kann man durch deaktivieren von crop vor dem Laden verhindern.
    ( Die passiert nur bei HDTV files )


    2. nach ca. 33% x264 encoding bricht er ab:


    ""General
    ID : 3F3
    Complete name : O:\DVBRECORD\HDTV im Zweiten.ts
    Format : MPEG-TS
    File size : 31.3 MiB
    Duration : 19s 925ms
    Overal bit rate : 13.2 Mbps


    Video
    ID : 6110 (0x17DE)
    Menu ID : 11110 (0x2B66)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L4.0
    Format settings, CABAC : Yes
    Format settings, ReFrames : 5 frames
    Duration : 19s 925ms
    Bit rate : 12.0 Mbps
    Width : 1280 pixels
    Height : 720 pixels
    Display aspect ratio : 16/9
    Frame rate : 50.000 fps
    Colorimetry : 4:2:0
    Scan type : Progressive


    Audio #1
    ID : 6120 (0x17E8)
    Menu ID : 11110 (0x2B66)
    Format : MPEG Audio
    Format version : Version 1
    Format profile : Layer 2
    Bit rate mode : Constant
    Bit rate : 256 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Resolution : 16 bits
    Video delay : -864ms
    Language : German
    Language_More : Clean effects


    Audio #2
    ID : 6122 (0x17EA)
    Menu ID : 11110 (0x2B66)
    Format : AC-3
    Format/Info : Audio Coding 3
    Bit rate mode : Constant
    Bit rate : 448 Kbps
    Channel(s) : 2 channels
    Channel positions : L R
    Sampling rate : 48.0 KHz
    Video delay : -927ms
    Language : German
    Language_More : Clean effects


    Menu #1
    ID : 6000 (0x1770)
    Menu ID : 11100 (0x2B5C)


    Menu #2
    ID : 6100 (0x17D4)
    Menu ID : 11110 (0x2B66)
    Format : AVC / MPEG Audio / AC-3
    List : 6110 (0x17DE) (AVC) / 6120 (0x17E8) (MPEG Audio, deu) / 6122 (0x17EA) (AC-3, deu)


    Menu #3
    ID : 6200 (0x1838)
    Menu ID : 11120 (0x2B70)


    Menu #4
    ID : 6400 (0x1900)
    Menu ID : 11140 (0x2B84)



    ------------------------------------------------------------
    Demux and index AVC using DGAVCIndex by format
    ------------------------------------------------------------


    "C:\Programme\StaxRip_1.1.1.3beta\Applications\DGAVCIndex\DGAVCIndex.exe" -i "O:\DVBRECORD\HDTV im Zweiten.ts" -o "O:\DVBRECORD\HDTV im Zweiten temp files\HDTV im Zweiten.dga" -a -h -e


    Preparer: Demux and index AVC using DGAVCIndex by format
    Start: 09:10:12
    End: 09:10:14
    Duration: 00:00:02


    ------------------------------------------------------------
    Filters
    ------------------------------------------------------------


    AVCSource("O:\DVBRECORD\HDTV im Zweiten temp files\HDTV im Zweiten.dga")


    ------------------------------------------------------------
    x264
    ------------------------------------------------------------


    "C:\Programme\StaxRip_1.1.1.3beta\Applications\x264\x264.exe" --output "O:\DVBRECORD\HDTV im Zweiten temp files\HDTV im Zweiten_EncoderOutput.264" "O:\DVBRECORD\HDTV im Zweiten temp files\HDTV im Zweiten.avs"



    ------------------------------------------------------------
    Error
    ------------------------------------------------------------


    x264 Encoder failed with exit code 3


    avis [info]: 1280x720 @ 50.00 fps (980 frames)
    x264 [info]: using cpu capabilities: MMX2 SSE2Slow
    x264 [info]: profile High, level 3.2
    [0.1%] 1/980 frames, 12.82 fps, 0.00 kb/s, eta 0:01:16
    [0.2%] 2/980 frames, 12.82 fps, 0.00 kb/s, eta 0:01:16
    [0.3%] 3/980 frames, 9.15 fps, 0.00 kb/s, eta 0:01:46
    [0.4%] 4/980 frames, 7.75 fps, 5936.60 kb/s, eta 0:02:05
    [0.5%] 5/980 frames, 6.04 fps, 8127.04 kb/s, eta 0:02:41
    [.......
    [33.5%] 328/980 frames, 4.40 fps, 5782.90 kb/s, eta 0:02:28
    [33.6%] 329/980 frames, 4.41 fps, 5767.05 kb/s, eta 0:02:27


    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information.""


    Merkwürdigerweise lassen sich ASTRA HD Aufnahmen ohne Probleme encoden.


    Auch funktionierte es Anfang des Jahres bei ArteHD noch einwandfrei.


    Kennt jemand eine Lösung?


    Lupissimo

    Zunächst noch einmal vielen Dank für StaxRip!!


    Trotz Lesens der Hilfe und dieses Threads habe ich bisher keine Möglichkeit gefunden das Filter "grayscale bzw greyscale" in StaxRip zu benutzen! Es ist bei schwarz weiß Filmen wichtig um diese schrecklich farbigen Senderlogos etwas zu mildern. In DVX ging das problemlos.


    Der Hinweis: "Kontextmenü -> Profile, ist auch in der Hilfe beschrieben." bringt leider nichts, da das Filter nirgendwo zu finden ist.


    Vielleicht erbarmt sich ja einer der Experten und hilft mir auf die Sprünge!


    Dank im Vorraus!


    Lupissimo