Beiträge von eronix

    Die Variante die ich per edit noch angefügt hatte, ist bisher recht zuverlässig - auch wenn sie von den Einstellungen dem One-Klick-Encoder recht ähnlich ist. Wirklich schade das beim One-Klick kein manuelles Croppen möglich ist.
    Ein weiterer Nachteil der Methode demux, indexieren, Video-Codierung und mux ist, das dadurch das Erstellen mehrerer Jobs die man dann in einem Rutsch abfahren kann nicht mehr möglich ist. Da die Jobs ja aufeinander aufbauen und ohne Datei XY die Job 1 erstellt Job 2 auch nicht erstellt geschweige dann gestartet werden kann. Damit kann ich mich allerdings arrangieren.


    Die exorbitante Verzögerung übrigens lag am RAW-Cutter vom TS-Doc, ich hatte zu Testzwecken etwas abgeknipst dabei ist irgendwas im Header flöten gegangen. Dennoch schade, das der Demuxer den Versatz nicht erkannt hat. Jedenfalls klappt so auch die Variante den du als "den ausführlichen, manuellen Weg" bezeichnet hast.


    Auch wenn mir der "AutoEncode"-Button immernoch suspekt ist. Ich meine, wozu soll der genau gut sein. Klickt man ihn gleich nach dem Starten des Tools an, will er verständlicherweise ein Video-Input haben. Geht man aber den Weg über File -> Open hat sich das doch erledigt, von da aus geht doch alles seinen normalen Weg über Index, Avisynth, A/V bearbeiten/ codieren bis hin zur fertigen Datei. Also wozu dieser olle Knopp? ^^


    Gruß

    Hi,


    ja zumindest bei HD-Aufnahmen kommt für mich nur die unkomprimierte Tonspur in Frage. Den Job hatte ich nur erzeugt, weil ich eben keine andere Möglichkeit in MeGUI sah, die Tonspur zu extrahieren. Aber dann kamst du mit Strg+F7 und ich sah den Wald wieder. ;) Überhaupt hatte ich die Tools wohl konsequent missachtet.


    Bisher arbeitete ich fast ausschliesslich mit den Frontend's StaxRip und Handbrake und bin da wohl etwas vorbelastet. Letztendlich versteckt sich dahinter bei allen die gleiche "Technik" nur eben anders angeordnet und Funktionen sind mal oder weniger leicht zu finden.


    Ich habe mal fix deine Vorgehensweise nachgeahmt mit dem Ergebnis das die Tonspur wie erwartet asynchron war. Beim Demuxen der Tonspur hat er leider das Delay nicht in den Dateinamen mit einfügt. In der Logdatei stand lediglich das er eine verbleibende Verzögerung von -9ms nicht beheben konnte. Natürlich habe ich dann versucht beim letzten Schritt diese und andere Werte händisch ins Delay-Feld einzutragen, ohne Erfolg. Und jedesmal mich an die Delay-Werte ranzutasten ist unnötig umständlich. Da es keine Vorschau gibt, müsste man jedesmal die Aufnahme muxen. Das geht jetzt bei einer Testdatei die nur ein paar MB ist noch aber bei kompletten Filme machen sieht das schon anders aus.


    Vielleicht hab ichs auch anders verstanden als du es beschrieben hast.


    Ich habe die bereinigte Datei geöffnet (mit TS-Doctor alles rausgeschmissen was ich nicht brauche, da er sich beim Indexieren mittels L-Smash an weiteren Tonspuren stört), L-Smash File Indexer gewählt, alle Tonspuren und indexiert. Gecroppt und danach im Input-Reiter nur den Videostream in die Queue geschickt - codiert. Ergebnis, eine .mkv ohne Ton - okay.
    HD Streams Extractor gestartet, File Mode und die original .ts ausgewählt. AC3 Audiostream als .ac3-Datei speichern lassen - okay.
    Zum Schluss MKV-Muxer geöffnet zuvor erstellte .mkv und .ac3 Streams ausgewählt und gemuxt. Ergebnis wie gesagt asynchron. Natürlich habe ich mit Delay-Werten rumgespielt die mir die originale .ts liefert aber diese brachte keinen Erfolg so musste wiedermal die Augen-Ohren Kombination herhalten und raus kam ein Delay von 650ms. Aber diese Frickelei muss ich echt nicht haben. Nachvollziehen oder gar errechnen konnte ich den Wert auch nicht.


    Mache ich es hingegen wie sonst auch gibts keine Probleme mit der Synchronität. Bereinigte Datei öffnen, als Indexer diesmal FFMS genommen und gecroppt. Im Input-Reiter auf "AutoEncode" gegangen "Adaptive Muxer" öffnet sich und codiert - alles okay. Komischerweise ist das Delay-Feld beim Adaptive Muxer ausgegraut und mit einer Null versehen, so dass ich leider nicht sehen kann was er da nun errechnet hat. Aber rauskommt eine synchrone Datei. Ob er den Audiostream aber jetzt wirklich nur gemuxt oder ihn irgendwie doch codiert hat ist nicht ersichtlich. Da sind wir wieder beim Fehlen einer passtrough Funktion.



    edit:


    Jetzt hab ichs nochmal mit einer anderen Methode probiert. Raus kam eine synchrone codierte .mkv mit unangetasteter Tonspur.
    Diesmal habe ich zuerst die bereinigte Aufnahme mit HD Streams Extractor geöffnet A/V-Streams als h264/ac3 demuxt. Danach über die Tools den Indexer geöffnet, weil sonst kann man ja nirgends ein Raw-Stream öffnen. Besagten Raw-Stream (h264) also geöffnet und mit DGAVC (alle anderen waren ausgegraut) indexiert. Wieder das Übliche: wahlweise gecroppt und codiert. Dann nochmal durch den MKV-Muxer gejagt und fertig.



    Gruß

    Eine (Verständnis-) Frage zu MeGUI (v2507) und der Vorgehensweise beim Vorbereiten einer Datei für die Codierung. Das ansonsten schicke Frontend zeichnet sich ja leider nicht durch seine Übersichtlichkeit aus - zumindest wenn es an das eigentliche Codieren geht. Jetzt möchte ich mal in Erfahrung bringen, ob die Vorgehensweise die "Richtige" ist oder ob ich zu viele einzelne Schritte gehe. Also die "Richtige" wirds schon sein, da ich ja mein Material codiert bekomme aber vielleicht gehts auch anders und ich meine damit nicht das automatische Starten der Queue sobald sich darin etwas einfindet.


    Beispiel:


    Ich habe eine HD-Aufnahme vorliegen die bereits von überflüssigem Inhalt befreit ist. Es handelt sich um eine .ts Datei (AVC/AC3), bei der der Ton allerdings unangetastet bleiben, also später nur gemuxt werden soll. Eine Art passtrough Einstellung habe ich bei MeGUI nicht entdecken können. Daher habe ich mir ein eigenes Tonprofil angelegt mit bei dem alle Einstellung auf Original stehen samt richtiger Bitrate und der Einstellung unter Encode "Never, but use only the core of HD tracks". Ob das überhaupt Auswirkungen hat, steht auf einem anderen Blatt.


    MeGUI ist also gestartet und ich wähle über File -> Open die Datei aus. Nun folgt die Wahl der Methode, hier nehme ich in dem Fall "File Indexer" da mit "One-Click" kein manuelles croppen möglich ist. Danach wähle ich als File Indexer allerdings "DGAVCIndex" da ich so die Tonspur demuxen kann.
    Nachdem das abgearbeitet wurde, öffnet sich das Vorschaufenster und ein Croppen ist nun möglich, ist auch das erledigt wird das Avisynth gespeichert.


    Am folgendes Punkt bin ich mir nicht ganz sicher, da sich nun nichts in der Queue befindet drücke ich immer auf "AutoEncode" und markiere einmalig die Option "add additional content" und wähle im nächsten Fenster (Adaptive Muxer) die gewünschte Tonspur aus. Start und fertig.


    Normal so oder zu umständlich? Zumal mich die beiden Queue Buttons bei Audio und Video im Input-Reiter etwas irritieren. Muss ich an irgendeinem Punkt selbst drücken? Hatte die mal nachdem ich den "File Indexer" (FFMSIndex) genutzt hatte mal geklickt, erst Audio dann Video. Nachdem die Warteschlange abgearbeitet war hatte ich zwar eine codierte Datei allerdings ohne Tonspur. Diese lag zwar separat im Temp-Ordner aber wurde anscheinend nicht gemuxt.


    Gruß

    Nabend,


    kurze Frage, ich habe lange nichts mit DivX gemacht, da ich ausschliesslich x264 nutze. Ist es garnicht mehr möglich die aktuellste DivX-Version in Stax einzubinden? Bei v10 liegt ja kein Codec mehr bei also gibts auch keine .dll somit ist diese Version nutzlos.
    Bis zur welcher Version nach v6.8 kommt staxrip denn noch klar?


    Gruß

    Morgen,


    alte Logs aus Tagen an denen es funktionierte habe ich leider nicht mehr. Habe es anhand zweier Testdateien dennoch reproduziert (Log im Anhang). Diese beiden ts-Dateien sind an unterschiedlichen Tagen aufgezeichnet worden und die Logdatei deutet nichts gutes an. Sobald ProjectX zur zweiten Datei kommt spielen die GOPs verrückt.


    Eben bei einer kurzen Probe habe ich zwei Dateien erstellt und ProjectX hat diese tatsächlich zusammengefügt und demuxt. Es scheint mir also irgendwas mit der zweiten Datei sobald diese auf eine andere folgt irgendwas nicht zu stimmen. Vertausche ich nämlich beide Dateien, demuxt ProjectX wie gehabt. Werde mal versuchen alles mit dem tsmuxer nachzustellen, mal schauen was dabei raukommt. In der aktuellen Reihenfolge der Dateien sehe ich aber keine große Hoffnung auf Erfolg.


    log.txt


    Gruß
    eronix

    Hallo,



    zunächst wünsche ich allen ein Fohes Neues, hoffe ihr seit gut reingerutscht.


    Nun zu meinem eigentlich doch recht banalen Problem mit ProjectX. Ich benutzte ProjectX hauptsächlich zum Demuxen meiner DVB-T Aufnahmen die als .ts Dateien vorliegen. Diese Vorgehensweise praktiziere ich eigentlich schon seit Jahren bis ich vor ein paar Wochen folgendes bemerkte.


    ProjectX ist so eingestellt, dass im Prozessfenster bei demultiplex ein Häkchen gesetzt ist. Im Hauptfenster füge ich nun per drag and drop mehrere ts-Dateien eines TV-Senders hinzu. Bislang wurden auch alle Dateien zu einer zusammengefügt und letztendlich in A/V gesplittet und im Speicherordner abgelegt. Nun, seit eben ein paar Wochen passiert folgendes, es wird jeweils immer nur die erste ts-Datei gemuxt und alle folgenden ignoriert. Und das obwohl ich im Prozessfenster sehen kann das er die folgenden zumindest bearbeitet aber am Ende wird immer nur die Erste in der Liste gemuxt.


    Habe es mit zwei unterschiedlichen ProjectX Versionen (0.91 & 0.90) probiert, kam aber jedesmal zum gleichen Ergebnis. Die ts-Dateien sind bis auf ihre Größe/ Länge natürlich gleich. Vielleicht hat ja jemand eine Ahnung wo es happert.


    Gruß
    eronix

    Mein Gott, nur weil ich den Zusatz b32 nicht dazugeschrieben habe? Sollte klar sein, dass ich keine 3 Jahre alte Version benutze.


    -----------------------------------


    Danke Jens, die Lösung kann ja manchmal so einfach und doch so fern sein. :) Die Leerzeichen, mit denen JAVA ja sowieso so seine Probleme hat, waren es. Nachdem entfernen dieser klappt es nun.


    greetz

    Du hast im Grunde das wiederholt was ich schon geschrieben hatte. Bitte, wenn du willst.


    - Den Pfad zu Cuttermaran unter "Externe Programme" eintragen. // hatte ich bereits
    - Unter "Nachbearbeitung: Demultiplex":
    "C:\Programme\Cuttermaran\Cuttermaran\Cuttermaran.exe" "?0" // hatte ich bereits
    - Statt der Null probehalber 'ne Eins eintragen, weiss nicht mehr genau was dieser Schalter bewirkt. // brauch ich nicht eintragen, weil ich weiß was die Zahlen bewirken und die 0 bewusst gewählt ist.
    - Solltest du eine neuere Version von ProjectX benutzen musst du explicit im Prozessfenster "Anpassen" unter "Bearbeiten" den Haken bei "Nachbearbeitung" setzen. // hatte ich bereits
    - unter "Datei" den Haken bei "Programm nach Ausführung benden" setzen. // Und das war nur ein Tipp am Rande der nichts mit dem Problem zu tun hatte.


    Aber du hast Recht, wir wollen keine Erbsen zählen. ;D


    Weiter im Text. Die Versionsnummer hatte ich eigentlich auch dazu geschrieben... die Version ist vom 31.10.2009. Sollte die neuste sein.


    ----------------------------------


    Hier der Log vom Demxen bis hin zu Übergabe an Cuttermaran, welche ja auch klappt nur verweigert Cuttermaran die Annahme - so scheint es mir.
    Leider sehe ich nirgends eine Art Spoiler Funktion um das Log platzsparender zu posten.


    Kann man da evtl. etwas mit einer *.bat erreichen? Hatte mir eine erstellt gehabt und ins Cuttermaran Dir kopiert mit dem Inhalt "Cuttermaran.exe %1 %2" (ohne ") und die Zeile in den Einstellungen von ProjectX sah dann so aus "Partition:\Cuttermaran\cut.bat" "?0". Da hatte ich die ?0 noch in Anführungszeichen gesetzt gehabt. Ist das gleiche in grün, oder?

    Hallo Jens,


    gesagt getan, Haken bei Standard Erweiterung MPG-Video *.mpv gesetzt. Leider ergibt sich ein unverändertes Bild. Erhalte von Cuttermaran immernoch die Meldung "invalid file type found in commandline".

    Hi,


    ähm, sei mir nicht böse aber alles was du geschrieben hast habe ich doch bereits in meinem Post aufgezählt. Das sind ja die Einstellungen die ich schon vorgenommen habe. "?0" habe ich bewusst gewählt, weil Cuttermaran alle Streams die vorhanden sind öffnen soll.

    Nabend,


    ich würde gerne wissen, was genau ich bei ProjectX eintragen muss, damit direkt nach dem Demuxen Cuttermaran aufgerufen wird und die A/V Streams geladen/ geöffnet werden.


    Bisher habe ich unter ProjectX im Prozessfenster die "Nachbearbeitung" aktiviert, in den Einstellungen unter "Extern" einen Haken bei "Cuttermaran info Version 1.61ff" gesetzt und unter "Nachbearbeitung" in der demultiplex Zeile folgendes eingefügt "Partition:\Cuttermaran\Cuttermaran.exe" open "?0".


    Soweit so gut, Cuttermaran öffnet sich aber es folgt erwarteterweise die Meldung "invalid file type found in commandline". Klar, ich habe ihm ja auch nicht gesagt was er öffnen soll. Bei den beiden Streams einer .mpg Datei (DVB-T), handelt es sich um eine .m2v und um eine .mp2. Nur weiß ich leider nicht wie ich das angeben soll.
    Muss ich evtl. den Ordner angeben in dem alles was ProjectX demuxt landet, damit Cuttermaran weiß, dass es sich daraus bedienen soll?
    Wäre toll wenn ihr mir ein paar Tipps geben könntet.


    Infos:
    ProjectX - v0.90.04
    Cuttermaran - v1.70


    greetz.

    Eine Frage an Benutzer eines Canon Drucker der IP-Serie. Ich hatte vor ca.: 1 Woche einen DVD+R 16x printable Rohling von Verbatim gebrannt und bedruckt. Nun habe ich mir die DVD heute nochmal angeguckt und bin leicht mit dem Finger über die DVD-Oberfläche gegangen. Resultat - es verwischte! Ich selbt benutze einen IP 4200 mit original Tinte und bedrucke den Rohling mit der Standardeinstellung (Treibermenü).
    Hat noch jemand ein ähnliches Problem bzw. druckt mit o.g. Kombination?

    Verbatim 8x DVD+R DL Jewelcase, MiT
    MKM-003-000
    Samsung SH-223F fw. SB00
    4x gebrannt





    Allgemeine Informationen
    Laufwerk: TSSTcorpCDDVDW SH-S223F
    Firmware: SB00
    Disk: DVD+R DL (MKM-003)
    Gewählte Geschwindigkeit: 4x


    PI errors
    Maximum: 24
    Durchschnitt: 3.36
    Gesamt: 10766


    PI failures
    Maximum: 3
    Durchschnitt: 0.01
    Gesamt: 2471


    PO failures: 0

    Verbatim 8x DVD+R printable
    MCC-004-000
    Samsung SH-223F fw. SB00
    22x gebrannt





    Allgemeine Informationen
    Laufwerk: TSSTcorpCDDVDW SH-S223F
    Firmware: SB00
    Disk: Verbatim 8x DVD+R printable (MCC-004-000), MiT, erst bedruckt dann gebrannt
    Gewählte Geschwindigkeit: 4x


    PI errors
    Maximum: 13
    Durchschnitt: 1.37
    Gesamt: 22225


    PI failures
    Maximum: 3
    Durchschnitt: 0.02
    Gesamt: 2068


    PO failures: 0

    Verbatim 8x DVD+R printable
    MCC-004-000
    Samsung SH-223F fw. SB00
    12x gebrannt





    Allgemeine Informationen
    Laufwerk: TSSTcorpCDDVDW SH-S223F
    Firmware: SB00
    Disk: Verbatim 8x DVD+R printable (MCC-004-000), MiT, erst bedruckt dann gebrannt
    Gewählte Geschwindigkeit: 4x


    PI errors
    Maximum: 11
    Durchschnitt: 1,15
    Gesamt: 20228


    PI failures
    Maximum: 2
    Durchschnitt: 0.01
    Gesamt: 1497


    PO failures: 0

    Hallo,


    ich bin auf der Suche nach Erfahrungswerten. Daher interessiert mich, ob jemand die o.g. Rekorder sein eigen nennt und welche DVD-Rohlinge er benutzt.


    Natürlich macht der Hersteller Angaben zu Rohlingen die ideal für das Gerät sein sollten. Darauf kann man man sich nur nicht immer verlassen, das musste ich schon leidvoll erfahren.


    Zur Zeit fahre ich mit den "Intenso DVD+RW 4x" ganz gut. Würde gerne auch andere probieren, und bevor ich von jeder Sorte einen Proberohling kaufe kann ich ja mal fragen. Ein Auge habe ich schon auf die Rohlinge von Verbatim geworfen ("Verbatim DVD+RW 2,4x"). Der wird u.a. auch von LG empfohlen.


    Auf dem Gebiet der -+R´s hab ich noch keine (guten) Erfahrungen machen können. Dort hatte ich ebenfalls von Intenso welche, die "Intenso DVD+R 8x", die ich auch erfolgreich brennen konnte, mir aber beim oder auch nach dem Finalisieren ein Discfehler angezeigt wurde und nichts mehr ging.


    Also wenn jemand die gleiche Konstellation hat, wäre es klasse wenn dieser etwas zu dem Thema schreiben könnte. Bin für alles offen, auch für DVD-R´s.


    Gruß

    Aso, danke für die Info. Bin eh die meiste Zeit am testen, welche Rohlinge nun "die besten" für mein Laufwerk sind. Bin gespannt, was mein neuer Brenner (Samsung SH-S223F), der Ende der Woche eintrudelt, zu den Rohlingen sagt.


    btw, irgendwas scheint mit imageshack nicht zu stimmen, vorhin war in meinem Post nämlich noch ein Grafik zu sehen.