Beiträge von willisurf

    Es ist schon ganz schön unübersichtlich mit den ganzen Formaten...
    E-Ac3 ist wieder was anderes als Ac3. Normale Ac3 Tracks werden in der Standardeinstellung nicht neu encodet.


    Wenn jmd die Parameter für eac3to betreffend e-ac3 kennt - immer her damit.


    Siehe auch:
    http://sites.google.com/site/xorphdstuff/remuxing


    Nur eine Vermutung, warum vielleicht unabhängig von den Einstellungen aus dem 768kbps E-AC3 mit eac3to immer ein 640kbps Audio Track extrahiert wird.


    Falls eac3to den E-AC3 Track wie einen TrueHD Track behandelt, wird mit der extension "AC3" in der Kommandozeile immer der 640kbps core extrahiert. Steht zumindest unten auf der von Hawk zitierten Seite bei den Beispielen nach step3.


    Bleibt die Frage ob E-AC3 einen 640kbps Core hat (konnte ich nicht genau herausfinden) und ob eac3to dieses Format wie TrueHD (was es ja nicht wirklich ist) behandelt.

    Ja kla hab schon alle dinger durchprobiert! Er codiert immer die 640kb/s in AC3 egal welchen Punkt ich setze!


    Könnte es vll was mit den Nero dings zu tun haben das ich mit in den vorherigen Logs gepostet habe?


    Nein, die Meldung "The Nero decoder doesn't seem to work, will use libav instead." ist normal.
    Es gibt mir eher zu denken, das es sich um eine m2ts einer HD DVD handelt. Ich weiss aber nicht ob BD und HD DVD in Bezug auf die m2ts Dateien kompatibel sind.

    Nun meim Problem in der m2ts datei habe ich eine Tonspur von 768kb/s, die ich auch gerne behalten möchte^^ nur der BluRip wandelt sie immer in eine 640kb/s egal welche Einstellung ich unter Entcoding Einstellungen mache!.
    Was muss ich denn machen das er die Tonspur so übernimmt und nicht neu Entcoded?

    Hast Du mal versucht auf der Seite "Encoding settings" bei "Audio settings" das Kreuz bei "Untouched Audio" zu setzen?
    Eigentlich sollte dann doch Audio nicht transcodiert werden.

    kannst Du mir kurz verraten, was hinter dem Changelog-Eintrag
    "v0.4.6.1 - Removed check for CuvidServer.exe" steckt?


    ab 0.4.6 wird DGMultiSource statt CuvidServer zum Decodieren benutzt (wenn gewählt). In der 0.4.6 war fälschlicherweise noch die Abfrage auf Cuvidserver enthalten. Dies führte zur Fehlermeldung wenn DGSource zum decodieren ausgewählt war.
    siehe auch http://forum.doom9.org/showthread.php?p=1381698#post1381698
    Mit der 0.4.6.1 wurde dies korrigiert.

    So langsam muss ich die Oberfläche wohl mal neu designen - sonst wirds zu unübersichtlich.


    Wenn Du die Oberfläche überarbeitest, könntest Du so etwas einbauen wie das automatische Vorfüllen der Felder "Target Filename" und "Movie Title"?
    Als Quelle zum Vorbefüllen würde sich m.E. in vielen Fällen der Directory Name der BD Quelle anbieten. Es schadet ja nicht, da es jederzeit überschrieben/geändert werden könnte. Bzw. könnte es ggf. abschaltbar sein.


    Parallel wäre für mich hilfreich, wenn beim Auswählen einer neuen Quelle der Start nicht immer wieder von "ganz oben" sondern entweder beim zuletzt gewählten Directory (bzw. sinnvollerweise eine Ebene höher) oder auch bei einem wählbaren Directory starten würde. Das würde etwas Klickerei sparen. Ist aber natürlich Feintuning :-))

    Allerdings hab ich sonst erstmal nichts mehr auf meiner "Liste"

    Hallo Hawk,
    was meinst Du zu meinen Ideen?
    http://forum.gleitz.info/showpost.php?p=404770&postcount=137
    Test habe ich gemacht, so ganz glücklich bin ich mit der Speicherung des Logfiles im temporären Verzeichnis nicht. Ich benutze den Prefix nicht. Im MKV Ausgabeverzeichnis mit eindeutigem Namen z.B. aus MKV Dateiname (und ggf sogar mit Datum/Uhrzeit im Namen) fände ich eindeutiger falls es etwas nachzusehen gibt.


    http://forum.gleitz.info/showpost.php?p=404772&postcount=138

    Zwei Anregungen zur Streamauswahl hätte ich noch aus den bisherigen Erfahrungen.


    Es wäre toll, wenn die Streamauswahl mit Checkboxen o.ä. möglich wäre. Falls ich jetzt mal die CTRL Taste nicht richtig gedrückt habe
    (Grobmotoriker ;-)) und dann klicke, ist alles deselektiert.


    Die automatische Streamauswahl entsprechend den bevorzugten Sprachen ist sehr hilfreich. Ideal wäre für mich eine getrennte Sprachauswahl für Audio und Subtitel. Hintergrund: Ich möchte als Audio Spuren "Deutsch" und "Englisch" und als Untertitel nur "Deutsch". D.h. momentan sind beide Sprachen ausgewählt, daher darf ich immer schön alle englischen Subtitel deaktivieren. Eine getrennte Auswahl der Sprachen für Audio und Subtitel würde das elegant lösen.

    Code
    1. SaveLog(richTextBoxLogMain.Text, settings.workingDir + "\\" + settings.filePrefix + "_completeLog.txt");


    Ist schon drin :)
    Solange jeder Job ein anderes fileprefix benutzt wird auch nix überschrieben.


    Tolle Sache! Ich lasse gerade einen Test laufen.
    Wenn ich das richtig verstanden habe, unterscheiden sich die Logs z.B. im Queue Betrieb nur, wenn ich einen Prefix vergebe. Ich benutze das bisher nicht. Wäre es nicht sinnvoll die Logs einfach mit dem MKV Output Namen zu versehen? Naja ich bin mal auf den Test gespannt.

    v0.4.6


    Hallo Hawk,
    Klasse, wieder etwas neues zu testen:)


    Könntest Du in eine der nächsten Versionen ein automatisches Abspeichern des Logfiles in das MKV Ausgabeverzeichnis mit einbauen?
    Könnte ja über eine Checkbox wählbar sein. Es würde helfen, wenn es im Queue Betreieb oder nach dem Schliessen des Programmes noch etwas zu klären gäbe.


    Vielen Dank für das super hilfreiche Programm!!:daumen::daumen:

    Ich habe mit der Version 0.4.5 (und wahrscheinlich auch Vorgängerversionen) folgendes Problem beim Autocrop entdeckt, da die Datei _002_video.mkv.ffindex nicht gelöscht wird.


    Folgender reproduzierbarer Ablauf:


    - Working Directory ist leer
    - Film A wird normal transcodiert, Haken bei "Delete source files after mux" ist gesetzt
    - Programm wird beendet
    - es bleiben die 3 Files "_001_chapter - Log.txt" "_compleLog.txt" und vor allem "_002_video.mkv.ffindex" im Working Directory zurück
    - Programm wird neu gestartet, Film B wird ausgewählt, Start
    - Autocrop stolpert über die nicht passende "_002_video.mkv.ffindex" (von Film A)


    Logauszug bis zum Ende
    .
    .
    [03.03.2010 20:10:00] Stream size : 12.2 GiB (98%)
    [03.03.2010 20:10:00] Proportion of this stream : 0.97912
    [03.03.2010 20:10:00] BufferSize : 3749952
    [03.03.2010 20:10:00]
    [03.03.2010 20:10:00] D:\Temp\_002_video.mkv.ffindex already exits
    [03.03.2010 20:10:00] Starting AutoCrop...
    [03.03.2010 20:10:03] Exception: FFVideoSource: The index does not match the source file
    (D:\Temp\_cropTemp.avs, line 1)

    hey... ne kurze frage:


    Hab die selbe 40 minuten folge von prison break mit crf 20 und 22 konvertieren lassen, und bei beiden kam auf ca 2kb genau die selbe größe raus!!!


    Das dürfte doch normal gar nicht sein oder???

    Doch das kann ohne weiteres sein. crf berechnet konstante Qualität ohne Aussage über die Größe, die Werte die ich vorher mal genannt hatte waren auch nur Richtwerte. In Deinem Fall war die Folge die mit crf 20 konvertiert wurde einfacher zu komprimieren (ruhigere Szenen etc) und liefert daher höhere Qualität ohne größer als die schlechter komprimierbare Folge zu sein. Also alles ok.


    In Summe kann man sagen: Wenn die Größe nicht vorhersagbar sein muß, ist crf die beste Kompressionsmethode mit konstanter vorhersagbarer Qualität.

    so, der film ist fertig, jedoch habe ich jetzt das problem dass der film ohne ton und untertitelspuren vorhanden ist.


    Warum das=???


    Hab das Changelog leider nicht mehr weil das so um 1:30 heute früh fertig war, und der computer sich dann bgedreht hat...


    Kann es sein, das Du keine Audio- und Subtitelspuren ausgewählt hast? Wenn Du jetzt das Log nicht mehr hast, bau Dir doch zum Testen mal ein Profil mit dem "--preset ultrafast" dann kannst Du schneller testen. Um danach den Film mit den richtigen Einstellungen durchlaufen zu lassen.


    Sollte das Problem immer noch bestehen, bekommen wir das Problem mit Hilfe des Log dann sicher gelöst.
    Hawk : Könntest Du in eine der nächsten Versionen ein standardmäßiges wählbares Speichern des Logs einbauen? Wegen Queue am besten mit wechselndem Namen.



    Kann man die ton und untertitelspuren noch in die video mkv reingeben???


    Geht sicher, ist aber m.E. etwas fummelig. Vielleicht wissen andere mehr dazu.

    [26.02.2010 18:58:51] Command: C:\Program Files\megui2\tools\x264\x264.exe--preset slow --tune film --crf 18.0 --level 4.1 "C:\Temp\testst_encode.avs" -o "C:\Temp\testst_video.mkv"


    [26.02.2010 19:01:06] [0.7%] 420/63337 frames, 3.19 fps, 15355.76 kb/s, eta 5:28:57


    ITS RUNNING!!!!


    Glückwunsch!


    Nicht verwundert sein, wenn das MKV File recht groß ist. Der Parameter crf=18 ergibt eine super Qualität, bei entspr. Größe. Ich persönlich kann mit crf=21..22 sehr gut leben. Damit sind die MKV´s bei normalen Filmen (1:40-2:20h) so um die 6-10GB.


    Morgen weisst Du mehr. Ich kenne das, habe in etwa die gleiche framerate.


    Hawk 26.02.10 22:45Uhr 500 Downloads erreicht Tolles Proggi!
    http://code.google.com/p/blurip/downloads/list

    Wenn du willst kann ich es gerne testen. . . habe sowieso ein paar blu rays zum rippen, aber derzeit mit megui probleme (mit der qualität)


    Hab mir dein programm schon runtergeladen, und werde es heute gleich mal versuchen. . .


    Je mehr Tester desto besser wird das Programm


    EDIT: Eine Anleitung wäre noch super!!!


    Hier werden noch freiwillige gesucht...
    Vielleicht hilft das für die Installation http://forum.doom9.org/showpost.php?p=1367545&postcount=21