Beiträge von honeymoon

    Ich glaube dass der Fehler bei MAGIX liegt, anders kann ich mir die Beobachtung nicht erklären: Das Weglassen bestimmter frames tritt nur dann an den besagten Stellen auf wenn ich den .mts-Stream mit der MAGIX-Projektdatei, in der alle Effekte und Schnitte gespeichert sind, öffne...
    Wenn ich hingegen den Stream neu und ungeschnitten in die Timeline importiere tritt dieses Fehlen der einzelnen Bilder an den gleichen Stellen im Film nicht auf.
    Warum sich diese Anweisung bestimmte Frames wegzulassen in die Projektdatei geschlichen hat weiß ich nicht, ich glaube dass das ein Bug ist... ich kann keine Regelmäßigkeit in den Szenen des Films die solch ein Phänomen provozieren könnten erkennen.

    Nun ja, es ist keine segmentierte Datei, es ist eine 26 GB große, einzelne Videodatei... und wenn ich sie mit Selur's Hybrid nach ProRes umwandle lässt MAGIX trotzdem immer die gleichen Frames beim decodieren weg, man sieht es auch schon im Vorschaufenster wie es immer an den gleichen Stellen ruckelt... Ich nehme mal an dass da irgendein "Fehler" in der Originaldatei vorhanden sein muss, aber ich verstehe nicht dass sich dieser weder beim Original, noch beim Abspielen der ProRes-Kopie mit vlc-player bemerkbar macht, da sind diese Stellen seltsamerweise alle flüssig. Welche Reparaturprogramme sind gemeint ?

    Vielen dank für die Tipps !
    Ich bin nur ein Halbwissender und muss gestehen dass ich etwas verwirrt bin weil ich entsprechende Häckchen im configuration dialog nicht entdecken kann, unter "Main" bei "tune" gibts bei mir nur kryptische PSNR oder SSIM und unter "Keyframe" finde ich auch nichts anklickbares, von daher weiß ich nicht mit welchem Wert bei x264 normalerweise gearbeitet wird damit ich ihn entsprechend anpassen könnte. Verstecken sich diese Dinge möglicherweise unter anderen Begriffen im Konfigurations Dialog ?

    Nein, scheint auch bei meiner Video deLuxe 16 nicht zu funzen, aus welchen Gründen auch immer... schade.
    Dann bleibt mir nur noch die von euch vorgeschlagene Möglichkeit des Umwandelns. Ich weiß nicht ob das vergleichbar ist, aber ich erinnere mich dunkel als ich früher den "Maximum i-frame Interval bei xvid von 300 Bildern auf 12 runtersetzte konnte ich flugs darauf auf der Timeline völlig flüssig und verzögerungsfrei arbeiten. Mache ich vielleicht einen Denkfehler wenn ich mir überlege dass es vergleichbar dazu doch möglich wäre den x264 so einzustellen dass der Rechner sich so ähnlich wenig beim Dekodieren abmüht ? Falls das nicht so klappt wie ich mir das erhoffe werde ich wohl den Kauf einer neuen großen Festplatte überlegen müssen.

    Danke für den Upload !
    hm... bei mir wird zwar das .avi erzeugt, allerdings sagt mir Magix ProX dass das Dateiformat nicht gelesen werden könne und ich einen Codec installieren soll der das Format "AVIS" decodieren kann... habe ich vielleicht mit "ffdshow_rev4532_20140717_clsid" eine falsche ffdshow version installiert ?


    Gerade probiert, virtual dub kann die pseudo avi öffnen, vielleicht ist mein MAGIX Video ProX zu modern... Matt Kirby, mit welcher MAGIX version funktioniert es denn bei dir ?

    auf die Idee das Video umzuwandeln bin ich noch nicht gekommen, das ist gut. Allerdings bin ich mit der Qualität von x264 so zufrieden dass ich mir gedacht habe das Original in diesen Codec zu wandeln... Dazu wäre es aber sinnvoller die "Referenz-frames" auf die sich alle anderen frames hinterher ableiten auf 1 oder 2 pro sekunde zu setzen. Nun sehe ich aber dass 3 "Reference-frames" schon als default in den Settings eingestellt sind. Sorry für meine Unwissenheit, heißt dass damit tatsächlich 3 Referenzbilder pro Sekunde gemeint sind ? Falls nicht, wie kann ich es so einstellen dass der Rechner möglichst wenig beim Resultat abspielen der Umwandlung hinterher rechnen soll ?

    Hallo.
    Wenn ich in mein Video-Schnittprogramm eine Videodatei (AVCHD mit .mts Endung) importiere geht das gut, aber der interne Decoder scheint nicht akkurat zu arbeiten, es werden hinterher wenn es zum rendern gehen soll offensichtlich an manchen Stellen frames ausgelassen so dass Audio und Video hinterher nicht mehr passen. Gäbe es eine Möglichkeit den File-Indexer von MeGui zum Import zu verwenden indem man mit Hilfe eines Programms die avs-Datei in eine "Pseudo"-videodatei kleidet die ich dann statt der Originalen ".mts" datei in das Schnittprogramm eventuell importieren könnte ?

    seltsam... aus irgendeinem Grund mag der File-Indexer von MeGui es nicht wenn ich besagte datei per Drag&Drop reinschmeisse. Daran lag es dass er sofort abstürzte als es zur Sache gehen sollte.
    Wenn ich dagegen die Videodatei über das Fenster "Video Input" suche und hinzufüge funzt alles wie es soll. Verstehe das wer will.
    Danke auf alle Fälle für die Antwort.

    Weiß nicht seit wann es bei mir auch so ist, daher kann ich auch nicht beurteilen ob es an dem selben oben beschriebenen Grund liegt... DirectShow bei MeGui aktivieren nützt bei mir nichts. Bei mir blitzt das Fenster zum Fileindexer kurz auf wenn der Prozess starten soll und ist dann einfach weg. Habe dann ffdshow_rev4533_20140929_clsid_x64 neu installiert, hat aber nichts gebracht.

    Hmm, irgendwas mach ich wohl falsch... Bild wird zwar auf 23976 runtergepulldowned, sieht aber trotzdem irgendwie nach 29940 aus, erkennbar an diesen kaum wahrnehmbaren mini-ruckelchen und unsauberen Bildübergängen...


    fehlt hier eventuell noch was ?


    LoadPlugin("D:\MeGUI_2153_x86\tools\lsmash\LSMASHSource.dll")
    LWLibavVideoSource("G:\bla.mkv")
    LoadPlugin("D:\MeGUI_2153_x86\tools\TIVTC\TIVTC.dll")
    tdecimate()

    Habe hier eine 29.940 interlaced Quelle in AVC codiert, wie kriege ich das nach 23.976 ?
    Wenns mpg wäre würde es mit dgmpgdec157 und honor pulldown vermutlich sauber hinkriegen... aber was nehme ich am besten für AVC ?

    ich habe nun ein paar Testdurchgänge mit verschiedenen CRFs gemacht und kann nun nachvollziehen warum einige meinen das wäre eher was für Zeichentrick oder Animes.
    Trotz "tune grain" schaffe ich es nicht feines Rauschen so abzubilden wie x264 das auch bei eher niedrigen Bitraten kann, bei ungefähr gleicher Dateigrösse. Grobes Rauschen in einer Szene wird bei "tune grain" gut dargestellt, sobald es aber um feineres Korn geht bügelt x265 das irgendwie unter, es scheint so eine "Schwelle" zu geben, "Alles oder Nichts" sozusagen... Gibt es ein Kommando mit der ich diese Schwelle beeinflussen kann ?

    Die Einstellungen findest Du unter Options->Externel encoders.
    Einfache Kommandozeile für x264:
    --demuxer raw - --input-res %(width)x%(height) --fps %(fpsnum)/%(fpsden) -o "%(tempvideofile)" --crf 23 -o video.mkv


    das funzt mit der x264-10bit version, danke...
    habs aber nun mit den gleichen parametern mit der x265.exe probiert, aber da klappts nicht wegen pipe-error...
    müssen andere parameter her oder gehts grundsätzlich nicht mit x265 ?