Beiträge von DeafYakuza

    3x bekam ich die Fehlermeldung, dass VirtualDub mit Avisynth Script kurz vor Ende des Encodings zum Sturz führte.

    Welche Ursache könnte es sein? Was fehlt es?


    Im VD habe ich das Encoding als AVI abgespeichert.


    VirtualDub Error:


    virtualdub_error1mj7l.jpg


    Hier mein Avisynth Script:



    Dann dachte ich, ich versuche mal mit der Teilung zu encoden. Die ersten 3 Encodings hatten Erfolg, aber der 4. scheiterte mit der Fehlermeldung:


    Code
    1. Avisynth read error: Could not allocate video frame. Out of memory. memory_max=1073741824, memory_used=893502716 Request=4717119


    virtualdub_error1f3jbg.jpg



    Kann jemand mir bitte erklären?


    Zur Info, das 1. Encoding von vorher mit demselben Skript hat durchgehend geklappt.

    Es ist wirklich schwer das zu ermitteln, aber mir scheint, dass sie nicht interlaced ist.

    Ich habe ein Videodatei hier angelegt und ihr könnt checken. PW ist gleich mein Username.

    Dieser Film wurde laut imdb mit einer Panavision Cameras (70mm) gedreht und zwar mit 24fps aufgenommen.


    bergh, da die Quelle in 23.976fps ist, deshalb muss ich das gecapture Video nach 23.976fps umwandeln, um sie in die Hauptquelle einzufügen möchte Sprich "HD mit SD Inserts".


    Außerdem das Video hat blending.


    Hallo,


    seit 2 Tage versuche ich vergebens meinen Erfolg zu erzielen. :-(

    Hier in diesem Forum sehe ich nach der Suche "PAL nach NTSC" kein passendes Thread, was mich helfen könnte und bin fassungslos, dass keiner hier über Wandlung von PAL nach NTSC gepostet hat außer einen, der mal hier gepostet hat, aber sein Video ist progressiv, meiner ist interlaced.

    Ich habe mich bemüht, viele Seiten und Foren viel durchzulesen und zu verstehen, leider bis jetzt verstehe ich immer noch nicht ganz 100%, wie man das Video sauber deinterlacen kann. (Theoretisch brauche ich jemanden, der an meiner Seite am PC sitzt und erklärt. Naja, ich bin meistens schwer vom Begriff wegen der Gehörlosigkeit.)

    Ich möchte nur mit Avisynth-Script betreiben, weil es beste ist.


    Hier mein Script und ist das so richtig für die Umwandlung nach NTSC (Progressive) mit FPS von 23.976?



    Vielleicht kann hier einer mir helfen (eventuell der gute Mr. Erklär-Bär LigH).

    Ich habe ein Film (Format AVI, lossless) von der VHS (PAL) mit 625i50 gecaptured und möchte sie nach NTSC (23.976fps, progressive) umwandeln und zwar mit Avisynth Script.

    Nach Umwandlung möchte ich das Video dann mit Sony Vegas weiterbearbeiten, weil die Hauptquelle auch in 23.976fps vorliegt (HD mit 1080p) und möchte deswegen das Video in das HD-Master einfügen und hochskalieren. Da die Blu-ray weltweit CUT ist.


    Hab WinRAR Datei angehängt, um AVI-Videodatei mit Avisynth-Script besser zu erstellen, wenn jemand es kann:


    https://www.file-upload.net/do…ed_by_DeafYakuza.rar.html





    Hier das gecapture Video:



    oder Ut Video Lossless Codec:



    So, ich geh jetzt schlafen, morgen werd ich weiter machen.



    Gruß :)

    MeGUI ist wirklich schrott geworden! Bei mir kommt ständig zum Absturz, auch wenn ich eine ganz kleine Stereo-Tonspur gerendert habe und habe auch viele Wege ausprobiert - kein Erfolg! MeGUI wird von mir verabschiedet! Dann suche ich eine Alternative.


    Edit: Mit TFM Audio Tool klappt wunderbar und die erstellte 6 Kanäle sind sauber.

    Hab alles gelöscht, dann noch einmal mit Progi durchgeführt, scheitert wie immer am Ende, dann wollte ich mit CMD durchführen und es läuft irgendwie schon, aber der Blinker blinkt seit ca. 20 Minuten schon und im Ordner sehe ich, dass es noch immer 0KB der ausgegebenen Datei ist. Mir scheint, dass diese CMD wie MeGUI nicht mehr weiter durchführen kann.



    Ah, ich hätte 4 Dateien "3e38010987e.........." nicht löschen sollen, dann habe ich nach Scheitern des Programms wieder in den Aviscript eingefügt und mit CMD noch einmal durchgeführt, dann bekam ich die nächste Meldung:



    Auch auf anderen Windows stürzt MeGUI ab. Ich glaube, diese Version wurde von Entwickler irgendwie verschrottet.


    Und jetzt sieht bei mir so aus:



    :|

    Leider kein Erfolg!


    Avisynth-Script als Hochzeitsfeier.avs gespeichert und mit MeGUI unter Avisynth-Script geöffnet.

    Code
    1. WAVSource("F:\Videobearbeitung\Eigene Videos\Projekt\Hochzeitsfeier.wav")


    Hab ich MeGUI richtig installiert?


    1. MeGUI-2913-64 entpackt

    2. Ordner im C:\Program Files als MeGUI 2913-64 eingelegt und die Dateien hinzugefügt.

    3. Options -> Auto Upldate: Häckchen für UseAutoUpdate beibehaltet und als "Use devolopment update server" gesetzt.

    4. Updates durchgeführt, Programm neugestartet, dann müsste es normalerweise funktionieren, leider scheitert es.

    Hm...


    Bei mir steht nichts von WAVSource im MeGUI. Wie muss ich installieren?


    Audio-Info:


    Ich hab schon oft nur Audio encoded und hat prima geklappt, aber jetzt nicht mehr. Ich verstehe das nicht.

    Erst wenn das Encoding zu Ende ist (bis 100%), stürzt MeGUI ab.

    Dann hab ich Tonspur reingehört und auch mit Audacity gecheckt, die Tonspur ist kaputt.


    Was ich gemacht habe, ist:


    1. MeGUI geöffnet

    2. Audio Input als wave

    3. Config -> Preferred Decoder: FFAudioSource, Output Channels: Upmix 2 to 5.1 via SuperEQ (slow), Sample Rate: Keep Original S. R., Time Modification: Keep Original und die Bitrate: 448kbps.

    4. OK

    5. Queue


    Hab mit MeGUI x64 (Version 2924) unter Win10 64-bit ein Problem.

    Jedesmal, wenn ich eine Wave-Spur mit 2 Kanäle nach Dolby Digital mit 6 Kanäle encodiere, stürzt MeGUI ab und die Tonspur ist verschrottet.


    Welche Ursache liegt es daran? Was kann ich tun, damit sie bis Ende erfolgreich abschließt? Im alten Windows war es nicht so.


    Jetzt klappt Deblock_QED plötzlich wieder, wahrscheinlich habe ich einen falschen Parameter eingegeben.


    FFMS2 oder L-SMASH Works sind zu kompliziert für mich, um sie zu installieren, bzw. im allgemeinen zu verstehen und durcharbeiten, da ich sonst andauernde Fehlermeldungen unterhalb der Videopreview bekomme. Darauf kann ich gut verzichten und stattdessen ist mir die DGAVCDec lieber.

    Mein CPU ist Intel Xeon E5 2680 v2 @2.80 GHz:


    Ich möchte nur die Artefakte entfernen, leichtes ReGrain und die Nachschärfung meines Videos hinzufügen und zwar mit Avisynth bearbeiten und dann mit ffmpeg nach mp4 mit ähnlichen hohen Bitrate encodieren. Die Reste bleiben wie die Quelle entsprechend.

    Komme mit dem Skript nicht weiter, weil die Fehlermeldung unterhalb des Preview-Video aufgetreten ist und lässt sich nicht verschwinden, was ich versucht habe, es hinzukriegen.


    Kann mir einer helfen?



    Code
    1. Fehler: System exception - Illegal Instruction
    2. (C:\Program Files (x86)\AviSynth+\plugins+\Deblock_QED.avs, line 58)
    3. (C:\Users\DeafYakuza\Desktop\Film.avs, line 4)



    Wenn ich "Deblock_QED()" entferne, dann erscheint das Videobild im Preview.


    Avisynth-Script:


    Code
    1. LoadPlugin("C:\DGAVCDec109\DGAVCDecode.dll")
    2. Import("C:\Program Files (x86)\AviSynth+\plugins+\Deblock_QED.avs")
    3. AVCSource("H:\Film.track_1.dga")
    4. Deblock_QED()



    truelies1994openmattek0jv9.png


    truelies1994openmattexjjym.png


    MediaInfo:


    Darf ich fragen, wieso muss man in TS umwandeln, wenn man Original schon hat? Mir geht's nur darum die farbige Untertitel von der Videodatei TS rauszunehmen und in den MKV muxen.

    Ich wusste nicht, dass das Abspielprogramm "PotPlayer" gibt und wie ich ihn sehr schätze, finde ich deutlich viel besser als VLC und MPC-HC.


    Habe mit 3 verschiedene Software in Sachen Untertitel beschäftigt:


    - ProjectX

    - TS-Doctor (getestet mit v1.2)

    - CCExtractor


    ProjectX macht das wirklich sehr gut und finde den am besten, wenn man farbige Untertitel (SAA) von der TS-Videodatei extrahieren will und alle Untertitel sind komplett enthalten, auch doppelte oder mehrgleiche Untertitel mit unterschiedlichen Timecodes werden mit hineingezogen. Was ich mit damit meinte, siehe hier: https://cypheros.de/forum_ger2/index.php?topic=4603.0

    Man muss nach dem Extrahieren mit Subtitle Edit oder andere Wunschsoftware die Times synchronisieren, damit sie zu den Dialogen angepasst werden muss, sonst stimmt es nicht, da die UT-Timings ein wenig verschoben wurde, aber das ist ja nicht so schlimm.

    Der kann sogar von der dunklen/schwarzen Sendungen, sowie Freezes oder beschädigte TS-Videodatei Untertitel komplett extrahieren.

    Ein kleiner Negativpunkt hat er auch, aber man kann zum Bsp. mit Subtitle Edit nacharbeiten, um unnötige Zeichen "{\q2\a2}" und "<font color="#ffffff"></font>" auf einmal zu entfernen, damit die Untertitel im Film sauber rüberkommen.


    Zuerst "{\q2\a2}" löschen, dann...



    ...diese "<font color="#ffffff"></font>"



    TS-Doctor macht ganz gut, nur 1 Negativpunkt ist, dass doppelte oder mehrgleiche Untertitel in eine Zeile zusammengefügt werden, was ich nicht gut finde, weil... (siehe Links oben)


    CCExtractor würde ich nicht empfehlen, weil zu viele Untertitel Zeilen werden nach Extrahieren vermisst, falsche Zeitlänge festgelegt und ebenso doppelte oder mehrgleiche Untertitel wurden zusammengefügt.


    Extrahiert mit CCExtractor:



    Extrahiert mit ProjectX: