Beiträge von -TiLT-

    Gehe bei beiden in das VTS_PGCITI, und dort in das entsprechende PGC, dass du ändern bzw kopieren willst. Aus der quelldatei nimmst du nun die values für audio stream x status und subpicture stream x status raus (doppelklick und kopieren) und kopierst es in die neue vob rein. Für jeden stream einzeln.


    In der neuen video_ts gehst du in die VGM_VTS_ATRT ebenfalls zu dem betreffenden PGC und erhöhst die Anzahl der Subpicture- und Audiostreams, um sie dem original anzugleichen. Dann stellst du abschließend noch alle Sprachen richtig ein, und nun sollte es gehen.

    Zerteile die vobs mal pro cellid (mit vobedit), und setze diese dann passend wieder aneinander (filemerger) bis du die gewünschten Größen erreichst. Dann sollte es besser gehen. Ich drück dir die daumen, dass die Kapitelsprünge erhalten bleiben.

    Gute anlaufstelle: Restream. checked demultiplexte files.
    Oder M2edit Pro checked multiplexte mpegs.



    Aber mal was anderes. Du schreibst du hast den film schon in MPEG2 aufgenommen. Ganz sicher? Wenn dem nämlich so ist. Sprich du hast die Aufnahme in MPEG2 für´s Video und MP2 für den ton schon gemacht, dann bräuchtest du nicht zu multiplexen. Es wäre zwar nicht die feine englische, aber probiere mal nur die Mpeg in VTS_01_1.VOB umzubenennen und dann mit ifoedit bei create new ifos nur das drumrum kreieren zu lassen. (Bleibt nur das prob mit den 44,1 khz, aber soll auch nur zum testen sein)


    Und zuguterletzt kannst du auch noch versuchen mit virtualdubmod den ton zu extrahieren.


    Dass der ton asynchron wird beim demuxen hab ich übrigens noch nie gehört.


    Allerdings gibt es sowas wie Delay, und du sprichst ja von einer Verschiebung. Finde mal heraus, ob bild und ton exakt gleich lang sind. Du bräuchtest ein programm, was solch ein delay herausfinden kann. vobedit kann das mit vobs, aber bei mpg bin ich mir nicht sicher.


    Virtualdubmod könnte dafür auch ne funktion haben, aber da leg ich nicht die hand für ins feuer.


    Viel erfolg noch.

    Hmmm


    postcomand in die ifo setzen, jump to title soundso, darin in diesem title eben das wechselbild authoren, und in der ifo vom wechselbild ebefalls einen postcommand jump to titleset, der auf sich selbst linkt.
    Muss dann noch in der VIDEO_TS eingebunden werden. Wie genau... leider überfragt, aber so ähnlich würde ich es machen.


    Letztemdlich: Erste DVD mit DVD Fab machen, zweite mit ifoedit :)

    Hm, komme nicht ganz dahinter wie du das meinst.


    Eventuell beim Musikvideo noch 4 Dummyspuren dazupacken. Eventuell stimmt die Samplingrate auch nicht.


    Ich kenne DVDLab noch aus Zeiten, als nur eine einzige Tonspur drin war, und alle Einzelmovies in ein riesiges VTS geklatscht wurden, von daher bräuchte ich zumindest, mehr infos, um zu helfen.

    Edit: Sorry falsches Forum, hatte mich vertan. Bitte verschieben nach IfoEdit.




    Also kurz vorweg, was ich bisher gemacht habe:


    Soft:
    Ifoedit 0.96
    Ifoupdate 0.78


    Wollte ein DVD-5 Backup erstellen, von einer DVD, auf der sich ein nicht wirklich großer Rest befindet (knapp 150 mb Menue, etc.) und dabei lediglich das Video des Hauptfilms verkleinern. Netterweise war die Struktur des Hauptfilms sehr einfach gehalten.


    Das Demultiplexing habe ich DVD2DVD-R überlassen, weil ich mit IfoEdit authoren wollte, und DVD2DVD-R das einzige mir bekannte Programm ist, was ordnentlich *.sup Untertitelspuren zusammen mit Video und Audio in einem Rutsch demuxen kann.


    Nach dem Encoding (ich hab dummerweise vergessen beim CCE die chapterpoints zu setzen, was aber nicht so schlimm ist denke ich) des Videos (der Film war so gross, dass ich auf anamorphes Bild verzichten musste :( ) hab ich dann alles mit IfoEdit wieder zusammengesetzt, und die Chapterpoints die mit DVD2DVD-R rausgeschmissen hat nicht verwendet, sondern mit ifoedit selbst von der Originalifo extrahiert.


    So weit so gut, nun fängt mein alldvdlicher Kampf mit IfoUpdate an:


    Ich verwende den "Standart Mode", da meine original DVD 2 PGC´s hat, meine geauthorte nur einen. (Der 2. PGC ist mal wieder so ein nerviger 12frames DummyPGC in vobID 3/1, der sogar als solcher noch dem hauptfilm selbst anhängt. BTW weiss einer wofür das eigentlich gemacht wird? Hab ich bei 9 von 10 DVD´s sowas)


    Meine Einstellungen die Erste:
    Haken an:


    1 Transfer VTS_C_ADT Table
    (2 Copy Audio and Subpicture Tables)
    3 VTS_TMAPTI Table Transfer (Time Map)
    4 Adjust VTS_TMAPTI and ADMAP Sizes
    (5 Autocorrect VTS-Sectors)
    6 und Autoanalyze ifo
    (7 Autocorrect Ifo & Bup length)


    (Werte in Klammern habe ich ohne weiteren Effekt an und abgeschaltet getestet)


    Resultat:


    ...
    -Warning: Source to Destination mismatch
    Original time = 03:12:47
    Newly Authored time = 03:12:46
    ...


    Nun ich glaube das könnte durch DVD2AVI stattgefunden haben, und sollte meiner Meinung auch keine weiteren Probleme mit sich ziehen, aber...


    1. Die ifo wird nach dem ifoupdate größer: 106k nach 128 k
    2. Wenn ich die Ifo danach mit Ifoedit öffne speichern möchte erhalte ich diese Fehler:


    ...
    The file position does not match the offset for table: ID_VTS_C_ADT
    ...
    ...
    The file position does not match the offset for table: ID_VTS_VOBU_ADMAP
    ...
    ...
    The IFO Endsector does not match the file size.
    ...


    Das kann ich beliebig oft widerholen, und auch ein Get VTS-Sectors ändert nichts daran.


    Beim Abspielen:
    PowerDVD: Keine ersichtlichen Probleme. Letztes kapitel will "nicht so recht".
    WinDVD: In den letzten 8/10 der DVD kann nicht mehr mit der Slidebar navigiert werden. DVD spielt nicht komplett durch.
    HWPlayer: Konnte ich nicht testen, mir ist danach der Appetit auf nen verbratenen Rohling vergangen und mein Player kann kein RW.


    Nun ich dachte nicht verzagen, probiers nochmal.


    Nun mit diesen Einstellungen:


    1 Transfer VTS_C_ADT Table
    (2 Copy Audio and Subpicture Tables)
    3 VTS_TMAPTI Table Transfer (Time Map)
    (5 Autocorrect VTS-Sectors)
    6 und Autoanalyze ifo
    (7 Autocorrect Ifo & Bup length)


    also Punkt 4. Adjust VTS_TMAPTI and ADMAP Sizes weggelassen.


    (Werte in Klammern habe ich ohne weiteren Effekt an und abgeschaltet getestet)


    Resultat:


    ...
    -Unequal VTS_TMAPTI table sizes. Not transferred
    - Processing VTS_PGC_1
    -Warning: Source to Destination mismatch
    Original time = 03:12:47
    Newly Authored time = 03:12:46
    ...


    Nun beschwert sich IfoEdit nicht mehr beim speichern, und die Filesize stimmt, aaaber


    Beim Abspielen:
    PowerDVD: Im letzten kapitel der DVd (Abspann) kann gar nicht navigiert werden, dvd hält an diesem kapitel an.
    WinDVD: Navigation in der vorderen Hälfte möglich. Bewegt man den Schieberegler in den hinteren Teil, springt die DVD in die Coyright Hinweise (Witzig nicht wahr :) )
    HWPlayer: Fand das noch blöder und hatte erst recht keine Lust, zu brennen.


    Weiterhin mir nicht erklärlich bleibt mir, dass die originalifo des Filmchens 106k groß ist, die die ifoedit geschrieben hat 118k groß ist. Aufgrund der vielen zusätzlichen Commands hätte ich jetzt gedacht, die Originalifo müsste größer sein.



    Nun ich bin ehrlichgesagt Ratlos. Habe allerlei Foren durchfostet, und bin doch zu keinem Rat gekommen. Habe jede erdenkliche Art versucht die Haken bei ifoupdate zu setzen, und komme zu keinem Erfolg.


    Kann es doch an dem "time mismatch" liegen? Ich kann mir das nicht recht vorstellen, da Ifoupdate ja auch bei Big3 verwendet wird, wo auch mit DVD2AVI gearbeitet wird, welches leichte Veränderungen in der Laufzeit des Videos hervorruft, und da scheint alles mit ifoupdate klarzugehen.


    Wer weiss Rat? Bitte helft mir.

    Hallöchen, ich hab wieder Internet! Juhuu.


    Also mir ist da leider eine DVD-R 10 MB zu groß geraten. Nun möchte ich gerne das Menue, welches ich "unbehadelt" belassen habe mit DVD-Shrink ein wenig eindampfen. Hatte mir also überlegt, ich stelle von meinem Big3 output einfach alles auf keine kompression ausser das Menue selbst, den rest erledigt dann DVD-Shrink selbst.


    Aber leider meckert DVD-Shrink beim öffnen der Files. Und zwar:


    Invalid Data in file: "x\film sowieso\VIDEO_TS\VTS_01_1.VOB.


    Dabei handelt es sich um die erste VOB von 4en die Scenarist geauthored hat.


    Scenarist selbst lief mit den üblichen Warnmeldungen durch die man eher vernachlässigen kann. (So was wie Untertitel, die über ein kapitel hinaus angezeigt werden, etc)


    Jetzt frage ich ob eventuell jemand so ein problem schon vor mir hatte, eine Lösung dafür gefunden hat, oder was ich da wohl falsch gemacht haben könnte.


    Grüße
    -TiLT-

    So, es hat dann doch letztenendes geklappt.


    Für den den es interessiert:


    Den Schnitt habe ich mit einer der 6 Waves (Center) gemacht (ggf per MergeChannels auf stereo aufgebläht)


    Danach habe ich die Tonspur wiederum auf 6 Kanäle aufgebläht ;)


    Virtualdub war davon nciht sehr begeistert, und weigerte sich fadeins und fadeouts im Ton vernünftig zu behandeln. Auch Pegelabsenkungen wurden ignoriert, somit war es entweder totenstill, oder übersteuert. Schade.
    An dieser Stelle dachte ich schon, es wäre alles umsonst gewesen. Jedoch Hab ich mir dann 3 mal die avs datei kopiert, und jeweils Statt 6 kanäle zu mergen, in der ersten datei nur "links, rechts", in der zweiten "rearlinks und rearrechts" und in der dritten "center und lfe" gemerged. Somit war auch Virtualdub wieder ganz brav, und konnte mir so 3 stereowaves liefern, bei denen alles 100%ig funktionierte. Diese mit einem beliebigen Programm in 6 mono´s zerlegt, hab ich jetzt alles als Multichannel Produziert, und freue mich über saftige effekte und einen sauber getrennten lfe ;)



    Grüße
    -TiLT-

    Also wie gesagt, ich denke ich mache den schnitt fertig und füge erst ganz zuletzt die richtigen tonspuren ein.


    Besweet macht übrigens die gleichen "übersetzungsfehler" von 6chwave auf 2chwave wenn big endian pcm abgehakt ist.

    Hi LigH,


    (hatte damit gerechnet, dass du was dazu sagst ;) )


    Hab die grosse 5.1 wave-datei jetzt in 2 "kleiner als 2 gb" dateien zerschnippelt, was sich alleine schon als schwierig darstellte, da hypercube irgendwas am 1.header verdreht, wenn man so eine grosse dts decodiert, und nur besweet damit noch was anfangen konnte.
    Ich bastele, wenn alles so läuft wie ich is mir vorstelle, aus vielen kleinen schnipseln, eine grosse avs mit mehrkanalton
    Diesen demultiplexe ich mich mit Virtualdubmod als 6kanal wave, splitte das in einzelne monowaves und code hinterher alles als ac3 oder dts, mal schauen. Das resultierende video als meg2, und fertig ist mein Intro.


    Nachteil dabei: beim encoden des videos braucht man ne menge speicher (bald 6 gb auslagerungsspeicher brauchte ich beim letzenmal, als ich einfach nur die einzelnen parts aneinandergelegt hatte mit fadein und fadeout effekten. Da hatte ich aber nur ein stück musik als hintergrund genommen. Diesmal will ich, halt die Soundeffekts der schnipsel mit einblenden)


    Ich wundere mich nur, warum das mergechannels bei mir nicht funktioniert. Solange ich nur mit 2 kanälen arbeite funktioniert alles ganz toll, aber mit jedem kanal, den ich dazunehme, wird die Tonhöhe tiefer, und der ton langsamer abgespielt. Also müsste ich das theoretisch mit nem assumesamplerate kompensieren können, jedoch finde ich leider nicht den richtigen wert für 6 kanäle, da auch mein system bei größer 132300 hz nicht mehr mitmacht. Und das mehrmals hintereinander anzuwenden wäre auch nicht gerade toll, noch dazu vermute ich da n paar stolpersteine. Also ich versuchs jetzt mit den beiden gesplitteten files als direkte 6kanalwaves, und hoffe, dass meine kanäle hinterher noch an den richtigen channels liegen.


    Grüße
    -TiLT-


    Edit: Funkt auch nicht. Gleiches Problem. Also ich werde wohl den schnitt erstmal im reinen stereo vorbereiten, und erst vor dem demultiplexen die 6 kanal tonspuren einfügen. Denn witzigerweise werden die avs zu langsam abgespielt, jedoch ist der ton nachdem er von wirtualdub wieder demultiplexed wurde 100%ig in ordnung. Schade, dass es nicht wirklich klappt, aber vielleicht kannst du ja den fehler reproduzieren und kommst der sache auf die schliche.

    Hallo leutz,


    gibt es irgendeine Möglichkeit avisynth dazu zu überreden, 6 Mono waves zu verarbeiten? Ich versuche gerade eine Art "Trailer" zu schneiden, dabei soll es eine Hintergrundmusik geben, und kurze Ausschnitte aus einem Film samt sämtlicher Kanäle eingeblendet werden. Da ich mir einige Scenen mit sehr kraftvollen Effekten ausgesucht habe, würde ich liebend gerne alles in 5.1 "produzieren", jedoch bin ich so langsam mit meinem Latein am Ende. Denn entweder habe ich was überlesen, oder Avisynth arbeitet wirklich "nur" auf stereobasis, bzw bei der ausgabe wird alles auf 2ch downmixed.


    Mein Script (Testphase) siehit bisher so aus:



    Man kann sich ja schon denken was da passiert. Alles wird in slowmo abgespielt, und zwar samt ton, der sich wie ne Schallplatte anhört, die auf 1/4 speed abgespielt wird.


    Also, falls jemand eine Möglichkeit kennt, dass


    a 5.1 in egal welcher Form ohne 2.0 downmix verarbeitet wird
    b 5.1 vielleicht sogar mit einer zweiten 5.1 Tonspur gemischt werden kann
    c Nach dem cutten eine 6 kanal wave oder 6 mono waves extrahiert werden können für eine ->dts/ac3 conversion


    und mir sagt, ob und wie es geht, der würde mir echt weiterhelfen. Ansonsten werd ich mich wohl an Prologic halten müssen, und das wär schade.


    Grüße
    -TiLT-


    P.S. Es sollte noch gesagt sein, dass eine einzelne 6chwav datei über 2 gb gross wäre, weswegen ich den weg mit den einzelnen mono waves gehe.