Beiträge von Massaguana

    Hallo Zusammen,


    ich versuche hier auf meinem Ubuntu Server ein paar Filme vom MKV Container in den MP4 Container samt Web Optimierung zu bringen. Leider erhalte ich eine Fehlermeldung die mir nichts sagt...


    Mein code:

    Code
    1. ffmpeg -i "Input.mkv" -movflags faststart -acodec copy -vcodec copy "Output.mp4"


    Fehlermeldung: Leider kann ich hier nicht die ganze Ausgabe anfügen, zu lang


    Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument


    Was muss ich tun um dies zu beheben?


    Grüße


    Massaguana

    Also bezüglich der Temperatur habe ich mit Hilfe des Tools "Intel Power Gadget" geschaut das der CPU bei unter 100°C nicht ins throtteling kommt. Nach kurzer zeit sieht man das sich die Temperatur und CPU Speed stabilisiert.


    Den Bildschirmschoner Abschalten werde ich einmal testen...


    Was ich tue ist: ein BD Film (Mit MakeMKV extrahiert) in x264 umrechnen. Ton wird nur kopiert. Wird hier der GPU genutzt? Wo in Hybrid sehe ich die Nutzung der GPU?

    Der Mac geht nicht in den Ruhezustand, ich kann jedenfalls die Lüfter hören. Wenn auch nur Leise, weit weg davon wie es klingt wenn der CPU 100% Belastet wird. Aber irgendein art Ruhemodus muss es sein sonst würde er ja nicht weiter Rechnen wenn auch nur sehr langsam


    Kann Hybrid denn die Verbaute GPU nutzen?


    Leider sehr ich nichts was da erklären würde, in dem moment wenn ich eine Taste drücke um den Mac Bildschirm zu Wecken drehen die Lüfter hoch... die CPU Temp ist auch sofort wieder auf 95°C

    Ich habe ein 2017er MBP. Die haben dies throttling problem nicht... Das kam erst mit den 2018er und wurde nun auch durch ein Update behoben wie ich gelesen habe...


    Sitze ich am Rechner und Arbeit irgendwas läuft das Encoding mit Stabiles FPS Zahlen durch... die Probleme beginnen wenn ich den Rechner verlasse.


    Apple eigene Tools haben das Problem nicht. Soweit ich es Verstanden habe können die dem System sagen das diese nun durchlaufen sollen. Ich habe nicht rausfinden können wie die das machen. Ich denke mal es ist ähnlich wie beim Setzen der Energiespareinstellung...


    Testweise habe ich mir mal das Tool "Handbrake" angeschaut... Dort den selben Job gestartet, und das Problem tritt nicht auf... Es scheint also solch eine Einstellung zu geben, auch wenn ich nicht raus bekommen habe wie man dies anstellt.

    Hmm, also mit meinem neuen MacBookPro habe ich das Problem das das Gerät scheinbar massiv die Leistung drosselt sobald ich es verlasse...


    Die Lüfter laufen weiter, der Fortschrittbalken ändert sich auch, nur halt Langsam...


    Hast du ne idee oder Stellschraube wie du das beeinflussen kannst? In den systemsettings ist dazu nichts zu finden...


    Grüße

    Massaguana

    Das sind MediaInfo files die ich mir notiert habe: Die Original files habe ich dummerweise schon gelöscht


    Audio

    ID : 1

    Format : MPEG Audio

    Format-Version : Version 1

    Format-Profil : Layer 3

    Format-Einstellungen : Joint stereo

    Codec-ID : 55

    Codec-ID/Hinweis : MP3

    Dauer : 42min 10s

    Bitraten-Modus : variabel

    Bitrate : 128 Kbps

    Kanäle : 2 Kanäle

    Samplingrate : 48,0 KHz

    Bildwiederholungsrate : 41,667 FPS (1152 SPF)

    Stream-Größe : 38,3 MiB (11%)

    Ausrichtung : Ausgerichtet an Interleaves

    Interleave, Dauer : 24 ms (0,60 Video-Frame)

    Interleave, Vorlaufsdauer : 514 ms

    verwendete Encoder-Bibliothek : LAME3.90.

    Kodierungseinstellungen : -m j -V 4 -q 2 -lowpass 17.6 --abr 128

    Hallo Zusammen,


    ich bin aktuell dabei alle meine AVI´s in MKV Container zu Transferieren. Dazu nutze ich die Mac version von MKVToolNix 26


    Klappt bei 95% der Files prima, bei einigen Beschwert sich das Tool aber das die Audiospuren "Ungültige" Daten enthalten würde, die werden entfernt... Laut InfoBox kann dies die Synchronität beeinflussen.


    Kann mir wer erklären wie so etwas zustande kommt? Kann ich hier etwas gegen tun?


    Grüße

    Massaguana

    Also ich kenne in meiner MediaInfo Version (Mac AppStore Version) keine vergleichsansicht...


    Aber hier mal jeweils die Ausgabe von MediaInfo angefügt


    Angemosertes file:


    Code
    1. AllgemeinUniqueID/String : 295974642290497519332844417093495042734 (0xDEAAA483D600FCF25ABAA547B11A32AE)Vollständiger Name : /Volumes/MacPro T3MP/-={ T3MP }=-/Looney Tunes D02 E03.mkvFormat : MatroskaFormat-Version : Version 2Dateigröße : 882 MiBDauer : 6min 53sModus der Gesamtbitrate : variabelGesamte Bitrate : 17,9 MbpsFilmname : Looney Tunes Platinum Collection Volume OneKodierungs-Datum : UTC 2018-05-09 07:30:00Kodierendes Programm : MakeMKV v1.10.6 darwin(x86-release)verwendete Encoder-Bibliothek : libmakemkv v1.10.6 (1.3.3/1.4.4) darwin(x86-release)VideoID : 1ID in the original source medium : 4113 (0x1011)Format : AVCFormat/Info : Advanced Video CodecFormat-Profil : High@L4Format-Einstellungen : CABAC / 2 Ref FramesFormat-Einstellungen für CABAC : JaFormat-Einstellungen für ReFrames : 2 framesCodec-ID : V_MPEG4/ISO/AVCDauer : 6min 53sBitraten-Modus : variabelBitrate : 17,9 MbpsBreite : 1 920 PixelHöhe : 1 080 PixelBildseitenverhältnis : 16:9Modus der Bildwiederholungsrate : konstantBildwiederholungsrate : 23,976 (24000/1001) FPSColorSpace : YUVChromaSubsampling/String : 4:2:0BitDepth/String : 8 bitsScantyp : progressivBits/(Pixel*Frame) : 0.360Stream-Größe : 882 MiB (100%)Sprache : EnglischDefault : NeinForced : NeinOriginales Source-Medium : Blu-ray


    folgendes file:



    Habe auch ein wenig experimentiert... lade und Starte ich das "Problem file" alleine, so läuft es ohne Probleme durch... im Verbund mit anderen kommt es zu dieser Meldung.


    Hab dazu logs angefügt:
    Archiv.zip


    Meine Settings sind


    x264 --preset slow --crf 22.00 --profile high --level 4.0 --sync-lookahead 39 --psy-rd 1.00:0.15 --vbv-maxrate 25000 --vbv-bufsize 31250 --sar 1:1 --qpfile GENERATED_QP_FILE --deblock -1:-1 --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1920x1080 --input-csp i420 --input-depth 8 --fps 24000/1001 --output-depth 8 --output "/Volumes/MacPro T3MP/-={ T3MP }=-/Looney Tunes D02 E33_new.264" -