Failed video encode, aborted

  • Hallo,


    bin neu im Thema BluRay und HD.


    Bei der Umwandlung einer HD Datei auf meiner Festplatte erhalte ich folgende Fehlermeldung:
    "Failed video encode, aborted"


    Als Orientierung für den Umgang mit BD_Rebuilder habe ich die Anleitung von "milOtis" genutzt.


    - [14:16:19] Reencoding: VID_00003, Pass 1 of 1
    - Encode failed. Retrying.
    - Encode failed. Retrying.
    - Reached retry limit. Aborting.
    - BD-Rebuilder v0.36.04 (beta)
    - Windows Version: 6.1 [7600]
    - AVISYNTH Version: 2.5.8.0, Ok
    - HAALI Splitter: Isn't recommended version
    - FFDSHOW: 3562, not recommended version
    - WIN7 preferred AVC CODEC: Not Set correctly
    - WIN7 preferred VC-1 CODEC: Not Set correctly
    - WIN7 preferred MPEG2 CODEC: Not Set correctly
    - FFDSHOW VC-1 set incorrectly: [0]
    - FFDSHOW MPEG2 set incorrectly: [0]

    - FFDSHOW AVC set to "ffmpeg-mt": Ok
    - X264: Ok
    - AFTEN: Ok
    - FAAC: Ok
    - MP4BOX: Ok
    - WAVI: Ok
    - TSMUXER: Ok
    [14:16:21] - Failed video encode, aborted


    Auch wenn in der Vergangenheit oft als erste Fehlerquelle die abweichenden Programmversionen genannt werden, gehe ich davon aus, dass bei mir eher die Problematik in dem oben fett markierten liegt.


    Bei der "ffdshow-Videodecoder-Konfiguration" steht z.B. bei MPEG2 "deaktiviert".


    Laut Anleitung soll man den ffdshow oder BD_Rebuilder am Anfang als Admin starten, was ich auch gemacht habe, gab aber ein paar Meldungen mit denen ich nichts anfangen konnte.


    Es wäre nett, wenn mir jemand erfahrenes helfen könnte:
    1) Woran könnte der Fehler liegen?
    2) Wo und wie kann ich die oben fett markierten Sachen einstellen?
    3) Was muss ich dann als Option auswählen?


    Vielen Dank und einen schönen Sonntag!
    Grüße
    der Neuling


    P.S.:
    OS: Win7 64bit
    BD_Rebuilde Free v. 0.36.04 (beta)
    Einstellungen: [Options]
    VERSION=0.36.0.4
    MODE=0
    ENCODE_QUALITY=0
    ONEPASS_ENCODING=2
    AUTO_QUALITY=1
    SUPPRESS_FF_WARNING=1
    AUDIO_TO_KEEP=eng;ger;
    SUBS_TO_KEEP=all
    SD_CONVERT=0
    OPEN_GOP=0
    RESIZE_1080=0
    DEINTERLACE=0
    DTS_REENCODE=1
    AC3_REENCODE=1
    AC3_640=1
    AC3_192=0
    KEEP_HD_AUDIO=0
    AVCHD=0
    REMOVE_WORKFILES=0
    MOVIE_ONLY_LOOP=1
    REMOVE_OUTPUT=0
    USE_FILTERS=0
    BDMV_CERT_ONLY=0
    USE_LAVF=0
    IVTC_PULLDOWN=0
    ASSUME_DVD_PAL=0
    AUDIO_TRACK_LIMIT=1
    SUBTITLE_TRACK_LIMIT=1
    CUSTOM_TARGET_SIZE=23450

  • :welcome:


    Da ich kein Windows 7 habe, weiß ich nicht, wie man das "Windows 7 Preferred DirectShow Filter Tweak Tool" exakt bedient. Aber ich vermute, dass dies unbedingt verwendet werden sollte, um nicht ausschließlich den Microsoft-Decodern das Decodieren zu erlauben, sondern DirectShow und ffdshow überhaupt erst mal wieder zuzulassen.


  • Hallo,


    also habe mir das CodecTweakUtility heruntergeladen.


    Beim Start bekomme ich 2 geteilte Fenster, einmal für 32-bit decoders und einmal für 64-bit decoder.
    - AVC finde ich nicht? Ist das H.264? Habe H.264 auf ffdshow umgestellt, oder lieber ffdshow(DXVA?)
    - VC-1 steht auf Microsoft -> habe ich umgestellt auf ffdshow (oder lieber auf ffdshow(DXVA)?
    - MPEG-2 war nur Microsoft zur Auswahl, nach der Änderung im ffdshow Filter steht es nun auf ffdshow


    Beim ffdshow-Videodecoder-Konfiguration waren MPEG2 und VC1 "deaktiviert".

    Sind folgende Einstellungen bei der Codec Zuweisung richtig?
    H.264/AVC = libavcodec (oder ffmpeg-mt?)
    MPEG2 = libavcodec (oder libmpeg2?)
    VC-1 = libavcodec (oder wmv9?)


    Weihnachtliche Grüße!

  • So,


    mit den oben genannten Einstellungen bekomme ich folgende Fehlermeldung:


    - [10:10:57] Reencoding: VID_00003, Pass 1 of 1
    - Encode failed. Retrying.
    - Encode failed. Retrying.
    - Reached retry limit. Aborting.
    - BD-Rebuilder v0.36.04 (beta)
    - Windows Version: 6.1 [7600]
    - AVISYNTH Version: 2.5.8.0, Ok
    - HAALI Splitter: Isn't recommended version
    - FFDSHOW: 3562, not recommended version
    - WIN7 preferred AVC CODEC: Ok
    - WIN7 preferred VC-1 CODEC: Ok
    - WIN7 preferred MPEG2 CODEC: Ok
    - FFDSHOW VC-1 set incorrectly: [1]
    - FFDSHOW MPEG2 set to "libavcodec": Ok
    - FFDSHOW AVC set to "libavcodec": Ok
    - X264: Ok
    - AFTEN: Ok
    - FAAC: Ok
    - MP4BOX: Ok
    - WAVI: Ok
    - TSMUXER: Ok
    [10:10:59] - Failed video encode, aborted