Verlustfreies Schneiden mit Hilfe von Hybrid

  • Ich habe hier einen Film, aufgenommen vom tschechischen DVB-T2. Also HEVC 50 fps progressiv.

    Ich will unbedingt die Qualität behalten - also nix umcodieren! Aber leider sind 15 Sekunden defekt. Jetzt habe ich aus einer anderen Quelle die defekte Stelle nochmal von DVB-S2 in h264 25i ( der Film ist aber progressiv)

    Jetzt will ich die 15 Sekunden in den HEVC Clip reinschneiden und nur die eine Stelle neucodieren.

    Dafür habe ich mir Tmpegenc Smart Renderer 5 gekauft, was mir auch gute Dienste jahrelang geleistet hat. Das kann nämlich den h265 Masterclip verlustfrei schneiden (ok die Schnittkanten codiert es neu) und nur die 15 Sekunden von h264 zu h265 umcodieren. Das geht auch, Aber wenn es h265 codieren soll, sieht die Stelle echt sehr schlecht aus. Starke Artefakte etc... Es benutzt wohl einen eigenen Encoder und nicht x265.

    Jetzt will ich die 15 Sekunden Stelle vorher selber manuell codieren und beide Clips verlustfrei verbinden (schneiden)

    Doch TMG Smart Re. 5 ist da sehr streng. Wenn das 15 Sekunden Stück etwas von den Settings abweicht, will es sofort neucodieren.

    Also will ich nun mit Hybrid genauso codieren wie es der Masterclip vorgibt. Ich kann Hybrid bedienen und habe auch schon mit Mediainfo ein paar Settings eingestellt aber das hilft nicht viel. Ich brauche einen Profi, der mir die genauen Setting sagt, die der Masterclip vorgibt.

    Mein Masterclip (ein 4 MB Teil davon) und das Avisynth script womit ich Hybrid fütter liegen hier:

    https://drive.google.com/drive/folders/…3ef?usp=sharing

  • Hier nochmal das, was TMPG SM RE zu dem Masterclip sagt

    und der Text aus der unteren Box

    Quote

    Open GOP, Progressive-Sequence, Minimale CU-Größe = 8, Maximale CU-Größe= 32, Minimale TU-Größe = 4, Maximale TU-Größe = 32, Max. Tiefe des Quadtrees von TU-intra = 3, Max. Tiefe des Quadtrees von TU-inter = 3, Analyse der AMP de-aktiviert, SAO-loop-Filter aktiviert, PCM-Kodierung de-aktiviert, Intra-Smoothing (stark) aktivert, Kontextsensitive Scheiben-Segment de-aktiviert, Sign Data Hiding aktiviert, Beschränkte Intra-Vorhersage de-aktivert, Transform-skip de-aktiviert, CU QP delta = 1, Lossless-Modus de-aktiviert, Kachel de-aktiviert, Wavefront Parallelverarbeitung aktiviert, Parallel merge level = 2, Kodierten Videogröße 1920 x 1080

  • Quote

    aber das hilft nicht viel.

    Wundert mich, eigentlich kann man HEVC files relativ einfach kombinieren.

    Mal versucht mit mkvtoolnix, anstatt mit TMG Smart Re. 5, die Ergebnisse aneinander zu packen?

    Hab einfach mal x265 crf 18 mit 4.1/Main/Main verwendet und das Ergebnis ließ sich ohne Probleme mit mkvtoolnix aneinanderhängen.

    (Habe erst das Video ohne Audio in ein 'videoonly.mkv' gepackt, dann ein 'reencode.mkv' erstellt und anschließend die Dateien mit mkvtoolnix zusammen gefügt,... -> merged.mkv)

    Zumindest im MPC-HC lässt sich das Ergebnis ohne Probleme abspielen.

    Cu Selur

  • nein, (jedenfalls finde ich das nicht)

    Man kann sich wohl nur an den von mir geposteten Settings vom Masterclip orientieren.

    Ich habe jetzt mal deinen Weg mit MKVToolnix gemacht. Ja, es wird fehlerfrei gemuxt. Doch sehe ich an den Schnittstellen in MPC-HC ein Ruckeln.

    In VLC nicht! Und genau sowas wollte ich nicht.

  • Ich habe jetzt eine brauchbare Lösung gefunden. Ich nehme das mit MKVToolnix gemuxte Video und lade es nochmal in T SmRe und der bemängelt die eine Stelle und kodiert sie erwartungsgemäß um. ABER beim Resultat sieht es nicht mehr nach Artefakten usw. aus. Das Ergebnis ist richtig gut. Damit kann ich leben und jetzt ist das ganze Video aus einem Guss und ruckelt auch nicht mehr in MPC-HC

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!