GUI für den Muxman DVD Authoring

  • habt Ihrs im Hirn? PS verbieten? Ich höre bei meiner etwas älteren verwandschaft immer: Neeee stell das wieder zurück, da sind ja Ränder oben und unten. ERGO PS ist Pflicht. Außerdem ist es das gleiche wie 4:3. Und ich encode auch 16x9 Video's in PANScan.


    hier mal mein Script, wie ich Bilder von 1x1 nach 16x9 wandle:

  • convert... -gravity center -crop 788x576+0+0 -filter Point -resize 720x576!


    Und was bedeutet das 'mathematisch'?


    Entsprechend der bisherigen Logik in GfD (die ich auch nicht ändern möchte) wird immer ein 720x576 (bzw. 720x480) Pixel Bild 'bearbeitet'. Dieses kann 'einfach so' als 4:3 Menü bzw. als 16:9 Menü 'wide' verwendet werden.
    Um dafür den Letterbox Highlight Stream zu 'berechnen' wird auf Bildhöhe = 0.75 x 576 (bzw. 0.75 x 480) resized und das Ergebnis an Y-Position: Bildhöhe x 0.125 auf ein neues 720x576 (bzw. 720x480) Pixel Bild kopiert. Die Button Positionen werden dann wie oben beschrieben umgerechnet.


    Ich brauch also einen Algorithmus der aus dem 720x576 (bzw. 720x480) Pixel Bild (wide) das P/S Bild berechnet. Die Button Positionen müssten sich dann identisch berechnen lassen.

  • Zitat von borax

    convert... -gravity center -crop 788x576+0+0 -filter Point -resize 720x576!


    Und was bedeutet das 'mathematisch'?


    Source ist ein 16x9 Bild in 1:1 Auflösung von 1050x576. Dieses wird von der Mitte (gravity center) auf 788x576 ausgeschnitten (crop). Und dann auf 720x576 skaliert.


    mmm jetzt muß man das nur noch von 720x umrechnen. Mal scharfi fragen, der kann das bestimmt.


    Und eine Bearbeitung mit 1:1 Material ist viel einfacher. sonst muß man immer schief gucken, wenn man ein Menü bauen will :(

  • Wie Du auf 1050 kommst versteh ich zwar nicht (außer es gibt da noch irgendwelche Overscan Pixel), aber damit hab ich es etwa begriffen.


    'Normal Bild' 720x576 wird bei 4:3 zu 768x576 (4*192=768; 3*192=576)
    'Normal Bild' 720x576 wird bei 16:9 zu 1024x576 (16*64=1024; 9*64=576)
    Aus dem 1024x576 Bild wird der 4:3 Bereich von 768x576 'herausgeschnitten' also 128 Pixel links+rechts = 256 Pixel
    Wegen dem 'Skalierungsfaktor' 720/1024=0.703125 werden also aus dem 720x576 Bild 'nur' 180 Pixel (256*0.703125) also links+rechts je 90 abgeschnitten so dass 540 Pixel 'übrigbleiben' und das resultierende Bild wieder auf 720x576 'verbreitert'.
    Die Buttonpositionen berechnen sich dann als
    y_P/S=y_wide, x_P/S=(x_wide-90)*1,3333 (1,3333 wegen 720/540)


    P.S. 1:1 Bearbeitung ist mir wegen der Rundungsproblematik sehr suspekt (sonst muss man ständig mit 'halben' Pixeln rechnen). In der Vorschau wird es aber 'richtig' skaliert. Ich könnte dann auch die Vorschau um einen wide,LB,P/S Button erweitern.

  • Warum???


    4/3=1.33333; 768/576=1.3333; 788/576=1,3680



    [EDIT]
    Deswegen...
    http://www.macnews.de/faq/fid55.html


    Spielt hierfür aber IMHO keine Rolle, da ich ja vom 720'er Bild ausgehe und das analoges Pal die 9 Pixel links und rechts nicht darstellen kann, ändert nichts an der Berechnung der Positionen, da das 'Problem' ja gleichermaßen auf jedes 720'er Bild zutrifft.

  • Du hast nur gefragt, wie ich meine Subs mache und warum ich 1050 verwende. Wenn Du schon ein sauberes 720x Menü hast und "nur" noch die die Subs malst, brauchst Du dich darum nicht kümmern.


    Erstelle einfach mal ne neue Version. ich teste es doch schon :) Bin ja hier so oder so die einzige Testerin.


    PS: machs ja auch gerne. Und hoffe, wenn div. Probleme erstmal aus der Welt sind, das dann auch mein Wunschkatalog abgearbeitet wird :D

  • Ich weiß, wir sind ein kleines Unternehmen...


    Probier mal. In den Menu-Settings die gewünschte 'Bauart' vorgeben (LB, P/S, LB & P/S)


    Anmerkung: Ich habe gemerkt, dass gespeicherte Projekte die verwendete Engine nicht mitgespeichert haben. Da der 'default' aber dvdauthor ist, muss man ggf. bei schon gespeicherten Projekten im gfd File die Engine 'nachtragen'.
    Zeile 6:
    </SETTINGS4> .... NOMENUS="0" LOOPSYNTAX="0" ENGINE="1">

  • Hallo,

    Zitat

    Keine Warnung mehr bei Sonderzeichen in Datei/Pfadnamen (MuxMan hat kein Problem damit)


    da bin ich mir nicht so sicher, ich hatte gerade eine Fehlermeldung im Script. Leider hab ich das ganze Zeug gelöscht, ich war stinksauer hab den ganzen Tag am Menü rumgemacht bis es so war wie ich es mir in etwa vorstelle da kommt diese sche** Fehlermeldung.
    Irgendwas mit "parsing in xml script......us ascii code...." Muxman schien sich am "ß" zu stören. Ich werd es morgen noch mal testen.


    Nochwas wenn ich einen Wunsch frei hätte würde ich mir wünschen das man eine Statusanzeige hätte an der amn sehen könnte wie weit das Authoring fortgeschritten ist. Teilweise ist man sich wirklich nicht sicher ob überhaupt noch was passiert.

  • Zitat von Morpheus

    Nochwas wenn ich einen Wunsch frei hätte würde ich mir wünschen das man eine Statusanzeige hätte an der amn sehen könnte wie weit das Authoring fortgeschritten ist. Teilweise ist man sich wirklich nicht sicher ob überhaupt noch was passiert.


    Das kannst Du mit der Muxman Engine vergessen. Das ist nicht mal in der Adv. Edition drin.


    borax
    leider noch keine Zeit gehabt :(

  • Morpheus
    >parsing in xml script... <= Das kann eigentlich nur von dvdauthor kommen. MuxMan versteht AFAIK kein XML. Ich habe extra schon Dateinamen mit äöüßÄÖÜ getestet - Kein Problem bei MuxMan.
    Statusanzeige... Kommt schon noch (so weit ich das realisieren kann - besser wäre es sicher, wenn MuxMan/MPUCoder das selbst übernehmen würde...). Mplex hat ja leider auch keine.


    katjarella
    Schon ok! Ich habe sowieso den größten Teil des Tages im Garten verbracht...


    Interessehalber hab ich noch ein paar 'Geschwindigkeitstests' gemacht (~2.5GB Video, 0.15GB Audio (MP2), ein Button, Standbild-Hauptmenü, immer frisch gestartetes System):


    MuxMan: 07:40
    MuxMan mit physikalisch separater Ziel-Partition: 05:45
    mplex/dvdauthor: 10:25
    mplex/dvdauthor mit physikalisch separater temp. Partition: 06:35


    Außer Konkurrenz...
    dvdauthor, fertig multiplextes MPEG: 05:14
    dvdauthor, fertig multiplextes MPEG von physikalisch separater Partition: 04:18

    (jeweils Minuten:Sekunden)

  • Hallo,

    Zitat

    Das kann eigentlich nur von dvdauthor kommen


    Es war auf Muxman eingestellt das weiss ich 100%tig. Hatte aber vorher mit dem DVDAuthor gearbeitet. Vieleicht hätte ich nach dem Wechseln neu starten sollen? Der DVDAuthor gibt mir auch nicht immer die Warnmeldung aus das ich Sonderzeichen im Dateinamen hab, mal macht er das mal nicht.

  • Hallo,
    habs gerade noch mal ausprobiert diesmal hat der Muxman die Sonderzeichen geschluckt. Lag wohl wirklich an der Umstellung von DVDAuthor zu Muxman.
    Man sollte nach dem Umstellen auf jeden Fall die GUI noch mal schließen, vielleicht sogar neu starten. Beim letzten Test hat das Schließen der GUI gereicht.

  • Hallo,

    Zitat

    Ein 'Datei - Neu' sollte reichen.


    stimmt das könnte auch reichen. Ich hab nichts von dem gemacht, einfach umgestellt und los gelegt. Das war wohl der Fehler.


    Was das Playall Button angeht hab ich es erst mal sogemacht wie du es geschrieben geschrieben hast. Hab in den Settings auf nächster Film gestellt das funktioniert auch. Für deinen anderen Vorschlag und auch die von Katjarella muß ich erst noch was lesen. Ich hätte aber schon gern wieder ein Button wie ich es unter DVDLab hatte.


    Aber eins nach dem anderen ich muß erst mal mit der GUI im "normalen" Betrieb klar kommen. Ich hatte es ja schon geschrieben Scripts editieren ist nicht so mein Ding.



    Achso noch was der Menü-Loop funktioniert bei meinem SAP nicht (Standbild + Audio). Der Audio-File wird nicht wieder neu gestartet. Auf dem PC funktioniert es einwandfrei (WinDVD,WMPC).