Staxrip vergisst Encoding-Einstellungen für Xvid

  • Guten Tag allerseits,


    nachdem ich nun ca. eine Stunde vergeblich suche, traue ich mich nun, mein Problem hier zur Diskussion zu stellen.
    Ich verwende Staxrip V1.1.6.0 u.a. mit Xvid 1.2.2 (Koepis Vanilla CVS Build vom 7. Juni 2009).
    Ich möchte für mein Nokia X6 ein Video in nHD encodieren und wollte folgende Einstellungen verwenden:
    Profile - portable, Encoding type - single pass, target bitrate 1000 kbps, keine B-VOPS, quantization type - H.263. Der Rest ebenfalls standard.
    Nun das eigentliche Problem: Wenn ich die Codec-Konfiguration mit OK verlasse und wieder neu aufrufe, steht dort nie meine ausgewählte Bitrate von 1000 kbps, sondern immer 600.
    Nach Neuinstallation war statt 600 auch einmal 4356 im betreffenden Feld, aber nie meine ausgewählte Bitrate.
    Was mache ich falsch? Ist das ein noch nicht bekannter Bug?
    Kann mir jemand von den Experten helfen?


    Danke für Eure Bemühungen im Voraus, Bibo

  • Staxrip berechnet die finale Bitrate erst nachdem der Ton komprimiert wurde anhand der vorgegebenen Dateigröße.
    Wenn du ein entsprechendes Profil ausgewählt hast, sollten dessen maximalen Parameter beim finalen Durchgang eigentlich berücksichtigt werden.

  • Danke für die prompte Antwort!
    Ich habe auf den Hinweis "Staxrip berechnet die Bitrate nach Audio-Encoding" etwas nachgeforscht.
    Wenn ich 1-Pass einschalte, erhalte ich die nicht einstellbare Bitrate.
    Nach Umschalten auf 2-pass läßt sich im dann erscheinenden Bitratenfeld die gewünschte Bitrate einstellen. Diese Bitrate behält Staxrip auch beim erneuten Umschalten auf 1-pass bei...?!
    Etwas seltsames Verhalten aber ich kann damit leben.
    Trotzdem sollte Staxrip bei Xvid-1-pass-Encodings eine elegantere Bitratenvorgabe erlauben.


    Evtl. ist mir auch etwas entgangen. Aber eine komplette Doku für Staxrip/Xvid habe ich noch nicht gefunden.
    Für Divx/Xvid unter GK war die Doku auf doom9.org ausführlich und schön gemacht; aber heutzutage natürlich nicht mehr up to date...


    Servus, Bibo