HDR mit DisplayPort/HDMI

  • Hi,

    ich habe:

    Wenn ich den Monitor per DisplayPort anschließe, wird er richtig als 10bit erkannt.

    Wenn ich den Monitor allerdings per HDMI anschließe, wird er nur als 8bit erkannt.

    Als HDMI Kabel verwende ich ein deleyCON 5m HDMI Kabel 2.0a/b - High Speed mit Ethernet - UHD 2160p 4K@60Hz 4:4:4 HDR HDCP 2.2 ARC CEC Ethernet 18Gbps 3D Full HD 1080p Dolby (https://www.amazon.de/gp/product/B005M0XU32).


    Habe leider nicht noch einen HDR Bildschirm zum Testen, darum die Frage: Übersehe ich da was? Eigentlich sollte das doch klappen, oder?


    Cu Selur


    Ps.: Nein, DisplayPort nutzen ist keine Lösung, da ich die zwei DisplayPort-Anschlüsse für meinen HP Z27q (https://support.hp.com/de-de/document/c04601277) brauche. "Die Grafikkarte des angeschlossenen PCs muss 5120 x 2880 bei 60 Hz unterstützen und über 2 DisplayPort-Ausgänge verfügen, um den Monitor im bevorzugten Modus zu betreiben." mit einem HDMI Kabel ist bei 4096x2160 Schluss (da geht aber 10bit).

  • Okay, wenn ich HDMI und 30Hz verwende, gehen 12bit obwohl es ein 10bit Panel ist,...

    -> nicht viel schlauer als vorher, entweder kann die Grafikkarte nicht mehr als 30Hz bei HDMI und 4k oder der Monitor.

    Werde ich wohl erst klären können, wenn ich 'ne neue Grafikkarte habe, aber das wird noch dauern.


    Cu Selur


    Ps.: okay, die Tage leihe ich mir von nem Kumpel mal dem seinen 4k Monitor zum Testen obs on Grafikkarte oder Monitor liegt.

  • vielleicht must du das Ausgabeformat von RGB auf YCbCr* oder ähnlichem im nvidia pannel umstellen.

    die 4k/10bit kommen wohl nicht ohne kompromisse.

    entweder von der grafikkarte(/anschluss) oder vom monitor(/anschluss).

    war bei meinem supa dupa benq auch eine offenbarung.

    4k/10bit kann der nur im YCbCr*-modus

    bedonnders hdmi wird immer wieder bei der auflösung rumgetricks...

    ...bei filmen fällt ja sowas nicht auf.


    aber kannst ja den hersteller ja mal n liebesbrief schreiben... ;D


  • Selur:

    Den Spezifikationen nach, macht der Monitor aus China 4k und 60 Hz.

    Die Asus Geforce 1070 ti mit 8 GB ist eine gute GK. Stellt auch 4k zur Verfügung, allerdings so wie es aussieht nur mit 30 Hz.

    Zu 10- und 12Bit, sind keine Infos zu finden. Da müsstest du einmal in der Bedienungsanleitung nachsehen.


    Aus eigener Erfahrung, kann ich nur sagen, dass ein HDMI-Kabel mit 5m für 9,99 Euro kein stabiles Bildsignal liefert.

    Bei HDR10+, 60Hz, und 18GBit/s in 4:4:4 RGB meiner Meinung nach schon gar nicht. Bei 4k braucht man min. eine Datenübertragungsrate von 21 GB. Eigentlich sollten es 24 GB.


    Das DisplayPort-Interface mit 77,4 GBit/s ist am schnellsten. Aber Vorsicht da gibt es auch DP-Kabel mit nur 18- oder 36 GB.

    Die schnellsten HDMI-Kabel bieten zurzeit 48 GB, so wie das EQUIP 119383 Ultra-High-Speed-Kabel.


    EQUIP 119383 Ultra-High-Speed-Kabel, 48 Gbit/s


    Ich denke, das Kabel ist noch bezahlbar mit 21,95 Euro.


    HQ-LQ:

    Ich sehe, dass bei deinem GK-Treiber unter „Dynamischer Ausgabebereich“ „Begrenzt“ (16-235) ausgewählt ist.

    Aktuell stellt man für Monitore, immer auf den vollen Bereich von 0-255 ein, egal ob es RGB oder YUV ist.

  • Zitat

    Ich sehe, dass bei deinem GK-Treiber unter „Dynamischer Ausgabebereich“ „Begrenzt“ (16-235) ausgewählt ist.

    Aktuell stellt man für Monitore, immer auf den vollen Bereich von 0-255 ein, egal ob es RGB oder YUV ist.

    Mach ich auch, tv scale war nur ausgewählt weil ich kurz vorher die Treiber neu installiert und alles zurückgesetzt hatte.

    Werde mal mit nem anderen Kabel versuchen.

  • der treiber läuft automatisch auf 'begrenst' wenn ich einen YCbCr*-modus auswähle.

    aber scheinbar kocht windows 11 noch seine eigene suppe.

    so muss man in den windows einstellungen extra den HDR modus aktivieren.

    der ignoriert auch die nvidia HDR einstellungen.

    ich weiß dann auch nicht was windows für ein ausgabeformat wählt.

    bei mir sieht dann alles so blass/farblos aus.

    zz lauf ich weiter im SDR... 🤷

  • Selur:

    Das HDMI-Kabel mit 8K, müsste normalerweise 10Bit darstellen können. Das ist mir auch ein Rätsel.

    Wichtig für die Zukunft ist die Datenübertragung mit 48 Gbit/s. Eigentlich müssten 18 Gbit/s für 10Bit auch bei einem guten HDMI-Kabel ausreichen.

    Dein deleyCON-Kabel ist auch schon HDMI 2.0.


    Mich würde einmal die Bezeichnung von deinem „teurem“ HDMI-Kabel interessieren. 20 Euro wäre jetzt nicht unbedingt teuer.

    Der Kollege Zerobrain bei YT, machte schon vor längerer Zeit einen großen Test mit 4K-HDMI-Kabel.

    Jeder kann sich selbst ein Urteil über die Qualität der getesteten HDMI-Kabel bilden, die er haben möchte.

    In der Praxis sieht die wirkliche Qualität ganz anders aus.


    HDMI Kabel Test: Vermessen, zerlegt und bewertet.


    Gute HDMI-Kabel fangen in dieser Preisklasse an:

    Avinity Ultra-High-Speed-HDMI-Kabel, 8K, 48 Gbit/s


    Ich schätze, dass dein innocn 27M2U nicht wirklich 10Bit darstellen kann. Anders kann ich mir das nicht erklären.

    Dein HDMI-Displayport-Adapter unterstützt vermutlich eine andere HDCP-Version, darum bleibt das Bild schwarz.

  • Adapter: was ich so an HDMI<>Displayport Adaptern auf der Arbeit finden konnte, hab ich mal probiert, da wird der Monitor aber nicht erkannt.

    Vermutlich braucht es da spezielle Adapter, die auch noch zusätzliche Informationen 'erfinden'.

    Monitor zu Kumpel schleppen hab ich nicht versucht. Vielleicht demnächst.

    Denke, ich warte jetzt aber erstmal bis Ende Oktober, um zu sehen, was sich da am Grafikkartenmarkt so tut. Werde vermutlich Ende des Jahres eh ne neue Grafikkarte kaufen, die dann 3 DP Anschlüsse hat und damit ist das Problem dann auch erledigt.


    Cu Selur

  • Die A380 macht sogar 8k. Für den Betrieb in voller Leistung bräuchte man für die beiden GK je einen PCI Express 3.0 (4.0) x16-Anschluss am Mainboard. Hat dein Mainboard min. 2 PCI Express x16-Anschlüsse?

    Sollte dein Mainboard nur einen PCI Express 3.0 x16 besitzen, dann fällt der 2. PCI Express 3.0-Anschluss automatisch auf x8 zurück.

    5K sind da, glaube ich, nicht mehr möglich.


    Aber ich denke, du hast schon ein gutes Mainboard mit min. 2 x16-Slots. Sehr gute Mainboards haben 5- oder sogar 7 x16-Anschlüsse.


    In den Spezifikationen lese ich, dass man für die A380 min. ein 600W-Netzteil benötigt. Von den Schnittstellen her, müsste die A380 locker 5k bringen.

    Ich bin mir auch sicher, dass du kein zu schwaches Netzteil eingebaut hast.

    Trotzdem würde ich einmal den gesamten Stromverbrauch aller Hardware, im höchsten Leistungspegel zusammenzählen.

    Dabei kommen meistens erstaunliche Watt-Zahlen ans Licht.


    1x CPU, 150-200 W,

    1x 1. GK, 150-200 W und

    1x 2. GK, 150-200 W


    Das sind ohne HDDs oder SSDs (Lüfter, Wasserpumpe) alleine schon 600 Watt. In deinem Fall, wäre ein Netzteil mit min. 750 W ratsam.

    Mit nur einer GK, würde dann ein Netzteil mit 650 W reichen. Eine NVIDIA RTX 3090 zieht kurzzeitig über 1200 Watt.


    BIOS/UEFI:

    Das Kompatibilitäts-Support-Modul (CSM) oder der Legacy-Modus müssen deaktiviert sein, und der UEFI-Boot-Modus muss aktiviert sein.


    Sicherstellen Die folgenden Einstellungen sind auf Aktiviert (oder Auto wenn die Option Aktiviert nicht vorhanden ist):

    Über 4G-Decodierung

    Unterstützung von BAR-Größen neu


    Aber diese Einstellungen, hast du sicherlich auch schon ausgeführt. 6 GB-RAM sind etwas schwach, 8 GB wären besser.

    Mir kommt es so vor, als ist deine CPU nicht kompatibel oder zu leistungsschwach.

    Deine CPU muss ja auch erst einmal 2x PCI Express x16-Slots von dem Mainboard ansprechen können. Das ist aber nur eine Vermutung von mir.

  • wenn er kein workstation board/cpu hat, dann dann sind die pcie lanes begrenst.

    bzw. mit der neusten hardware wäre da mehr möglich, aber die extra lanes sind shared.

    ich bezweifel ob die lanes so en großen enfluss haben...


    ich hab ein multimonitor setup, da hab ich flächenmäßig mehr pixel...


    und vergiss nicht die ganzen usb3 videoadapter, die ham noch weniger bandbreite.

  • Ja, das sehe ich auch so. Aber in der Anleitung für die A380 steht, dass für die volle Leistung unbedingt ein x16 (Lanes) – Anschluss erforderlich ist.

    Sonst fällt die GK auf x8 zurück. Es könnte so sein, dass gerade das höhere HD-Bildsignal auf einer der weiteren 8 Lanes übertragen wird.


    Das halte ich auch für etwas komisch, denn wenn man die GK anschließt, dann müsste automatisch auch mit 5K ein Bild zu sehen sein.

    Selur hat vermutlich ein Performance-Problem. Irgendeine Komponente leitet das 5K-Bildsignal nicht weiter. Ich glaube nicht, dass es am Treiber liegt.

    Das wird uns ein Rätsel bleiben.

  • wenn man mal den pc als fehlerquelle ausschließen möchte,

    dann sollte man sich mal auf das kabel, bzw. auf den monitor konzentrieren.

    ich würde mir ein online-shop suchen mit kostenlosen rückversand

    und so mal ein moitor testen, der 100% funktionieren müsste...

    dann kann man die fehlerkette wieder rückwerts gehen...


    ggf. würde ich das windows mal sichern und eine clean-install testumgebung einrichten...

    ich hatte mal ein kompatibilitäts-problem mit einem mixed-reality vr-heatset,

    obwohl ich alles richtig gemacht hatte, blieb mir am ende nur eine neuinstallation...

    (dabei war die installation erst 6 monate alt -_- )


    hatte ich mal erwähnt, dass die unscheinbarste fehlerquelle mal ein netzteil verursacht hatte.

    heutzutage erwarte ich das nicht mehr (von 'gaming'-marken herstellern),

    aber das wäre so eine kompetente, die am längsten in einem pc verweilt...

  • CPU ist ein Ryzen 9 3950x der sollte nicht das Problem sein. (Netzteil ist 850Watt, bis dato keine Probleme damit.)

    Das Problem ist, wenn ich an der Geforce Karte mit neuen Treibern (auch wenn sie alleine im System ist) den 5k Bildschirm anschließe bleibt das Bild schwarz.

    Gleiches Spiel bei der Intel Karte.

    Scheint als ob DualDisplayport-Monitore nicht mehr unterstüzt werden. :(

    Wegen der Leistung der Intelkarte mache ich mir keine Sorgen, da ich die nicht zum Gaming verwende und bei Videoplayback und Encoding sollte selbst 8x reichen.


    Cu Selur

  • Da wir keine näheren Infos zu deiner CPU und dem Netzteil hatten, mussten wir leider spekulieren, welche Hardware du haben könntest.

    Dass du nur hochwertige Teile verwendest, ist uns schon klar.


    Folgendes (Zitate von techjunkies.blog):

    5K, 60 Hz ist nur noch mit DisplayPort 1.3/1.4 und nur mit einem Kabel möglich.

    2 x DisplayPort 1.2 und eine Grafikkarte, die diese Ausgabe ermöglicht, wird am Monitor nicht mehr unterstützt.


    Das heißt, deine GK ermöglicht zwar 5K und 60 Hz, aber Monitore mit 2x DP 1.2, werden nicht mehr unterstützt.

    Dazu reicht die Bandbreite nicht mehr aus. 4K 60 Hz bei DP 1.2, das geht.


    HDMI:

    Der ältere HDMI 2.0-Standard unterstützt lediglich 5K und 30 Hz. Das ist wenig geeignet für die Praxis.

    5K und 60 Hz ist nur mit HDMI 2.1 möglich. HDMI 2.0 funktioniert bei 5K mit 60 Hz nicht.


    Bislang ist jedoch noch kein 5K-Monitor (oder ein anderer Monitor) mit HDMI 2.1 in Sicht.

    Damit 5K @ 60 Hz in dieser Kombination läuft, ist jedoch ein aktueller iMac, ein aktueller Mac Mini oder ein aktuelles MacBook (z.B. MacBook Pro ab 2016, Details) erforderlich.


    Mittlerweile ist auch Thunderbolt 4 als Nachfolger verfügbar.

    Höhere Bildwiederholraten (100 Hz, 144 Hz, 240 Hz etc.) bleiben bei einem 5K-Monitor einstweilen Zukunftsmusik.


    Warum Apple auf 5K-Displays schwört – und niemand sonst.


    Ich hoffe, du bist mit den Infos zufrieden.

  • Zitat

    5K, 60 Hz ist nur noch mit DisplayPort 1.3/1.4 und nur mit einem Kabel möglich.

    2 x DisplayPort 1.2 und eine Grafikkarte, die diese Ausgabe ermöglicht, wird am Monitor nicht mehr unterstützt.

    Das geht am Problem vorbei.

    Fakt ist: Ich betreibe meinen 10bit HP z27q 5k Monitor mit 60Hz mit meiner Geforce GTX 1070ti seit Ende 2016 ohne Probleme.

    Probleme gibt es erst mit neueren NVIDIA Treibern.
    Der Monitor und die Grafikkarte ändern sich durch neuere Treiber nicht.

    Die 5k Displays haben zwei Panels sprich da werden 2x 2560x2880@60Hz an den Bildschirm geschickt, was mit 2xDisplayPort 1.2 ohne Probleme geht.

    Das DisplayPort 1.3/1.4 und neuer das über ein Kabel können ist irrelevant, da der Bildschirm nur DisplayPort 1.2 hat.

    Momentan geht es bei mir:

    5k Monitor mit alten Treibern und 2xDisplayPort an der Geforce und neuen 4k@60Hz HDR Monitor über DisplayPort an der Intelkarte.


    -> Meiner Ansicht nach ist das ein reines Treiberproblem.


    Das die neue Intelkarte auch keine 2xDisplayPort unterstützt ist schade und macht mir etwas Sorgen, dass neuere NVIDIA Karten, das eventuell auch nicht mehr können werden.


    Cu Selur