Fehlermeldung bei Divx -> Divx mit AutoGK

  • Hallo,
    ich hab noch ein Problem mit AutoGK.

    Beim Versuch Divx-Videos (Divx3.11) erneut zu encodieren (verkleinern) bricht AutoGK nach dem ersten Pass mit folgender Fehlermeldung von VirtualDub ab:

    Quote

    The function set mode was called on a stream[?] that hasn't been previously initialized with set source

    Danach macht AutoGK weiter, das Ergebnis ist aber ein viel zu großer File, als gewünscht:

    Ich habe es mit AutoGK 2.18 beta und 2.20 final probiert, beides mal das selbe :(


    Woran liegt es?

    Grüße,
    Darko

  • Ja, das lässt sich problemlos mit VirtualDubMod öffnen (es kommt nur der Hinweis wegen VBR-MP3). Auch das Ergebnis, das AutoGK produziert lässt sich öffnen und auch abspielen. Es ist nur wegen fehlendem zweiten Durchlauf zu gross.

    Ich hab inzwischen auch probiert, dass Divx mit VirtualDubMod in Divx zu (re-)encodieren: 1 pass läuft ohne Probleme, bei dem 2. bricht VDub ab und zeigt in der Job List "Error" (es entsteht dann aber im Gegensatz zu AutoGK kein "brauchbares" Video).

    Installieren des Divx3.11-Codecs änderte auch nichts.

  • hey!

    ich würde divx3 nicht erneut encoden wegen erneutem qualitätsverlust.

    Quote from Darko

    Ja, das lässt sich problemlos mit VirtualDubMod öffnen (es kommt nur der Hinweis wegen VBR-MP3). Auch das Ergebnis, das AutoGK produziert lässt sich öffnen und auch abspielen. Es ist nur wegen fehlendem zweiten Durchlauf zu gross.


    hm, der 2nd pass dauert nicht mal 2min und das ganze lässt sich anschauen? versteh ich nicht ganz...

    Quote

    Ich hab inzwischen auch probiert, dass Divx mit VirtualDubMod in Divx zu (re-)encodieren: 1 pass läuft ohne Probleme, bei dem 2. bricht VDub ab und zeigt in der Job List "Error" (es entsteht dann aber im Gegensatz zu AutoGK kein "brauchbares" Video).


    was steht den im log von virtualdubmod? - können dir sicher helfen wenn du das posten würdest...


    mfg
    scrat

    Matroska Guide - Encoden mit GordianKnot, VirtualDubMod im x264/Xvid Format *Update: 25.09.2005*

  • Soweit ich es jetzt raus gefunden habe, scheint der mp3-Stream Schuld an dem ganzen zu sein.
    Öffne ich das Video mit Virtual Dub Mod kommt der Hinweis auf vbr-mp3. Beantworte ich "rewrite header..." mit Nein lässt sich die Tonspur nicht mehr demuxen. VirtualDub hängt dann und gibt irgendwann auf. Beantworte ich mit ja und speichere das Video mit save as nochmal ab ist der Ton verschoben.
    Das von AutoGK erzeugte und funktionierende (aber zu große) Video hat übrigens keine Tonspur!
    Bei anderen Divx mit VBR-mp3 war das demuxen dagegen möglich.

    (An Sonderzeichen liegt es nicht; das die Qualität nicht so toll wird, weiss ich auch, es sollen halt ein paar Videos verkleinert werden, da alles auf eine DVD passen soll.)

  • Bearbeite doch Video und Audio getrennt (demuxen eventuell mit AVIMux-GUI). Ich denke die mp3-Spur willst du eh nicht verändern, oder?

    "Diejenigen, die grundlegende Freiheiten aufgeben würden, um geringe vorübergehende Sicherheit zu erkaufen, verdienen weder Freiheit noch Sicherheit."
    Benjamin Franklin (1706-1790)

    Meine Erfahrungen in der Open Source-Welt: blog.bugie.de

  • Wenn es darum geht, das der Player kein DivX3 kann, aber evt. DivX4 (OpenDivX) gibt es die Möglichkeit über ffmpeg (-mstomp4) ohne Verlußt zu wandeln....

    Quote

    ffmpeg that doesn't really have any functionality other than msmpeg4v3 to mpeg4 transcoding (most other codecs are disabled). to use it, you must include -mstomp4 to a regular mpeg4 command-line like:
    ffmpeg -i inputdivx3.avi -vcodec mpeg4 -acodec copy -mstomp4 outputmpeg4.avi

    Besser ist es aber (meine Tests):
    1: das Audio zu demuxen
    2: das Video zu transformieren
    ffmpeg.exe -i inputdivx3.avi -vcodec mpeg4 -an -mstomp4 outputmpeg4.avi
    3: das Audio in das neue Video zu muxen

    so ein gewandeltes Video konnt ein alter Player abspielen, der noch kein DivX3 konnte.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!