5.0 Dolby AC3 nach muxen nur Stereo???

  • Hallo-
    laßt euch von dem Grünschnabel nicht irritieren! Aber jetzt habe ich ein schwieriges Problem:


    Ich hab ne DVD mit XMPEG gerippt. Ein AVI File und ne AC3 Tonspur erzeugt- soweit alles klar. Dann die Sachen mit NANDDUB gemuxt und siehe da: Es ist nur Stereo!! Alles paßt, alles synchron usw...nur wollte ich 5.0 Sound!!
    Wenn ich das AC3 alleine mit PowerDVD anhöre, schaltet mein Soundsystem wie es sich gehört auf Digitalen Ausgang und ich habe Dolby!



    Was mache ich beim Muxen falsch??
    Oder liegt es am Player? Fehlen irgendwelche Treiber/DLL´s


    Mit Windows Player kann ich nie auf Digitalen Ausgang schalten - weiß einer wie das geht?


    Danke

  • Welchen AC3 decoder verwendest du?

    btw: nandub ist schon seehr betagt, VirtualDubMod ist besser.

    Es gibt eine Theorie, die besagt, dass das Universum sofort verschwinden und etwas noch Unerklärlicheres und Bizarres an seine Stelle treten wird, sobald jemand herausfindet, wofür es gut ist und warum es existiert.


    Es gibt eine andere Theorie, die besagt, dass das bereits geschehen ist.

  • Hi-
    keinen AC3 decoder bzw. das mach ich mit DIREKT STREAM COPY bei XMPEG 4.2. Ich denke das File ist o.k. weil ich den Sound ja einzeln in Dolby anhören kann...


    Den VirtualDubMod habe ich, aber ich sehe da gar keine Möglichkeit zu muxen... hab ich ne falsche Version?

  • Ja, schon klar, dass du das AC3 muxt.

    Aber wenn du das auf deinem Computer abspielst, sollte ein decoder das AC3 in abspielbare Daten zurückverwandeln, dass dann deine Lautsprecher ausgeben, oder das Signal zum digi Ausgang schleifen.

    Ich vermute, dass dieser decoderfilter einen Mixdown durchführt und dir nur Stereo zurückgibt.

    Deshalb habe ich gefragt, was du für einen decoder verwendest.

    Es gibt eine Theorie, die besagt, dass das Universum sofort verschwinden und etwas noch Unerklärlicheres und Bizarres an seine Stelle treten wird, sobald jemand herausfindet, wofür es gut ist und warum es existiert.


    Es gibt eine andere Theorie, die besagt, dass das bereits geschehen ist.

  • Beziehungsweise wäre auch interessant, welchen Media-Player du verwendest; der "Media Player Classic" von Gabest hat beispielsweise mittlerweile seinen eigenen AC3-Decoder eingebaut. Ansonsten würden Media-Player beim Abspielen einen DirectShow-Filter zum Decodieren benutzen (denn eine Soundkarte kann ja keine AC3-Daten ausgeben, die müssen vorher decodiert werden - außer du läßt sie per S/P-DIF = Digitalkabel an den Receiver ausgeben).


    Wenn du einen Software-DVD-Player installiert hast (PowerDVD oder WinDVD), könnte deren Decoder benutzt werden, ansonsten wäre der SourceForge AC3Filter zu empfehlen.

  • Also nochmal für die, die nicht genau lesen: ich kann mein AC3 File anhören mit dem PowerDVD!! Es funktioniert alles - ich kann mit meinem SPDIF Ausgang das Soundsystem mit Dolby Digital ansteuern...
    Nur wenn ich den Film mit irgendeinem ***DUB dazumische ist es nur noch Stereo!!!


    Was fehlt....

  • Ja, mit dem PowerDVD spiele ich das AVI ab. Oder mit dem WMP - bei dem weiß ich aber daß es nur Stereo geht...
    Mit dem BSP habe ich es auch schon probiert - auch nur Stereo. Mit den AUDIOAC3 filtern von DOOM9 geht auch nix!


    Wenn ich das AC3 mir PowerDVD hören kann und nach dem muxen nicht mehr, liegts doch am muxen - oder nicht??

  • Nein - im Gegenteil!


    PowerDVD verwendet beim Abspielen von DVDs seinen eigenen AC3-Decoder, der von dir sicherlich passend eingestellt wurde.


    Media-Player (oder auch PowerDVD) verwenden jedoch zum Abspielen von AVIs denjenigen AC3-Decoder, der mit höchster Priorität im DirectShow-System registriert ist. Und den hast du wahrscheinlich noch nicht konfiguriert, wenn du noch nicht mal genau weißt, welcher Filter das für diesen Fall ist.


    Ich würde dir empfehlen, den SourceForge AC3Filter 0.70b zu installieren, und ihn dann so zu konfigurieren, wie du es gern hättest - zum Beispiel mit ProLogic-Downmix-Matrix. Aber konfigurieren musst du. Dafür richtet der AC3Filter Icons im Startmenü und in der Systemsteuerung ein - also behaupte nicht, du kommst nicht an seine Konfiguration heran...


    Trotzdem wirst du noch nachschauen müssen, welcher Filter überhaupt während des Abspielens von AVIs mit AC3-Tonspur verwendet wird. Im BSplayer könnte das besonders einfach gehen - ein Rechtsklick ins laufende Video sollte der erste Schritt dazu sein.

  • Hi- danke... im POWERDVD habe ich es auf SPDIF eingestellt. Das geht an wenn ich nur das AC3 höre! Also funktioniert doch der Filter! Hat doch nix mit dem Filter zu tun...Nur wenn der Videoteil dazukommt gehts nicht mehr...


    Im BSP habe ich sämtlich Filtereinstellungen ausprobiert - da waren 3 verschiedene einzustellen!!


    Diesen AC3 dingsbums 0.70 den Du da vorschlägst kommt mir nicht mehr auf die Platte, nachdem ich letzten Do den Rechner komplett platt machen mußte, nachdem überhaupt kein Ton mehr ging - weder TV-Karte noch DVD noch DIVX! (Dadurch habe ich Mash verpasst- das verzeihe ich niemandem)


    Ach ja: wo ist das Direct-Show dings?

  • Dings?


    "DirectShow" ist eine Schnittstelle, die eine Vielzahl von Filtern (meist Decodern) verwaltet. Ist vergleichbar mit "Video für Windows" und ihren Codecs. Für einen bestimmten Datentyp können mehrere Filter registriert sein, dann wird im Normalfall der Filter verwendet, der von den vorhandenen einen besonders hohen Vorzugswert hat. Da ich nicht weiß, welche du installiert hast, kann ich dir nicht sagen, welcher bei dir verwendet wird, das mußt du selbst herausfinden.


    Eine einfache Möglichkeit wäre: Das AVI in das Programm GSpot öffnen, im unteren Bereich auf "Render" klicken und abschreiben, welchen Render-Pfad für die Tonspur gefunden wurde. GSpot kann auch eine Liste aller DirectShow-Filter ermitteln, die bei dir installiert sind - diese Liste wäre sicher interessant für uns.


    Beim BSPlayer ist das leider nicht so einfach: Wenn ich mit der rechten Maustaste in das laufende Video klicke, und im auftauchenden Menü zu "Eigenschaften" und "Filter" gehe, finde ich bei mir nur den "Morgan StreamSwitcher", aber nicht den tatsächlichen Decoder-Filter. Anscheinend wird hier nur der erste Filter in der Kette gezeigt, und das hilft nicht beim Einstellen. Überhaupt nicht.

  • Hi LigH,


    ich habe genau das selbe prob wie es richi hat.... egal bei welchem divx/xvid mit ac3 nur stereo höre ...


    wenn ich mit power dvd die ungemuxte datei öffne hab ich gewünschtes dolby .... ging ewig lang nicht durch zufall gings letztens bei ner dvd :-) dann auch bei nem xvid nochmal getestet


    filter habe ich alle richtig installiert ....


    jetz hab ich in gspot das xvid mit dem ac3 file geöffnet und bin unten auf render geangen dann kam ein fehler und zwar folgender:
    DirectShow partially succeeded to play file. The actual text of the error or warning is:


    0x00040242: VFW_S_PARTIAL_RENDER - Some of the streams in this movie are in an unsupported format.


    The following combination of filters were used:


    {D:\Movies\Basic\basic xvid.avi} (Video Source)
    {AVI Splitter} (Video Splitter)
    {ffdshow MPEG-4 Video Decoder} (Video Decoder)
    {Video Renderer} (Video Renderer)


    wär hammer wenn du noch nen tip auf lager hättest weil tät endlich mal meine divx mit ac3 in dolby geniesen :-)


    Gruß & Thx - Maista

  • Hi,


    hab dir mal unter gspot dann unter installed codecs/audio die rauskopiert


    und in ner .txt im anhang gespeichert - da stehn alle audio codecs - denke das wolltest du doch sehn oder?!


    Vielen dank & Gruß - Maista

  • Code
    1. DSH 0x2000 AC3Filter Copyright © 2002 by Vigovsky Alexander ac3filter.ax
    2. DSH InterVideo Audio Decoder InterVideo Inc. iviaudio.ax
    3. DSH 0x0050 CyberLink Audio Decoder CyberLink Corp. claud.ax


    WinDVD, PowerDVD und SourceForge AC3Filter - einer von den dreien wird es wohl sein.


    Schau mal bei der "AC3Filter Configuration" im System-Register nach, ob oben rechts (in der Gruppe "Filter merit") die Option "Prefer AC3Filter" gewählt ist, das dürfte Standard sein. In dem Fall wird höchstwahrscheinlich dieser AC3Filter zum Abspielen von AC3 in AVI verwendet.

  • Hi


    habe nachgeschaut und das stand schon auf prefer ac3filter - hat auch nichts geholfen wo ich mal hin und her gewechselt hab dort zw den einstellungen


    übrigens noch was ganz merkwürdig ist wenn ich ein avi über den media player 6.4 öffne dann sagt er mir das er einen codec nicht gefunden hat obwohl ich alle da hab eigentlich und wenn ich mit dem media classic öffne gehts ohne probs


    hilft dir das evlt. noch weiter ?! oder hättest du noch ne andre idee ..könnte ja mein system komplett bereinigen von allen reg einträgen etc und dann neu installiern aber im grunde hab ich ja nichts falsches installiert oder ??!


    ah noch was wenn ich einen divx mit ac3 in power dvd öffne dann springt die audio einstellung von spdif auf 2 lautsprecher und ist gar nicht mehr auswählbar - wenn ich ne dvd bzw den ac3 ton alleine öffne ist dies wohl möglich also sehr unerklärlich für mich ??!


    danke dir vielmals & gruß - maista

  • Zitat von maista

    dann sagt er mir das er einen codec nicht gefunden hat


    Welchen?


    Zitat von maista

    obwohl ich alle da hab eigentlich


    Du hast "alle"? Woher?


    :nein: Etwa aus einem K-Lite- oder Nimo-Codec-Pack? Dann würde mich gar nichts mehr wundern.
    :ja: Oder aus dem GordianKnot Codec-Pack? Gut - das wäre richtig.
    __


    Der neueste Media Player Classic (6.4.7.7+) hat seinen eigenen AC3-Decoder (oder S/P-DIF-Ausgabe). Wäre langsam mal an der Zeit, dir dessen Optionen anzuschauen?!

  • Moin


    der alte media player sagt mir er hat keinen sound codec gefunden - es kommt auch kein sound beim abspielen obwohl ich ja den ac3 codec 0.7 drauf hab!!


    nein das nimo codec pack hab ich auf dem rechner nicht instaalliert - allerhöchstens das guardian codec pack 1.6 und davon halt nur ffdshow, xvid, und ac3, morgan stream switch


    ja und ich weiß auch das der classic player nen eigene ac3 codec hat - wenn ich unter optionen audio dann auf ausgang spdif umschalte dann kommt ärger geknister bei meiner anlage und nicht dolby sound ....


    -> das komische an allem das ich sonst wenn ich das ac3 file alleine abspiele über power dvd ich über spdif out perfekt dolby hören kann -


    Maista

  • Hi,


    danke für deinen tipp.
    hab einmal bisschen rumprobiert -


    also das mit umstellen auf wave out halt leider nichts
    ansonsten habe ich mal den ac3 codec deinstalliert - wenn ich jetzt im media player classic auf spdif out stelle habe ich kein geknister mehr - jedoch kann ich an meiner dolby anlage nicht auf dolby/dts stellen - bleibt auf prologic ...


    Ich glaube ich habe mein Problem jetzt beseitigt !!


    -> Kann Divx mit nem AC3 jetzt abspielen - Dolby kommt bei der Anlage an und zwar mit Win DvD gings jetzt ur plötzlich ...sehr verwunderlich aber dennoch bin ich jetzt froh es endlich geschafft zu haben...


    update 2:
    kann jetz auch divx mit ac3 mitn media player classic abspielen - glaube da war nur auf meinem system der wurm und glaub die neuinstallation des ac3 codec hat das prob im endefekkt gelöst :-)


    was ich mittlerweile gemerkt hab - viele dvds haben auch nur prologic, nur neuere haben dolby oder dts


    ich bendanke mich ganz herzlich für deine hilfe , schönen abend noch - maista