Wireless LAN Router und Windows XP

  • Habe heute den ganzen Abend bei meiner Nichte verbracht. Die hat jetzt ein Notebook mit WLAN Router von Medion (aus'm Aldi).

    Das Ding connected sich per DSL so wie es soll, und bekommt damit eine IP-Adresse zugewiesen. Aber ich kann dieses #+*@* Windows XP nicht dazu überreden, eine Seite im Internet aufzurufen, auch ein Ping auf eine externe Adresse kommt nicht zustande.

    Habe alles so konfiguriert, wie ich es selbst zuhause habe (allerdings habe ich kein XP, sondern W2K):

    WLAN-Router hat die IP 192.168.0.100
    WLAN-Stick im Notebook hat die IP 192.168.0.1

    Standard-Gateway: 192.168.0.100
    DNS: 192.168.0.100

    Verbindung zum Router funktioniert, Konfiguration über Browser ok, am Status kann ich ja sehen, dass er den DSL-Connect bekommt.

    Router-Firewall und XP-Firewall zu Testzwecken komplett deaktiviert, trotzdem komme ich nicht raus.

    Wo kann man da bei XP noch was einstellen?

    Gruß, zisoft

  • Machs mal umgekehrt,
    Router 192.168.0.1
    PeeCee 192.168.0.100

    DNS 192.168.0.1

    Subnetzmaske nicht vergessen 255.255.255.0

    Primäre und sekundäre DNS vom Provider hast du im Router auch eingetragen?

    Gruß Sistenix

  • Quote from Sistenix

    Primäre und sekundäre DNS vom Provider hast du im Router auch eingetragen?

    Subnetz war auch gesetzt: 255.255.255.0

    Primäre und sekundäre DNS-Angaben habe ich vom Provider (Versatel) nicht. Habe ich bei mir zuhause (1&1) allerdings auch nicht eingetragen.

    Wenn ich vom DSL-Modem direkt in den PC gehe, funktioniert alles. Von der Netwerkkarte stehen alle Einstellungen auf automatisch. Muss demnach irgendwo in den Netzwerk-Einstellungen des WLAN-Sticks zu suchen sein.

    Gruß, zisoft

  • Wenn jemand bisher nicht wusste, was Mosquito-Effekte sind, dann aber jetzt :D

    Tja, sieht alles so aus, wie ich das auch jederzeit wieder konfigurieren würde. Und hier bei mir sieht's auch alles so aus.

    XP treibt mich noch zum Wahnsinn.

    Auf jeden Fall danke für Deine Bemühungen.

    Gruß, zisoft

  • Quote from zisoft

    Wenn jemand bisher nicht wusste, was Mosquito-Effekte sind, dann aber jetzt :D

    Ist doch schik, oder? :D

    Wie weit stehen denn die Geräte auseinander? Vielleicht ist das ja des Rätsels Lösung.
    Manchmal hat man ja schon bei geringen Entfernungen Probleme mit WLan.
    Treiber wäre auch noch eine Möglichkeit, eventuell mal die Duplex Einstellungen verändern.
    Oder du besorgst dir eine PCMCIA Karte, die sind unter Umständen ausgereifter.
    Ansonsten bin ich mit meinem Latein auch erst mal am Ende.

    Gruß Sistenix

  • Hallo und guten Morgen :D

    Hat der Router einen eigenen DHCP Server ?
    Wenn ja: schalte den mal an und lasse den PC automatisch per DHCP konfigurieren lassen.

    Hast du evtl. Die SSID verstecken lassen und im PC nicht eingetragen ?
    Hast du den richtigen WEP-Key auf beiden Seiten richtig eingegeben (Schreibfehler ??) (Gilt nur wenn du es überhaupt benutzt)
    Hast du evtl. den Router so konfiguriert, dass er nur bestimmte Mac-Adressen von Wlan-karten akzeptiert. (Richtig eingetragen)

    Welche Übertragungsprotokolle hast du außer TCP/IP noch installiert ?
    Ist der lokale Dienst "DHCP-Client" auf dem PC gestartet ? (Systemsteurerung-->Verwaltung-->Dienste)
    Ist der Dienst "Konfigurationsfreie drahtlose Verbindung" getstartet ? (Nur nötig wenn man alles automatisch konfigurieren lässt)

  • Nach einer weiteren dreistündigen Sitzung heute habe ich's wohl hoffentlich hinbekommen.

    Die Lösung war zunächst mal ein Firmware-Upgrade des Routers, sowas ist ja wohl nicht zu fassen! Wenn ich daran denke, dass das ein Medion-Router von Aldi ist, kann ich mir gut vorstellen, wie viele Leute den gekauft haben.

    Ich habe jetzt DHCP aktiviert, obwohl ich das eigentlich nicht machen wollte, ich arbeite lieber mit fest vergebenen IP-Adressen.

    Einen komischen Effekt hatte ich trotzdem noch. Der Router hat die IP 192.168.0.100. Nach mehreren Neustarts des PCs, um zu testen, ob danach noch alles funktioniert, hatte der PC plötzlich eine IP-Adresse im 196.xx.xx.xx Bereich, damit funktionierte natürlich nichts.

    Der DHCP-Bereich ist auf 192.168.0.100 - 192.168.0.200 konfiguriert, hätte also eigentlich nicht passieren dürfen.

    Naja, ich rühr' jetzt erstmal nichts mehr an, im Moment funktionierts.

    Gruß, zisoft

  • 169.254.x.x? Das ist der von Microsoft reservierte Bereich, wenn eine auf automatische Zuteilung konfigurierte Netzwerkverbindung für eine gewisse Zeit nach dem Start keine Zuteilung erhält, also kein DHCP-Server erreichbar ist. Diese Zone nennt sich APIPA (Automatic Private Internet Protocol Addressing).
    __

    Folgende Adressbereiche werden niemals durch Router in andere Netze weitergeleitet:

    10.0.0.0/24{16} (durch die IANA reserviert für große Intranets)
    127.0.0.0/24 (durch die IANA reserviert für "localhost"-Loopback)
    169.254.0.0/16{16} (durch Microsoft reserviert für Arbeitsgruppen ohne DHCP)
    172.16.0.0/20{12} (durch die IANA reserviert für mittlere Intranets)
    192.168.0.0/16{8} (durch die IANA reserviert für kleinere Intranets)

    Die Zahl x.x.x.x/X{Y} gibt die Anzahl der Bits für die Subnetzmaske der Reservierung an; es steht aber jedem frei, einen kleineren Bereich {Y: empfohlene Subnetzgröße} für die tatsächlichen Sub-Subnetze festzulegen.

    Hinweis: "localhost" ist landläufig eigentlich nur als 127.0.0.1 bekannt. Dennoch ist tatsächlich der gesamte Bereich (127.x.x.x) als "Loopback" (Weiterleitung auf die öffentliche IP-Adresse) reserviert.
    __

    So was blödes, dass ich den Beitrag erst jetzt bemerkt hab. Ich hoffe, zu dem Thema kann ich noch was beitragen...

  • Quote from LigH

    169.254.x.x? Das ist der von Microsoft reservierte Bereich, wenn eine auf automatische Zuteilung konfigurierte Netzwerkverbindung für eine gewisse Zeit nach dem Start keine Zuteilung erhält, also kein DHCP-Server erreichbar ist. Diese Zone nennt sich APIPA (Automatic Private Internet Protocol Addressing).

    Das könnte durchaus hinkommen. Zuerst hatte der Adapter nach dem Start die IP 0.0.0.0, also noch keine Zuteilung vom DHCP. Ob's danach dann 169 oder 196 war, habe ich nicht so genau beobachtet. Guter Hinweis!

    Gruß, zisoft

  • Noch eins: Der Router darf natürlich nicht eine Adresse haben, die innerhalb des DHCP-Adresspools liegt.

    In deinem Beispiel hast du dem DHCP-Server des Routers erlaubt, unter anderem auch die *.100 zu vergeben, obwohl sein eigener Ethernetanschluss bereits die *.100 hatte - das gibt einen Adresskonflikt. Beim zweiten Versuch hat er deshalb wahrscheinlich mit der nächsten Adresse aus dem Pool weiter gemacht, da klappte es dann.

  • Das ist mir auch aufgefallen, aber das ist die Standard-Konfiguration des Routers. Wenn ich das nächste mal vor Ort bin, werde das mal ändern.

    Gruß, zisoft

  • Machen wir's doch noch mal ausführlich für alle, die sich etwas für's IP-Rechnen interessieren ("Wetten dass" ist grad langweilig, Mike Krüger und Thomas Gottschalk - beide Supernasen - im Dialog):

    "Kleine-Intranet-Zone" ist laut IANA "192.168.0.0/16" - also sämtliche Pakete mit Adressen im Bereich 192.168.x.x werden vom Router nicht durchgeleitet.

    Die erste vergebbare Adresse bei Adressbereich "192.168.0.0/8" ("/8" = "tatsächliche Subnetzmaske 255.255.255.0") ist die 192.168.0.1; das ist also Rechner Nummer 1 im Subnetz 0 (man kann also zum Beispiel 256 Subnetze zu je 254 Rechnern einrichten; oder anders, je nach dem, wo das am weitesten links stehende Bit mit dem Wert 0 in der Subnetzmaske liegt...).

    192.168.0.0 ist die Basisadresse des Subnetzes 0, keine echte IP-Adresse. 192.168.0.255 wäre Broadcast- (Rundruf-) Adresse für das Subnetz 0 (wenn z.B. ein PC einen DHCP-Server in Subnetz 0 sucht, fragt er an diese Adresse).

    Ob man nun die unteren Rechnernummern für "wichtiges" reservieren möchte (z.B. 1 .. 9) oder höhere Nummern (z.B. 250 .. 254) oder welche aus der Mitte, ist vorwiegend Geschmackssache, sowie vielleicht abhängig von der Anzahl der Geräte, die man im Netzwerk verwalten möchte. Aber es ist schon ratsam, sich den DHCP-Adresspool so auszusuchen, dass man sofort an der Nummer erkennt: Diese müsste eine feste Nummer sein, jene eine zugeteilte.

  • LigH, Du hast Recht, die Adresse lautet 169.254.x.x

    Sieht wohl danach aus, dass der DHCP-Server seinen Dienst nicht richtig erfüllt.

    Gruß, zisoft

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!