MeGui x64 Fehlermeldung Index

  • leider habe ich bei MeGui 2215 x64 die Fehlermeldung, dass der Index im Bereich außerhalb lag.


    Was hast du denn gemacht und poste bitte das Log.


    Wie kann ich den automatisch mit dem Öffnen einer *.m2ts Datei starten? Das ging bei meiner alten x86 Version immer.


    Dann muss die "alte Version" in der Tat schon älter sein. M2TS sollten nicht im AviSynth Script Creator mit DirectShowSource geöffnet werden.

  • Hallo nochmal,


    also, das Encoding funktioniert eine ganze Weile, bis es irgendwann abstürzt.
    Im Log steht:
    --[Error] [29.11.2012 20:50:32] Process exits with error: 0xC0000005 STATUS_ACCESS_VIOLATION (-1073741819)


    Was kann das sein?


    Viele Grüße

  • OK, sorry, hier mal komplette Log-File.
    Der selbe Stream funktioniert übrigens mit dem alten 32-Bit MeGui.


    [Error] Log
    -[Information] Versions
    --[Information] [29.11.2012 19:39:34] MeGUI Version : 2220 x64
    --[Information] [29.11.2012 19:39:34] Operating System: Windows 7 Enterprise Edition x64 (6.1.0.7600)
    --[Information] [29.11.2012 19:39:34] .Net Framework: 3.5 SP1 (3.5.30729.4926)
    --[Information] [29.11.2012 19:39:34] AviSynth: 2.5.8.5 (16.04.2010 18:06:58)
    --[Information] [29.11.2012 19:39:34] AvisynthWrapper: 10.04.2010 11:58:26
    --[Information] [29.11.2012 19:39:34] Haali Matroska Muxer: 1.10.175.0 (19.05.2010 20:59:40)
    --[Information] [29.11.2012 19:39:34] Haali DSS2: 19.05.2010 20:57:26
    --[Information] [29.11.2012 19:39:34] ICSharpCode.SharpZipLib: 0.85.5.452 (07.08.2008 20:31:12)
    --[Information] [29.11.2012 19:39:34] LinqBridge: 1.0.0.0 (28.05.2009 01:24:34)
    --[Information] [29.11.2012 19:39:34] MediaInfo: 0.7.61.0 (21.10.2012 16:29:04)
    --[Information] [29.11.2012 19:39:34] MediaInfoWrapper: 0.7.53.0 (23.08.2012 14:33:43)
    --[Information] [29.11.2012 19:39:34] MessageBoxExLib: 1.0.2218.28317 (19.12.2008 20:53:04)
    --[Information] [29.11.2012 19:39:34] SevenZipSharp: 0.64.3890.29348 (02.01.2011 10:59:32)
    --[Information] [29.11.2012 19:39:34] 7z: 9.20 (18.11.2010 16:21:50)
    -[Information] Update detection
    --[Information] [29.11.2012 19:39:34] Connecting to server: http://megui.org/auto/
    --[Information] [29.11.2012 19:39:35] All files are up to date
    -[Information] AutoEncode job generation log
    --[Information] [29.11.2012 19:40:41] Projected Bitrate : 10000kbps
    --[Information] [29.11.2012 19:40:41] Split Size : null
    --[Information] Eliminating duplicate filenames
    ---[Information] [29.11.2012 19:40:41] Video output file: C:\Users\...............................
    ---[Information] [29.11.2012 19:40:41] Muxed output file: C:\Users\..................................mkv
    -[Information] Log for job19 (video, .................avs -> )
    --[Information] [29.11.2012 19:40:45] Started handling job
    --[Information] [29.11.2012 19:40:45] Preprocessing
    ---[Information] Bitrate calculation for video
    ----[Information] [29.11.2012 19:40:46] Desired size after subtracting audio: 7457093 KBs
    ----[Information] [29.11.2012 19:40:46] Calculated desired bitrate: 10596 kbit/s
    --[Information] [29.11.2012 19:40:46] Avisynth input script
    ---[NoImage] LoadPlugin("C:\DVD\MeGuix64\tools\avs\directshowsource.dll")
    ---[NoImage] DirectShowSource("C:\Users\................................m2ts", fps=25.000, audio=false, convertfps=true).AssumeFPS(25,1)
    ---[NoImage] #deinterlace
    ---[NoImage] #crop
    ---[NoImage] #resize
    ---[NoImage] #denoise
    ---[NoImage] ConvertToYV12()
    --[Information] [29.11.2012 19:40:47] Job commandline: "C:\DVD\MeGuix64\tools\x264\x264_64.exe" --pass 1 --bitrate 10596 --stats "C:\Users\........stats" --sar 1:1 --output NUL "C:\Users\....................................avs"
    --[Information] [29.11.2012 19:40:47] Encoding started
    --[Information] [29.11.2012 20:44:24] Standard output stream
    --[Information] [29.11.2012 20:44:24] Standard error stream
    ---[NoImage] avs [info]: 1920x1080p 1:1 @ 25/1 fps (cfr)
    ---[NoImage] x264 [info]: using SAR=1/1
    ---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
    ---[NoImage] x264 [info]: profile Main, level 4.1
    ---[NoImage]
    ---[NoImage] x264 [info]: frame I:1938 Avg QP:11.35 size:173315
    ---[NoImage] x264 [info]: frame P:100361 Avg QP:14.19 size: 59667
    ---[NoImage] x264 [info]: frame B:41821 Avg QP:15.53 size: 28411
    ---[NoImage] x264 [info]: consecutive B-frames: 49.7% 33.4% 4.0% 12.8%
    ---[NoImage] x264 [info]: mb I I16..4: 52.8% 0.0% 47.2%
    ---[NoImage] x264 [info]: mb P I16..4: 32.2% 0.0% 0.0% P16..4: 39.2% 0.0% 0.0% 0.0% 0.0% skip:28.6%
    ---[NoImage] x264 [info]: mb B I16..4: 8.2% 0.0% 0.0% B16..8: 25.8% 0.0% 0.0% direct:21.6% skip:44.4% L0:31.3% L1:39.7% BI:29.0%
    ---[NoImage] x264 [info]: final ratefactor: 15.84
    ---[NoImage] x264 [info]: coded y,uvDC,uvAC intra: 74.2% 89.4% 77.2% inter: 26.2% 28.5% 5.7%
    ---[NoImage] x264 [info]: i16 v,h,dc,p: 30% 18% 40% 12%
    ---[NoImage] x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 20% 18% 23% 4% 10% 6% 6% 6% 7%
    ---[NoImage] x264 [info]: i8c dc,h,v,p: 64% 15% 17% 4%
    ---[NoImage] x264 [info]: Weighted P-Frames: Y:1.0% UV:0.5%
    ---[NoImage] x264 [info]: kb/s:10425.06
    ---[NoImage] encoded 144120 frames, 37.76 fps, 10425.06 kb/s
    --[Information] [29.11.2012 20:44:24] Postprocessing
    ---[Information] Deleting intermediate files
    --[Information] [29.11.2012 20:44:24] Job completed
    -[Error] Log for job20 (video, ..............avs -> ...............264)
    --[Information] [29.11.2012 20:44:24] Started handling job
    --[Information] [29.11.2012 20:44:24] Preprocessing
    --[Information] [29.11.2012 20:44:24] Avisynth input script
    ---[NoImage] LoadPlugin("C:\DVD\MeGuix64\tools\avs\directshowsource.dll")
    ---[NoImage] DirectShowSource("C:\Users\....................................m2ts", fps=25.000, audio=false, convertfps=true).AssumeFPS(25,1)
    ---[NoImage] #deinterlace
    ---[NoImage] #crop
    ---[NoImage] #resize
    ---[NoImage] #denoise
    ---[NoImage] ConvertToYV12()
    --[Information] [29.11.2012 20:44:25] Job commandline: "C:\DVD\MeGuix64\tools\x264\x264_64.exe" --pass 2 --bitrate 10596 --stats "C:\Users\..................stats" --sar 1:1 --output "C:\Users\..............................264" "C:\Users\....................................avs"
    --[Information] [29.11.2012 20:44:26] Encoding started
    --[Error] [29.11.2012 20:50:32] Process exits with error: 0xC0000005 STATUS_ACCESS_VIOLATION (-1073741819)
    --[Information] [29.11.2012 20:50:32] Standard output stream
    --[Information] [29.11.2012 20:50:32] Standard error stream
    ---[NoImage] avs [info]: 1920x1080p 1:1 @ 25/1 fps (cfr)
    ---[NoImage] x264 [info]: using SAR=1/1
    ---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
    ---[NoImage] x264 [info]: profile High, level 4.0
    --[Information] [29.11.2012 20:50:32] Job completed
    -[Information] [29.11.2012 20:50:36] User aborted shutdown

  • --[Warning] [21.12.2012 16:06:30] Haali Matroska Muxer: not installed
    --[Warning] [21.12.2012 16:06:30] Haali DSS2: not installed
    Versuch mal den Haali Media Splitter zu installieren. Bei einigen Operationen benötigt FFMSIndex() diesen Splitter.


    Ansonsten der Rat die 32bit MeGUI Variante zu benutzen. Die 64bit Version ist bedingt durch die instabile AviSynth x64 Version, fehlende Plugins, ... nicht unbedingt zu empfehlen.

  • Oder, wie wir immer und immer und immer wieder wiederholen: M2TS erst in MKV konvertieren.


    Ich weiß übrigens nicht, warum du behauptest, du würdest "mit DirectShow encodieren": Offenbar kommt ffindex zum Einsatz, also wird FFmpegSource2 als Quellfilter verwendet, nicht DirectShowSource. Und FFMS2 kann M2TS nur mit Hilfe des Haali Media Splitter lesen. MKV könnte es auch alleine verarbeiten, ohne fremde Hilfe.

  • LigH: Sorry, hatte mal das Log von dem FFindex doppelt gepostet und einmal gelöscht. jetzt wurden aber auch beide Postings gelöscht.


    Also, habe Haali installiert, aber leider doch wieder beim ffindex ein Fehler aufgetreten. Hier das Logfile. Ich versuche es dann nochmal mit MKV als Quelle, sonst muss ich doch wieder auf 32Bit gehen.


    Einmal editiert, zuletzt von LigH () aus folgendem Grund: CODE um das Log

  • Deine Löschung hätte ich auch rückgängig machen können... Nun ja, es bleibt bei den Empfehlungen: Grundsätzlich eher AviSynth 32-bit, auch bei x264 64-bit. Und besser erst mal MKV, das ist ein vorteilhafter Kontainer, der durch eigene Index-Tabellen die zuverlässige Verarbeitung unterstützt.

  • Also, selbst mit MKV stürzt mir die Sache mit DirectShow ab.
    Noch ein letzter Versuch MKV mit dem One Click Decoder und ich wechsel doch wieder zu 32 Bit.
    Ist denn abzusehen wann sich bei 64Bit Avisynth mal was tut?

  • Update und Lösung!
    Jetzt hatte ich auch noch Probleme mit der 32Bit Version. Und komischerweise ist immer erst nach ein paar Stunden MeGUI abgeschmiert.
    So kam ich darauf, dass es womöglich an der Hardware liegt.
    Und siehe da, im BIOS war mein System noch übertaktet. Zwar nicht viel, aber durch schlechte Wärmeleitpaste hatte sich doch die CPU doch etwas zu stark erhitzt und ist dann abgestürzt.
    Jetzt läuft ALLES, auch in 64 Bit!
    Danke nochmals für die Hilfestellungen. Habe einiges dazugelernt.