Kodi auf Raspbian spielt das Video nicht ab

  • Habe hier Kodi 17.3 aktuelle Version auf dem Raspberry Pi 3 OS Raspbian. Allerdings spielt er folgendes Video nicht ab


    , ich klicke es an Doppelklick ganz normal aber es passiert nichts. Betrifft einige, wird von einer Externen FP 1TB gelesen.


    avplay (Libav, ffmpeg-Fork) hat damit keine Probleme


    Woran liegts?


    Edit: Ok avplay auch nicht wirklich, Audio wird nicht abgespielt und avplay stürzt ab
    Dateien fehlerhaft?

  • Hat leider nichts gebracht. Letzte verfügbare mkvmerge Version auf Raspbian ist aber auch 7.3


    die Datei liegt jetzt auf der SD/Home-Ordner von Raspbian

  • Und was gibt denn Kodi im Log aus?


    Wo finde ich das?, unter "Event Log" finde ich nichts.


    Auch den reinen Videostream in einer MKV spielt Kodi nicht ab, avplay schon.


    Ich habe mal jetzt die Audiospur.ac3 in eine mp3 gewandelt

    Code
    1. avconv -i video.mkv -vn -acodec copy audiospur.ac3avconv -i audiospur.ac3 output.mp3


    Das ganze dann wieder mit mkvmergeGUI muxed
    Kein Erfolg beim Abspielen
    Jetzt mal in eine MP4 zu muxen/kopiert

    Code
    1. avconv -i new-muxed-video.mkv -vcodec copy -acodec copy output.mp4


    Auch kein vernünftiges Abspielen, Kodi gar nicht und avplay nur die Videospur und den Audiostream ein kleines bisschen bis gar nicht.

  • Wenn ich mich nicht sehr täusche bringt der Raspberry für AVC kein Hardwaredecoder mit, daher muss er das in Software erledigen... dies klappt nicht immer und funktioniert nur bei geringen Datenraten. Das selbe Problem gibt es bei HEVC

     MacBookPro 15" 2017 | 4 x 3,1 Ghz | 16 GB Ram | 1TB SSD NVME |

    Einmal editiert, zuletzt von Massaguana ()

  • Unter Linux-Derivaten hängt die Unterstützung von Hardwarebeschleunigung sicherlich von der Verfügbarkeit von Kernelmodulen ab. In einem OS speziell für Media-Playback sind sie sicher integriert, auf einem Allround-System vielleicht nicht ohne ausdrückliche Installation...